aboutsummaryrefslogtreecommitdiff
path: root/security/pear-Auth
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2005-03-15 20:09:37 +0000
committerThierry Thomas <thierry@FreeBSD.org>2005-03-15 20:09:37 +0000
commit7c704a00e3ba25ecddff7c1c8afd11b101976568 (patch)
treee4b4c21cefa97470662a60c1ac8cabf75a0a9f64 /security/pear-Auth
parent68f63116a6207657dc29bea88f418793e15164dc (diff)
downloadports-7c704a00e3ba25ecddff7c1c8afd11b101976568.tar.gz
ports-7c704a00e3ba25ecddff7c1c8afd11b101976568.zip
+ fix CATEGORIES
+ take maintainership + update COMMENT + add PEAR package dependencies and use OPTIONS + replace @version@ strings + update pkg-descr PR: ports/78862 Submitted by: Antônio Carlos Venâncio Júnior
Notes
Notes: svn path=/head/; revision=131332
Diffstat (limited to 'security/pear-Auth')
-rw-r--r--security/pear-Auth/Makefile68
-rw-r--r--security/pear-Auth/pkg-descr3
2 files changed, 50 insertions, 21 deletions
diff --git a/security/pear-Auth/Makefile b/security/pear-Auth/Makefile
index 157a9c3771a0..c2cf5db3308f 100644
--- a/security/pear-Auth/Makefile
+++ b/security/pear-Auth/Makefile
@@ -7,38 +7,66 @@
PORTNAME= Auth
PORTVERSION= 1.2.3
-CATEGORIES= security www pear
+PORTREVISION= 1
+CATEGORIES= security pear
-MAINTAINER= ports@FreeBSD.org
-COMMENT= PEAR authentication methods
+MAINTAINER= antonio@php.net
+COMMENT= PEAR class for creating an authentication system
BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
RUN_DEPENDS= ${BUILD_DEPENDS}
+LATEST_LINK= pear-Auth
+OPTIONS= PEAR_FILE_PASSWD "PEAR::File_Passwd support" off \
+ PEAR_NET_POP3 "PEAR::Net_POP3 support" off \
+ PEAR_DB "PEAR::DB support" off \
+ PEAR_MDB "PEAR::MDB support" off \
+ PEAR_AUTH_RADIUS "PEAR::Auth_RADIUS support" off \
+ PEAR_FILE_SMBPASSWD "PEAR::File_SMBPasswd support" off
+
+USE_REINPLACE= yes
+
CATEGORY= Auth
-FILES= Auth.php Container.php Container/DB.php Container/File.php \
- Container/IMAP.php Container/LDAP.php Container/MDB.php \
- Container/POP3.php Container/RADIUS.php Container/SMBPasswd.php \
- Container/SOAP.php Container/vpopmail.php
-TESTS= DBContainer.php FileContainer.php POP3Container.php \
- POP3aContainer.php TestAuthContainer.php \
- auth_container_db_options.php auth_container_file_options.php \
- auth_container_pop3_options.php auth_container_pop3a_options.php \
- tests.php users
-
-do-install-tests-msg: .USE
- @${ECHO_MSG} " (These tests require PHPUnit - see"
- @${ECHO_MSG} " <http://pear.php.net/package/PHPUnit/>;)."
+FILES= Auth.php Auth/Auth.php Container.php Container/DB.php \
+ Container/File.php Container/IMAP.php Container/POP3.php \
+ Container/LDAP.php Container/MDB.php Container/RADIUS.php \
+ Container/SMBPasswd.php Container/SOAP.php Container/vpopmail.php
+TESTS= auth_container_db_options.php DBContainer.php \
+ auth_container_file_options.php FileContainer.php \
+ auth_container_pop3_options.php POP3Container.php \
+ auth_container_pop3a_options.php POP3aContainer.php \
+ TestAuthContainer.php users tests.php
+DOCS= README.Auth
+_DOCSDIR= .
+
+post-extract:
+ @${REINPLACE_CMD} -e "s|@version@|${PORTVERSION}|" ${WRKSRC}/Auth.php
.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
-.if exists(${PEARDIR}/DB.php)
-WITH_DB= yes
+.if defined(WITH_PEAR_FILE_PASSWD)
+RUN_DEPENDS+= ${PEARDIR}/File/Passwd.php:${PORTSDIR}/security/pear-File_Passwd
.endif
-.if defined(WITH_DB)
+.if defined(WITH_PEAR_NET_POP3)
+RUN_DEPENDS+= ${PEARDIR}/Net/POP3.php:${PORTSDIR}/net/pear-Net_POP3
+.endif
+
+.if defined(WITH_PEAR_DB)
RUN_DEPENDS+= ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB
.endif
+.if defined(WITH_PEAR_MDB)
+RUN_DEPENDS+= ${PEARDIR}/MDB.php:${PORTSDIR}/databases/pear-MDB
+.endif
+
+.if defined(WITH_PEAR_AUTH_RADIUS)
+RUN_DEPENDS+= ${PEARDIR}/Auth/RADIUS.php:${PORTSDIR}/net/pear-Auth_RADIUS
+.endif
+
+.if defined(WITH_PEAR_FILE_SMBPASSWD)
+RUN_DEPENDS+= ${PEARDIR}/File/SMBPasswd.php:${PORTSDIR}/security/pear-File_SMBPasswd
+.endif
+
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
.include <bsd.port.post.mk>
diff --git a/security/pear-Auth/pkg-descr b/security/pear-Auth/pkg-descr
index 9e68af144e00..c3f17bcaac25 100644
--- a/security/pear-Auth/pkg-descr
+++ b/security/pear-Auth/pkg-descr
@@ -6,6 +6,7 @@ the login data:
* All databases supported by the PEAR database layer
* All databases supported by the MDB database layer
+* All databases supported by the MDB2 database layer
* Plaintext files
* LDAP servers
* POP3 servers
@@ -13,6 +14,6 @@ the login data:
* vpopmail accounts
* RADIUS
* SAMBA password files
-* SOAP.
+* SOAP
WWW: http://pear.php.net/package/Auth/