aboutsummaryrefslogtreecommitdiff
path: root/security/phpdeadlock
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2014-06-01 12:39:59 +0000
committerStefan Eßer <se@FreeBSD.org>2014-06-01 12:39:59 +0000
commit02625d7d3b1d8564b24d1527e7760cc4fa57522b (patch)
tree25f5f8551f6df6a16086bf8c197b490989803ac0 /security/phpdeadlock
parent1667bf0efd22b45e533eff8ab7a962cfb1cace05 (diff)
downloadports-02625d7d3b1d8564b24d1527e7760cc4fa57522b.tar.gz
ports-02625d7d3b1d8564b24d1527e7760cc4fa57522b.zip
Add stage support.
Approved by: antoine (mentor)
Notes
Notes: svn path=/head/; revision=356110
Diffstat (limited to 'security/phpdeadlock')
-rw-r--r--security/phpdeadlock/Makefile25
-rw-r--r--security/phpdeadlock/pkg-plist4
2 files changed, 12 insertions, 17 deletions
diff --git a/security/phpdeadlock/Makefile b/security/phpdeadlock/Makefile
index c1110784b239..1f641bf0ebf2 100644
--- a/security/phpdeadlock/Makefile
+++ b/security/phpdeadlock/Makefile
@@ -11,8 +11,10 @@ DISTNAME= Deadlock-${PORTVERSION}-Stable
MAINTAINER= ports@FreeBSD.org
COMMENT= Web-based user authentication/password protection system
-WRKSRC= ${WRKDIR}/Deadlock-1.01
-DLURL?= ${PORTNAME}
+LICENSE= GPLv2
+
+WRKSRC= ${WRKDIR}/Deadlock-1.01
+DLURL?= ${PORTNAME}
DLDIR= www/${DLURL}
PORTDOCS= CHANGES.txt COPYING.txt UPGRADE.txt
@@ -23,8 +25,8 @@ NO_BUILD= yes
SUB_FILES= pkg-message
SUB_LIST= DLURL=${DLURL} DLDIR=${DLDIR}
+PLIST_SUB= WWWOWN=${WWWOWN} WWWGRP=${WWWGRP}
-NO_STAGE= yes
post-extract:
@cd ${WRKDIR} && ${MV} "Deadlock v1.01" Deadlock-1.01
@@ -32,19 +34,8 @@ post-patch:
@${FIND} ${WRKSRC} -name \*.orig -exec ${RM} {} \;
do-install:
- @cd ${WRKSRC}/deadlock && ${COPYTREE_SHARE} . ${WWWDIR}
- @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${WWWDIR}
- @${ECHO_CMD} '@exec ${CHOWN} -R ${WWWOWN}:${WWWGRP} \
- ${WWWDIR:S|^${PREFIX}/|%D/|}' >> ${TMPPLIST}
- @${CHMOD} 777 ${WWWDIR}/db_config.php
- @${ECHO_CMD} '@exec ${CHMOD} 777 \
- ${WWWDIR:S|^${PREFIX}/|%D/|}/db_config.php' >> ${TMPPLIST}
-
-post-install:
-.if !defined(NOPORTDOCS)
- @${INSTALL} -d ${DOCSDIR}
- @cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
-.endif
- @${CAT} ${PKGMESSAGE}
+ @cd ${WRKSRC}/deadlock && ${COPYTREE_SHARE} . ${STAGEDIR}${WWWDIR}
+ @${INSTALL} -d ${STAGEDIR}${DOCSDIR}
+ @cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/security/phpdeadlock/pkg-plist b/security/phpdeadlock/pkg-plist
index 38a56299b85d..159323e2206b 100644
--- a/security/phpdeadlock/pkg-plist
+++ b/security/phpdeadlock/pkg-plist
@@ -1,3 +1,5 @@
+@owner %%WWWOWN%%
+@group %%WWWGRP%%
%%WWWDIR%%/.htaccess
%%WWWDIR%%/admin/.htaccess
%%WWWDIR%%/admin/bulkemail.php
@@ -13,7 +15,9 @@
%%WWWDIR%%/admin/userlist.php
%%WWWDIR%%/admin/userrequests.php
%%WWWDIR%%/admin/validateuser.php
+@mode 777
%%WWWDIR%%/db_config.php
+@mode
%%WWWDIR%%/fckeditor/_documentation.html
%%WWWDIR%%/fckeditor/_whatsnew.html
%%WWWDIR%%/fckeditor/editor/css/behaviors/disablehandles.htc