aboutsummaryrefslogtreecommitdiff
path: root/security/pks
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2001-01-15 05:26:00 +0000
committerKris Kennaway <kris@FreeBSD.org>2001-01-15 05:26:00 +0000
commit93cbcc1bec732ef8a54680794c824f8366a2517f (patch)
tree317866bc3e27b0b72622ae7de47a2c62048a7540 /security/pks
parent04665ddc392f7965fe98a2d34c10ac90bbe3e0a7 (diff)
downloadports-93cbcc1bec732ef8a54680794c824f8366a2517f.tar.gz
ports-93cbcc1bec732ef8a54680794c824f8366a2517f.zip
Fix a buglet and finish pointing the config file at ${PREFIX}/etc, not
/etc as in NetBSD
Notes
Notes: svn path=/head/; revision=37211
Diffstat (limited to 'security/pks')
-rw-r--r--security/pks/Makefile2
-rw-r--r--security/pks/files/pksd.sh12
2 files changed, 7 insertions, 7 deletions
diff --git a/security/pks/Makefile b/security/pks/Makefile
index 2adaf529f424..e3dff0ab3eb4 100644
--- a/security/pks/Makefile
+++ b/security/pks/Makefile
@@ -25,7 +25,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --datadir=${PREFIX}/share/pks --localstatedir=/var/pks \
--sysconfdir=${PREFIX}/share/examples \
--libdir=${LOCALBASE}/lib
-CONFIGURE_ENV= LDFLAGS=-L${LOCALBASE}/lib
+MAKE_ENV+= LDFLAGS=-L${LOCALBASE}/lib
MAN5= pksd.conf.5
MAN8= pks-intro.8 pksclient.8 pksd.8 pksdctl.8
diff --git a/security/pks/files/pksd.sh b/security/pks/files/pksd.sh
index bf8ce4d6c38b..d78041b8fe5f 100644
--- a/security/pks/files/pksd.sh
+++ b/security/pks/files/pksd.sh
@@ -10,11 +10,11 @@ command=${1:-start}
case ${command} in
start)
- if [ ! -f /etc/${name}.conf ]
+ if [ ! -f @PREFIX@/etc/${name}.conf ]
then
exit 0
else
- dbdir=`awk '/db_dir/ { print $2 }' < /etc/${name}.conf`
+ dbdir=`awk '/db_dir/ { print $2 }' < @PREFIX@/etc/${name}.conf`
fi
if [ ! -f ${dbdir}/keydb000 -a -x @PREFIX@/bin/pksclient ]
then
@@ -23,17 +23,17 @@ start)
if [ -x @PREFIX@/bin/${name} -a -x @PREFIX@/bin/pks-queue-run.sh ]
then
echo "Starting ${name}."
- @PREFIX@/bin/${name} /etc/${name}.conf &
+ @PREFIX@/bin/${name} @PREFIX@/etc/${name}.conf &
sleep 5
- @PREFIX@/bin/pks-queue-run.sh /etc/${name}.conf
+ @PREFIX@/bin/pks-queue-run.sh @PREFIX@/etc/${name}.conf
fi
;;
stop)
- if [ ! -f /etc/${name}.conf ]
+ if [ ! -f @PREFIX@/etc/${name}.conf ]
then
exit 0
else
- socket=`awk '/socket_name/ { print $2 }' < /etc/${name}.conf`
+ socket=`awk '/socket_name/ { print $2 }' < @PREFIX@/etc/${name}.conf`
fi
if [ -x @PREFIX@/bin/${name}ctl -a -S ${socket} ]
then