aboutsummaryrefslogtreecommitdiff
path: root/security/polarssl
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2009-12-12 12:32:58 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2009-12-12 12:32:58 +0000
commitaff5d67bbee3476c8938388a1f58bfb9e35da8fa (patch)
tree98618ca3d3101e3193530738d00043a33438e9c3 /security/polarssl
parent115a02a258489107cd3481ac5c5651207614531b (diff)
downloadports-aff5d67bbee3476c8938388a1f58bfb9e35da8fa.tar.gz
ports-aff5d67bbee3476c8938388a1f58bfb9e35da8fa.zip
PolarSSL is a light-weight open source cryptographic and SSL/TLS library
written in C. PolarSSL is written with embedded systems in mind and has been ported on a number of architectures, including ARM, PowerPC, MIPS and Motorola 68000. Features include: * Small memory footprint * Clean and simple API for integration * Loose coupling of cryptographic code. * Symmetric encryption algorithms: AES, Triple-DES, DES, ARC4, Camellia, XTEA * Hash algorithms: MD2, MD4, MD5, SHA-1, SHA-224, SHA-256, SHA-384, SHA-512 * HAVEGE random number generator * RSA with PKCS#1 v1.5 padding * SSL version 3 and TLS version 1 client support * X.509 certificate and CRL reading from memory or disk in PEM and DER formats * Over 900 regression and code coverage tests * Example applications LICENSE: GPL2 WWW: http://polarssl.org/
Notes
Notes: svn path=/head/; revision=245609
Diffstat (limited to 'security/polarssl')
-rw-r--r--security/polarssl/Makefile29
-rw-r--r--security/polarssl/distinfo3
-rw-r--r--security/polarssl/files/patch-Makefile11
-rw-r--r--security/polarssl/pkg-descr21
-rw-r--r--security/polarssl/pkg-plist47
5 files changed, 111 insertions, 0 deletions
diff --git a/security/polarssl/Makefile b/security/polarssl/Makefile
new file mode 100644
index 000000000000..b7a111fb756a
--- /dev/null
+++ b/security/polarssl/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: polarssl
+# Date created: 10 Dec 2009
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= polarssl
+PORTVERSION= 0.12.1
+DISTVERSIONSUFFIX= -gpl
+CATEGORIES= security devel
+MASTER_SITES= http://polarssl.org/code/download/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= Open Source embedded SSL/TLS cryptographic library
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+PORTDOCS= ChangeLog LICENSE README
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for i in ${PORTDOCS}
+ ${INSTALL_MAN} ${WRKSRC}/${i} ${DOCSDIR}/
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/polarssl/distinfo b/security/polarssl/distinfo
new file mode 100644
index 000000000000..7e3063cf9c99
--- /dev/null
+++ b/security/polarssl/distinfo
@@ -0,0 +1,3 @@
+MD5 (polarssl-0.12.1-gpl.tgz) = 08bc85a19bbe65493076b9968b421e80
+SHA256 (polarssl-0.12.1-gpl.tgz) = 4bd79758b22e04b653e3e825847e3c72b4aab51685fa2acdb6fe00431c8bb8f3
+SIZE (polarssl-0.12.1-gpl.tgz) = 335160
diff --git a/security/polarssl/files/patch-Makefile b/security/polarssl/files/patch-Makefile
new file mode 100644
index 000000000000..aef523ea9486
--- /dev/null
+++ b/security/polarssl/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile.orig 2009-07-28 22:29:34.000000000 +0200
++++ Makefile 2009-12-10 13:10:07.000000000 +0100
+@@ -7,7 +7,7 @@
+ all:
+ cd library && make all && cd ..
+ cd programs && make all && cd ..
+- cd tests && make all && cd ..
++# cd tests && make all && cd ..
+
+ install:
+ mkdir -p $(DESTDIR)/include/polarssl
diff --git a/security/polarssl/pkg-descr b/security/polarssl/pkg-descr
new file mode 100644
index 000000000000..5016535825c7
--- /dev/null
+++ b/security/polarssl/pkg-descr
@@ -0,0 +1,21 @@
+PolarSSL is a light-weight open source cryptographic and SSL/TLS library
+written in C. PolarSSL is written with embedded systems in mind and has
+been ported on a number of architectures, including ARM, PowerPC, MIPS
+and Motorola 68000.
+
+Features include:
+ * Small memory footprint
+ * Clean and simple API for integration
+ * Loose coupling of cryptographic code.
+ * Symmetric encryption algorithms: AES, Triple-DES, DES, ARC4, Camellia, XTEA
+ * Hash algorithms: MD2, MD4, MD5, SHA-1, SHA-224, SHA-256, SHA-384, SHA-512
+ * HAVEGE random number generator
+ * RSA with PKCS#1 v1.5 padding
+ * SSL version 3 and TLS version 1 client support
+ * X.509 certificate and CRL reading from memory or disk in PEM and DER formats
+ * Over 900 regression and code coverage tests
+ * Example applications
+
+LICENSE: GPL2
+
+WWW: http://polarssl.org/
diff --git a/security/polarssl/pkg-plist b/security/polarssl/pkg-plist
new file mode 100644
index 000000000000..ac5811abcc69
--- /dev/null
+++ b/security/polarssl/pkg-plist
@@ -0,0 +1,47 @@
+bin/polarssl_aescrypt2
+bin/polarssl_benchmark
+bin/polarssl_dh_client
+bin/polarssl_dh_genprime
+bin/polarssl_dh_server
+bin/polarssl_hello
+bin/polarssl_md5sum
+bin/polarssl_mpi_demo
+bin/polarssl_rsa_genkey
+bin/polarssl_rsa_sign
+bin/polarssl_rsa_verify
+bin/polarssl_selftest
+bin/polarssl_sha1sum
+bin/polarssl_sha2sum
+bin/polarssl_ssl_cert_test
+bin/polarssl_ssl_client1
+bin/polarssl_ssl_client2
+bin/polarssl_ssl_server
+bin/polarssl_ssl_test
+include/polarssl/aes.h
+include/polarssl/arc4.h
+include/polarssl/base64.h
+include/polarssl/bignum.h
+include/polarssl/bn_mul.h
+include/polarssl/camellia.h
+include/polarssl/certs.h
+include/polarssl/config.h
+include/polarssl/debug.h
+include/polarssl/des.h
+include/polarssl/dhm.h
+include/polarssl/havege.h
+include/polarssl/md2.h
+include/polarssl/md4.h
+include/polarssl/md5.h
+include/polarssl/net.h
+include/polarssl/openssl.h
+include/polarssl/padlock.h
+include/polarssl/rsa.h
+include/polarssl/sha1.h
+include/polarssl/sha2.h
+include/polarssl/sha4.h
+include/polarssl/ssl.h
+include/polarssl/timing.h
+include/polarssl/x509.h
+include/polarssl/xtea.h
+lib/libpolarssl.a
+@dirrm include/polarssl