aboutsummaryrefslogtreecommitdiff
path: root/security/pssh
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2007-07-03 00:06:22 +0000
committerBrooks Davis <brooks@FreeBSD.org>2007-07-03 00:06:22 +0000
commitc8ff799714f0b9da8a68c1e6e4b87ca056d99d11 (patch)
tree0a3bf162851d36468dbb49436847f9a6babf028a /security/pssh
parent22d3ded4158dd81ed3c128abd79cdd8b989cf5a2 (diff)
downloadports-c8ff799714f0b9da8a68c1e6e4b87ca056d99d11.tar.gz
ports-c8ff799714f0b9da8a68c1e6e4b87ca056d99d11.zip
Add pssh:
This package provides parallel versions of the openssh tools. Included in the distribution: - Parallel ssh (pssh) - Parallel scp (pscp) - Parallel rsync (prsync) - Parallel nuke (pnuke) - Parallel slurp (pslurp) What are these tools good for? Mainly for controlling large collections of nodes in the wide-area. WWW: http://www.theether.org/pssh/
Notes
Notes: svn path=/head/; revision=194735
Diffstat (limited to 'security/pssh')
-rw-r--r--security/pssh/Makefile37
-rw-r--r--security/pssh/distinfo3
-rw-r--r--security/pssh/pkg-descr13
-rw-r--r--security/pssh/pkg-plist8
4 files changed, 61 insertions, 0 deletions
diff --git a/security/pssh/Makefile b/security/pssh/Makefile
new file mode 100644
index 000000000000..bf69c340b53b
--- /dev/null
+++ b/security/pssh/Makefile
@@ -0,0 +1,37 @@
+# Ports collection makefile for: pssh
+# Date created: Mon Jul 2, 2007
+# Whom: Brooks Davis <brooks@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pssh
+PORTVERSION= 1.3.1
+CATEGORIES= security net sysutils
+MASTER_SITES= http://www.theether.org/pssh/ \
+ ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= brooks
+
+MAINTAINER= brooks@FreeBSD.org
+COMMENT= Parallel versions of the openssh tools
+
+BUILD_DEPENDS= easy_install:${PORTSDIR}/devel/py-setuptools
+RUN_DEPENDS= easy_install:${PORTSDIR}/devel/py-setuptools \
+ rsync:${PORTSDIR}/net/rsync
+
+USE_PYTHON= YES
+USE_PYDISTUTILS=yes
+
+PLIST_SUB+= PSSH_EGG=${PSSH_EGG} \
+ EASY_INSTALL_CMD=${EASY_INSTALL_CMD} \
+ PSSH_EGG=${PSSH_EGG} \
+ EGG="pssh==${PORTVERSION}"
+
+PYDISTUTILS_BUILD_TARGET= bdist_egg
+PYDISTUTILS_INSTALL_TARGET= easy_install
+PYDISTUTILS_INSTALLARGS= -N -O1 -s ${PREFIX}/bin -S ${PYTHON_SITELIBDIR} dist/${PSSH_EGG}
+
+EASY_INSTALL_CMD= easy_install-${PYTHON_VER}
+PSSH_EGG= ${PORTNAME}-${PORTVERSION}-py${PYTHON_VER}.egg
+
+.include <bsd.port.mk>
diff --git a/security/pssh/distinfo b/security/pssh/distinfo
new file mode 100644
index 000000000000..7096924ba628
--- /dev/null
+++ b/security/pssh/distinfo
@@ -0,0 +1,3 @@
+MD5 (pssh-1.3.1.tar.gz) = f01bc890a473f5e1c1ca1957320fcd5c
+SHA256 (pssh-1.3.1.tar.gz) = 4701aacbcbdc018d1e87c02624589e09c956080455c87cac1497d1b2a82055a1
+SIZE (pssh-1.3.1.tar.gz) = 37742
diff --git a/security/pssh/pkg-descr b/security/pssh/pkg-descr
new file mode 100644
index 000000000000..b2f33c6698f8
--- /dev/null
+++ b/security/pssh/pkg-descr
@@ -0,0 +1,13 @@
+This package provides parallel versions of the openssh tools. Included
+in the distribution:
+
+ - Parallel ssh (pssh)
+ - Parallel scp (pscp)
+ - Parallel rsync (prsync)
+ - Parallel nuke (pnuke)
+ - Parallel slurp (pslurp)
+
+What are these tools good for? Mainly for controlling large collections
+of nodes in the wide-area.
+
+WWW: http://www.theether.org/pssh/
diff --git a/security/pssh/pkg-plist b/security/pssh/pkg-plist
new file mode 100644
index 000000000000..0ac9198fbad4
--- /dev/null
+++ b/security/pssh/pkg-plist
@@ -0,0 +1,8 @@
+@unexec %%EASY_INSTALL_CMD%% -q -N -m -x -S %D/%%PYTHON_SITELIBDIR%% %%EGG%%
+bin/prsync
+bin/pnuke
+bin/pslurp
+bin/pssh
+bin/pscp
+%%PYTHON_SITELIBDIR%%/%%PSSH_EGG%%
+@exec %%EASY_INSTALL_CMD%% -q -x -N -S %D/%%PYTHON_SITELIBDIR%% %%EGG%%