aboutsummaryrefslogtreecommitdiff
path: root/security/pwman/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-10-08 21:32:20 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-10-08 21:32:20 +0000
commitff2b67ac7dd0fd031c3b595225c7e3a1238c56e0 (patch)
tree619cd47b79ebff559f8860d4cf1e30a2dee20a3e /security/pwman/Makefile
parentf07b80a7e4450c9280c451893d9d5f7cbdc42178 (diff)
downloadports-ff2b67ac7dd0fd031c3b595225c7e3a1238c56e0.tar.gz
ports-ff2b67ac7dd0fd031c3b595225c7e3a1238c56e0.zip
- Fix handling of & sign, it need to be escaped for XML storage
PR: ports/85240 Submitted by: Maurice Castro <maurice@sphinx.clari.net.au> Approved by: maintainer timeout (anders, 17 days) - While here, fix runtime crash on 64bit platforms by explicitly declaring getenv() (via including <stdlib.h> header)
Notes
Notes: svn path=/head/; revision=144607
Diffstat (limited to 'security/pwman/Makefile')
-rw-r--r--security/pwman/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/security/pwman/Makefile b/security/pwman/Makefile
index 024394a7c603..ba12701de766 100644
--- a/security/pwman/Makefile
+++ b/security/pwman/Makefile
@@ -7,7 +7,7 @@
PORTNAME= pwman
PORTVERSION= 0.3.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -19,11 +19,15 @@ LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2
RUN_DEPENDS= gpg:${PORTSDIR}/security/gnupg
GNU_CONFIGURE= yes
+USE_REINPLACE= yes
MAN1= pwman.1
DOCS= AUTHORS COPYING ChangeLog README TODO
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/bin/gpg|${LOCALBASE}/bin/gpg|g' ${WRKSRC}/src/misc.c
+
.if !defined(NOPORTDOCS)
post-install:
@${INSTALL} -d -m 0755 ${DOCSDIR}