aboutsummaryrefslogtreecommitdiff
path: root/security/py-plaso
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2013-05-07 19:31:47 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2013-05-07 19:31:47 +0000
commit31094afbb271f2df37822c3612d4f2b065e2b8a6 (patch)
tree36002035c6771811c31eecf9db94edf6ea19648f /security/py-plaso
parente0bc6138beb757b0f6ff0ae3b80fc142806dab34 (diff)
downloadports-31094afbb271f2df37822c3612d4f2b065e2b8a6.tar.gz
ports-31094afbb271f2df37822c3612d4f2b065e2b8a6.zip
New port: security/py-plaso
Automatic creation of a super timeline WWW: https://sites.google.com/a/kiddaland.net/plaso/ Approved by: miwi (mentor)
Notes
Notes: svn path=/head/; revision=317629
Diffstat (limited to 'security/py-plaso')
-rw-r--r--security/py-plaso/Makefile57
-rw-r--r--security/py-plaso/distinfo2
-rw-r--r--security/py-plaso/pkg-descr9
-rw-r--r--security/py-plaso/pkg-plist8
4 files changed, 76 insertions, 0 deletions
diff --git a/security/py-plaso/Makefile b/security/py-plaso/Makefile
new file mode 100644
index 000000000000..0b61c6c6d5cf
--- /dev/null
+++ b/security/py-plaso/Makefile
@@ -0,0 +1,57 @@
+# Created by: Antoine Brodin <antoine@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= plaso
+DISTVERSION= 1.0.1alpha
+CATEGORIES= security python
+MASTER_SITES= GOOGLE_CODE
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME}_${DISTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= antoine@FreeBSD.org
+COMMENT= Automatic creation of a super timeline
+
+LICENSE= AL2
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/hachoir_core/__init__.py:${PORTSDIR}/devel/hachoir-core \
+ ${PYTHON_SITELIBDIR}/hachoir_metadata/__init__.py:${PORTSDIR}/sysutils/hachoir-metadata \
+ ${PYTHON_SITELIBDIR}/hachoir_parser/__init__.py:${PORTSDIR}/devel/hachoir-parser \
+ ${PYTHON_SITELIBDIR}/pyevt.so:${PORTSDIR}/devel/libevt \
+ ${PYTHON_SITELIBDIR}/pyevtx.so:${PORTSDIR}/devel/libevtx \
+ ${PYTHON_SITELIBDIR}/pylnk.so:${PORTSDIR}/devel/liblnk \
+ ${PYTHON_SITELIBDIR}/pymsiecf.so:${PORTSDIR}/devel/libmsiecf \
+ ${PYTHON_SITELIBDIR}/pyregf.so:${PORTSDIR}/devel/libregf \
+ ${PYTHON_SITELIBDIR}/pyvshadow.so:${PORTSDIR}/devel/libvshadow \
+ ipython${PYTHON_PKGNAMESUFFIX}>=0:${PORTSDIR}/devel/ipython \
+ ${PYTHON_PKGNAMEPREFIX}dateutil>=0:${PORTSDIR}/devel/py-dateutil \
+ ${PYTHON_PKGNAMEPREFIX}protobuf>=0:${PORTSDIR}/devel/py-protobuf \
+ ${PYTHON_PKGNAMEPREFIX}pytsk>=0:${PORTSDIR}/sysutils/py-pytsk \
+ ${PYTHON_PKGNAMEPREFIX}pytz>=0:${PORTSDIR}/devel/py-pytz \
+ ${PYTHON_PKGNAMEPREFIX}sqlite3>=0:${PORTSDIR}/databases/py-sqlite3 \
+ ${PYTHON_PKGNAMEPREFIX}yaml>=0:${PORTSDIR}/devel/py-yaml
+
+USE_PYTHON= 2.7
+USE_PYDISTUTILS=easy_install
+PYDISTUTILS_PKGVERSION=0.1
+WRKSRC= ${WRKDIR}/${DISTNAME}/${PORTNAME}
+
+PORTDOCS= AUTHORS
+DOCSDIR= ${PREFIX}/share/doc/py-${PORTNAME}
+
+PORTEXAMPLES= README.tools image_export.py
+EXAMPLESDIR= ${PREFIX}/share/examples/py-${PORTNAME}
+
+.include <bsd.port.options.mk>
+
+post-install:
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
+.endif
+.if ${PORT_OPTIONS:MEXAMPLES}
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${PORTEXAMPLES:S,^,${WRKSRC}/tools/,} ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/py-plaso/distinfo b/security/py-plaso/distinfo
new file mode 100644
index 000000000000..76206313f3f5
--- /dev/null
+++ b/security/py-plaso/distinfo
@@ -0,0 +1,2 @@
+SHA256 (plaso_1.0.1alpha.tgz) = 08920c45d72b009df8cb80c76afe272e5554464e968ad1f07dcf4f45b317d437
+SIZE (plaso_1.0.1alpha.tgz) = 609132
diff --git a/security/py-plaso/pkg-descr b/security/py-plaso/pkg-descr
new file mode 100644
index 000000000000..5558c5aa1a7f
--- /dev/null
+++ b/security/py-plaso/pkg-descr
@@ -0,0 +1,9 @@
+Plaso is the Python based back-end engine used by tools such as log2timeline
+for automatic creation of a super timelines. The goal of log2timeline (and thus
+plaso) is to provide a single tool that can parse various log files and
+forensic artifacts from computer and related systems, such as network equipment
+to produce a single correlated timeline. This timeline can then be easily
+analysed by forensic investigators/analysts, speeding up investigations by
+correlating the vast amount of information found on an average computer system.
+
+WWW: https://sites.google.com/a/kiddaland.net/plaso/
diff --git a/security/py-plaso/pkg-plist b/security/py-plaso/pkg-plist
new file mode 100644
index 000000000000..dca48997a5a2
--- /dev/null
+++ b/security/py-plaso/pkg-plist
@@ -0,0 +1,8 @@
+bin/log2timeline.py
+bin/plaso_console.py
+bin/plaso_information.py
+bin/pprof.py
+bin/presets.py
+bin/psort.py
+bin/psort_test.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%