aboutsummaryrefslogtreecommitdiff
path: root/security/py-xmlsec
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-02-13 01:04:26 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-02-13 01:04:26 +0000
commit22d139791080099a807144012808e59c60621fa7 (patch)
treed608f6fd21ea509bd4a06c59b9c46124d4666d02 /security/py-xmlsec
parent815f710e2a64989747b3b108ea6cc5b788e47e4f (diff)
downloadports-22d139791080099a807144012808e59c60621fa7.tar.gz
ports-22d139791080099a807144012808e59c60621fa7.zip
add py-xmlsec 0.2.0
A set of Python bindings for XML Security Library
Notes
Notes: svn path=/head/; revision=100801
Diffstat (limited to 'security/py-xmlsec')
-rw-r--r--security/py-xmlsec/Makefile47
-rw-r--r--security/py-xmlsec/distinfo2
-rw-r--r--security/py-xmlsec/files/patch-setup.py41
-rw-r--r--security/py-xmlsec/pkg-descr3
4 files changed, 93 insertions, 0 deletions
diff --git a/security/py-xmlsec/Makefile b/security/py-xmlsec/Makefile
new file mode 100644
index 000000000000..815979e13dcf
--- /dev/null
+++ b/security/py-xmlsec/Makefile
@@ -0,0 +1,47 @@
+# ex:ts=8
+# Ports collection makefile for: pyxmlsec
+# Date created: Feb 3, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= xmlsec
+PORTVERSION= 0.2.0
+CATEGORIES= security python
+MASTER_SITES= http://pyxmlsec.labs.libre-entreprise.org/releases/sources/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= py${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A set of Python bindings for XML Security Library
+
+LIB_DEPENDS= xmlsec1.3:${PORTSDIR}/security/xmlsec1
+
+USE_REINPLACE= yes
+USE_PYTHON= 2.2+
+USE_PYDISTUTILS= yes
+
+DOCSDIR= ${PREFIX}/share/doc/py-${PORTNAME}
+EXAMPLESDIR= ${PREFIX}/share/examples/py-${PORTNAME}
+
+post-install:
+ @${FIND} ${PYTHON_SITELIBDIR} -name "xmlsec*" | \
+ ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${CP} -R ${WRKSRC}/docs/html/* ${DOCSDIR}
+ @${FIND} ${DOCSDIR} -type f | \
+ ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
+ @${FIND} ${DOCSDIR} -type d | ${SORT} -r | \
+ ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
+
+ @${MKDIR} ${EXAMPLESDIR}
+ ${CP} -R ${WRKSRC}/examples/* ${EXAMPLESDIR}
+ @${FIND} ${EXAMPLESDIR} -type f | \
+ ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
+ @${FIND} ${EXAMPLESDIR} -type d | ${SORT} -r | \
+ ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/py-xmlsec/distinfo b/security/py-xmlsec/distinfo
new file mode 100644
index 000000000000..3ccc05662c82
--- /dev/null
+++ b/security/py-xmlsec/distinfo
@@ -0,0 +1,2 @@
+MD5 (pyxmlsec-0.2.0.tar.gz) = d316e9f8dcd070b9780b11116e4220fc
+SIZE (pyxmlsec-0.2.0.tar.gz) = 212662
diff --git a/security/py-xmlsec/files/patch-setup.py b/security/py-xmlsec/files/patch-setup.py
new file mode 100644
index 000000000000..2a58511140d6
--- /dev/null
+++ b/security/py-xmlsec/files/patch-setup.py
@@ -0,0 +1,41 @@
+--- setup.py.orig Fri Feb 13 08:55:47 2004
++++ setup.py Fri Feb 13 08:57:30 2004
+@@ -71,22 +71,22 @@
+
+ # the crypto engine name : openssl, gnutls or nss
+ xmlsec1_crypto = "openssl"
+-if 'build' in sys.argv:
+- msg = '\nChoose a crypto engine :\n' \
+- ' 1. OpenSSL\n' \
+- ' 2. GnuTLS\n' \
+- ' 3. NSS\n' \
+- 'Your choice : '
+- reply = raw_input(msg)
+- choice = None
+- if reply:
+- choice = reply[0]
+- if choice == '1':
+- xmlsec1_crypto = "openssl"
+- elif choice == '2':
+- xmlsec1_crypto = "gnutls"
+- elif choice == '3':
+- xmlsec1_crypto = "nss"
++#if 'build' in sys.argv:
++# msg = '\nChoose a crypto engine :\n' \
++# ' 1. OpenSSL\n' \
++# ' 2. GnuTLS\n' \
++# ' 3. NSS\n' \
++# 'Your choice : '
++# reply = raw_input(msg)
++# choice = None
++# if reply:
++# choice = reply[0]
++# if choice == '1':
++# xmlsec1_crypto = "openssl"
++# elif choice == '2':
++# xmlsec1_crypto = "gnutls"
++# elif choice == '3':
++# xmlsec1_crypto = "nss"
+
+ define_macros = []
+ include_dirs = []
diff --git a/security/py-xmlsec/pkg-descr b/security/py-xmlsec/pkg-descr
new file mode 100644
index 000000000000..72c8982acb38
--- /dev/null
+++ b/security/py-xmlsec/pkg-descr
@@ -0,0 +1,3 @@
+PyXMLSec is a set of Python bindings for the XML Security library (XMLSec).
+
+WWW: http://pyxmlsec.labs.libre-entreprise.org/