aboutsummaryrefslogtreecommitdiff
path: root/security/py-yara
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2011-03-07 18:04:50 +0000
committerWesley Shields <wxs@FreeBSD.org>2011-03-07 18:04:50 +0000
commit47b8b364d9c57662931ade7f3643711ccb3aa9ef (patch)
tree54fd0090840fab815b427348e22911474d905c9f /security/py-yara
parente0972dd3d0dabbc28aba83a42276dddb4c6af4fd (diff)
downloadports-47b8b364d9c57662931ade7f3643711ccb3aa9ef.tar.gz
ports-47b8b364d9c57662931ade7f3643711ccb3aa9ef.zip
Two new ports: security/yara and security/py-yara. The latter is the python
bindings for the former. "YARA is a tool aimed at helping malware researchers to identify and classify malware samples. With YARA you can create descriptions of malware families based on textual or binary patterns contained on samples of those families. Each description consists of a set of strings and a Boolean expression which determines its logic." WWW: http://code.google.com/p/yara-project/
Notes
Notes: svn path=/head/; revision=270455
Diffstat (limited to 'security/py-yara')
-rw-r--r--security/py-yara/Makefile28
-rw-r--r--security/py-yara/distinfo2
-rw-r--r--security/py-yara/files/patch-setup.py15
-rw-r--r--security/py-yara/pkg-descr9
4 files changed, 54 insertions, 0 deletions
diff --git a/security/py-yara/Makefile b/security/py-yara/Makefile
new file mode 100644
index 000000000000..a4006227533d
--- /dev/null
+++ b/security/py-yara/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: py-yara
+# Date created: Mar 7 2011
+# Whom: wxs@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= yara
+PORTVERSION= 1.4a
+CATEGORIES= security
+MASTER_SITES= GOOGLE_CODE
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= yara-python-${PORTVERSION}
+
+MAINTAINER= wxs@FreeBSD.org
+COMMENT= Python bindings for yara
+
+LIB_DEPENDS= yara.0:${PORTSDIR}/security/yara
+
+PROJECTHOST= yara-project
+MAKE_JOBS_SAFE= yes
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+PYDISTUTILS_EGGINFO= yara_python-1.4a-py2.7.egg-info
+
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/yara.so
+
+.include <bsd.port.mk>
diff --git a/security/py-yara/distinfo b/security/py-yara/distinfo
new file mode 100644
index 000000000000..78da7a1b03ae
--- /dev/null
+++ b/security/py-yara/distinfo
@@ -0,0 +1,2 @@
+SHA256 (yara-python-1.4a.tar.gz) = 0221b6b5178edc99584fb0e082ebbc454e3e33701112f7041349e547a8aabc66
+SIZE (yara-python-1.4a.tar.gz) = 7504
diff --git a/security/py-yara/files/patch-setup.py b/security/py-yara/files/patch-setup.py
new file mode 100644
index 000000000000..2a9ed18afcc8
--- /dev/null
+++ b/security/py-yara/files/patch-setup.py
@@ -0,0 +1,15 @@
+--- ./setup.py.orig 2011-03-07 12:21:10.504810488 -0500
++++ ./setup.py 2011-03-07 12:21:30.973804718 -0500
+@@ -11,8 +11,9 @@
+ name='yara',
+ sources=['yara-python.c'],
+ libraries=['yara','pcre'],
+- include_dirs=['/usr/local/include']
++ include_dirs=['/usr/local/include'],
++ library_dirs=['/usr/local/lib']
+ )])
+
+
+-
+\ No newline at end of file
++
diff --git a/security/py-yara/pkg-descr b/security/py-yara/pkg-descr
new file mode 100644
index 000000000000..28eb3db86f9c
--- /dev/null
+++ b/security/py-yara/pkg-descr
@@ -0,0 +1,9 @@
+The python bindings for yara.
+
+"YARA is a tool aimed at helping malware researchers to identify and classify
+malware samples. With YARA you can create descriptions of malware families
+based on textual or binary patterns contained on samples of those families.
+Each description consists of a set of strings and a Boolean expression which
+determines its logic."
+
+WWW: http://code.google.com/p/yara-project/