aboutsummaryrefslogtreecommitdiff
path: root/security/racoon2
diff options
context:
space:
mode:
authorMunechika SUMIKAWA <sumikawa@FreeBSD.org>2005-02-02 13:06:25 +0000
committerMunechika SUMIKAWA <sumikawa@FreeBSD.org>2005-02-02 13:06:25 +0000
commitcf2b32527010772faaccc1d53959fb11d13a2e9c (patch)
treeef7d50817f24d915edf03f6eccc9a0f7c89977c3 /security/racoon2
parent59ed1e239687131fe78ed3f80d98d399f00beda3 (diff)
downloadports-cf2b32527010772faaccc1d53959fb11d13a2e9c.tar.gz
ports-cf2b32527010772faaccc1d53959fb11d13a2e9c.zip
- Make it broken when Kerberos5 is not installed in the system
- Correct paths in documents
Notes
Notes: svn path=/head/; revision=127908
Diffstat (limited to 'security/racoon2')
-rw-r--r--security/racoon2/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/security/racoon2/Makefile b/security/racoon2/Makefile
index feffbb4a1432..130a6356e518 100644
--- a/security/racoon2/Makefile
+++ b/security/racoon2/Makefile
@@ -14,6 +14,10 @@ EXTRACT_SUFX= .tgz
MAINTAINER= sumikawa@FreeBSD.org
COMMENT= Racoon2 IPsec daemon
+.if !exists(/usr/lib/libkrb5.a)
+BROKEN= "Kerberos5 is required in the system"
+.endif
+
USE_RC_SUBR= YES
USE_OPENSSL= YES
@@ -21,6 +25,7 @@ USE_AUTOCONF_VER=259
CONFIGURE_TARGET=
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--sysconfdir=${LOCALBASE}/etc
+USE_REINPLACE= yes
.if !defined(NOPORTDOCS)
PORTDOCS= INSTALL USAGE.iked USAGE.kinkd USAGE.spmd config-usage.ja.txt
@@ -39,6 +44,13 @@ pre-patch:
${MV} rc.d-kinkd rc.d-kinkd.in ;\
${MV} rc.d-spmd rc.d-spmd.in )
+post-patch:
+.if !defined(NOPORTDOCS)
+.for FILE in ${PORTDOCS}
+ ${REINPLACE_CMD} -e 's|/usr/local/racoon2|${LOCALBASE}|' ${WRKSRC}/doc/${FILE}
+.endfor
+.endif
+
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}