aboutsummaryrefslogtreecommitdiff
path: root/security/rainbowcrack
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2008-07-23 01:01:58 +0000
committerWesley Shields <wxs@FreeBSD.org>2008-07-23 01:01:58 +0000
commitada702800b3d504df2f99107cca1f9a8eb905fe3 (patch)
tree26fa57b7ec6f15efdf4803422f4b2c10f8049e4d /security/rainbowcrack
parent7b24a614fb97d6c1627851ca51dedda9b10dbba9 (diff)
downloadports-ada702800b3d504df2f99107cca1f9a8eb905fe3.tar.gz
ports-ada702800b3d504df2f99107cca1f9a8eb905fe3.zip
Bring this port back to life with a new master site, new maintainer, and
some patches to improve functionality. PR: ports/125595 Submitted by: Dax Labrador <semprix@bsdmail.org>
Notes
Notes: svn path=/head/; revision=217331
Diffstat (limited to 'security/rainbowcrack')
-rw-r--r--security/rainbowcrack/Makefile7
-rw-r--r--security/rainbowcrack/files/patch-HashAlgorithm.cpp58
-rw-r--r--security/rainbowcrack/files/patch-HashAlgorithm.h16
-rw-r--r--security/rainbowcrack/files/patch-HashRoutine.cpp15
4 files changed, 91 insertions, 5 deletions
diff --git a/security/rainbowcrack/Makefile b/security/rainbowcrack/Makefile
index c6849a6b9f69..2037023a98f2 100644
--- a/security/rainbowcrack/Makefile
+++ b/security/rainbowcrack/Makefile
@@ -8,14 +8,11 @@
PORTNAME= rainbowcrack
PORTVERSION= 1.2
CATEGORIES= security
-MASTER_SITES= http://freshdns.net/rainbowcrack/
+MASTER_SITES= http://cerrg.com/dax/rainbowcrack/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= semprix@bsdmail.org
COMMENT= Hash cracker that precomputes plaintext - ciphertext pairs in advance
-DEPRECATED= Software was abandoned by author and master site has disappeared.
-EXPIRATION_DATE= 2008-09-13
-
.include <bsd.port.pre.mk>
.if ${ARCH} == "ia64" || ${ARCH} == "sparc64"
diff --git a/security/rainbowcrack/files/patch-HashAlgorithm.cpp b/security/rainbowcrack/files/patch-HashAlgorithm.cpp
new file mode 100644
index 000000000000..31c061fe9aa6
--- /dev/null
+++ b/security/rainbowcrack/files/patch-HashAlgorithm.cpp
@@ -0,0 +1,58 @@
+--- ./HashAlgorithm.cpp.orig 2008-07-22 20:31:14.000000000 -0400
++++ ./HashAlgorithm.cpp 2008-07-22 20:35:25.000000000 -0400
+@@ -6,9 +6,14 @@
+
+ #include "HashAlgorithm.h"
+
++#include "Public.h"
++
+ #include <openssl/des.h>
++#include <openssl/md2.h>
++#include <openssl/md4.h>
+ #include <openssl/md5.h>
+ #include <openssl/sha.h>
++#include <openssl/ripemd.h>
+ #ifdef _WIN32
+ #pragma comment(lib, "libeay32.lib")
+ #endif
+@@ -48,6 +53,30 @@
+ des_ecb_encrypt((des_cblock*)magic, (des_cblock*)pHash, ks, DES_ENCRYPT);
+ }
+
++
++void HashNTLM(unsigned char* pPlain, int nPlainLen, unsigned char* pHash)
++{
++ unsigned char UnicodePlain[MAX_PLAIN_LEN * 2];
++ int i;
++ for (i = 0; i < nPlainLen; i++)
++ {
++ UnicodePlain[i * 2] = pPlain[i];
++ UnicodePlain[i * 2 + 1] = 0x00;
++ }
++
++ MD4(UnicodePlain, nPlainLen * 2, pHash);
++}
++
++void HashMD2(unsigned char* pPlain, int nPlainLen, unsigned char* pHash)
++{
++ MD2(pPlain, nPlainLen, pHash);
++}
++
++void HashMD4(unsigned char* pPlain, int nPlainLen, unsigned char* pHash)
++{
++ MD4(pPlain, nPlainLen, pHash);
++}
++
+ void HashMD5(unsigned char* pPlain, int nPlainLen, unsigned char* pHash)
+ {
+ MD5(pPlain, nPlainLen, pHash);
+@@ -57,3 +86,9 @@
+ {
+ SHA1(pPlain, nPlainLen, pHash);
+ }
++
++void HashRIPEMD160(unsigned char* pPlain, int nPlainLen, unsigned char* pHash)
++{
++ RIPEMD160(pPlain, nPlainLen, pHash);
++}
++
diff --git a/security/rainbowcrack/files/patch-HashAlgorithm.h b/security/rainbowcrack/files/patch-HashAlgorithm.h
new file mode 100644
index 000000000000..bcf5e2b7923e
--- /dev/null
+++ b/security/rainbowcrack/files/patch-HashAlgorithm.h
@@ -0,0 +1,16 @@
+--- ./HashAlgorithm.h.orig 2008-07-22 20:30:34.000000000 -0400
++++ ./HashAlgorithm.h 2008-07-22 20:31:07.000000000 -0400
+@@ -8,7 +8,13 @@
+ #define _HASHALGORITHM_H
+
+ void HashLM(unsigned char* pPlain, int nPlainLen, unsigned char* pHash);
++void HashNTLM(unsigned char* pPlain, int nPlainLen, unsigned char* pHash);
++
++void HashMD2(unsigned char* pPlain, int nPlainLen, unsigned char* pHash);
++void HashMD4(unsigned char* pPlain, int nPlainLen, unsigned char* pHash);
+ void HashMD5(unsigned char* pPlain, int nPlainLen, unsigned char* pHash);
++
+ void HashSHA1(unsigned char* pPlain, int nPlainLen, unsigned char* pHash);
++void HashRIPEMD160(unsigned char* pPlain, int nPlainLen, unsigned char* pHash);
+
+ #endif
diff --git a/security/rainbowcrack/files/patch-HashRoutine.cpp b/security/rainbowcrack/files/patch-HashRoutine.cpp
new file mode 100644
index 000000000000..e94c5bc6bc20
--- /dev/null
+++ b/security/rainbowcrack/files/patch-HashRoutine.cpp
@@ -0,0 +1,15 @@
+--- ./HashRoutine.cpp.orig 2008-07-22 20:27:54.000000000 -0400
++++ ./HashRoutine.cpp 2008-07-22 20:28:34.000000000 -0400
+@@ -18,8 +18,12 @@
+ // Notice: MIN_HASH_LEN <= nHashLen <= MAX_HASH_LEN
+
+ AddHashRoutine("lm", HashLM, 8);
++ AddHashRoutine("ntlm", HashNTLM, 16);
++ AddHashRoutine("md2", HashMD2, 16);
++ AddHashRoutine("md4", HashMD4, 16);
+ AddHashRoutine("md5", HashMD5, 16);
+ AddHashRoutine("sha1", HashSHA1, 20);
++ AddHashRoutine("ripemd160", HashRIPEMD160, 20);
+ }
+
+ CHashRoutine::~CHashRoutine()