aboutsummaryrefslogtreecommitdiff
path: root/security/razorback-officeCat
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-08-20 18:45:02 +0000
committerJohn Marino <marino@FreeBSD.org>2014-08-20 18:45:02 +0000
commit20049eb7c6e82b303f12420431de98410a3d73ce (patch)
tree949ea75dd07577769620111610e54760fc67db53 /security/razorback-officeCat
parent062822415e1f7e6b2914ccd811ee16f67c173b30 (diff)
downloadports-20049eb7c6e82b303f12420431de98410a3d73ce.tar.gz
ports-20049eb7c6e82b303f12420431de98410a3d73ce.zip
security/razorback-officeCat: Chase json-c update (Unbreak)
This port is i386 only (due to dependency on wine, so the ONLY_FOR_ARCH definition is actually unnecessary) so I can't test it. It's also unstaged. However, the standard json-c patches apply, so just assume that officeCat needs them. If I'm wrong, the port will probably be pruned in a week anyway. Approved by: portmgr (implicit, NO_STAGE)
Notes
Notes: svn path=/head/; revision=365504
Diffstat (limited to 'security/razorback-officeCat')
-rw-r--r--security/razorback-officeCat/Makefile8
-rw-r--r--security/razorback-officeCat/files/patch-common__m4_api__deps.m411
-rw-r--r--security/razorback-officeCat/files/patch-common__m4_compiler__options.m411
3 files changed, 27 insertions, 3 deletions
diff --git a/security/razorback-officeCat/Makefile b/security/razorback-officeCat/Makefile
index 6261151002a6..ae57c0eb583e 100644
--- a/security/razorback-officeCat/Makefile
+++ b/security/razorback-officeCat/Makefile
@@ -3,18 +3,20 @@
PORTNAME= officeCat
PORTVERSION= 0.5.0
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= SF/razorbacktm/Nuggets
PKGNAMEPREFIX= razorback-
DIST_SUBDIR= razorback
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= Framework for an intelligence driven security - OfficeCat Detection
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
-LIB_DEPENDS= librazorback_api.so:${PORTSDIR}/security/razorback-api
+LIB_DEPENDS= librazorback_api.so:${PORTSDIR}/security/razorback-api \
+ libjson-c.so:${PORTSDIR}/devel/json-c
BUILD_DEPENDS= razorback-masterNugget>=0.5.0:${PORTSDIR}/security/razorback-masterNugget \
wine:${PORTSDIR}/emulators/wine
RUN_DEPENDS= razorback-masterNugget>=0.5.0:${PORTSDIR}/security/razorback-masterNugget \
@@ -33,7 +35,7 @@ NO_STAGE= yes
RB_LIBDIR?= ${PREFIX}/lib/razorback
GNU_CONFIGURE= yes
-USE_AUTOTOOLS= libtool
+USE_AUTOTOOLS= libtool autoconf
USE_LDCONFIG= ${RB_LIBDIR}
.if ${PORT_OPTIONS:MDEBUG}
diff --git a/security/razorback-officeCat/files/patch-common__m4_api__deps.m4 b/security/razorback-officeCat/files/patch-common__m4_api__deps.m4
new file mode 100644
index 000000000000..b424f894f261
--- /dev/null
+++ b/security/razorback-officeCat/files/patch-common__m4_api__deps.m4
@@ -0,0 +1,11 @@
+--- common_m4/api_deps.m4.orig 2012-04-16 18:59:44 UTC
++++ common_m4/api_deps.m4
+@@ -55,7 +55,7 @@ LIBS="$LIBCONFIG_LIBS $LIBS"
+ # [AC_MSG_ERROR("curl header file not found")]
+ # )
+
+-PKG_CHECK_MODULES([JSON], [json >= 0.9])
++PKG_CHECK_MODULES([JSON], [json-c >= 0.9])
+
+ CFLAGS="$JSON_CFLAGS $CFLAGS"
+ LIBS="$JSON_LIBS $LIBS"
diff --git a/security/razorback-officeCat/files/patch-common__m4_compiler__options.m4 b/security/razorback-officeCat/files/patch-common__m4_compiler__options.m4
new file mode 100644
index 000000000000..8e2572727b90
--- /dev/null
+++ b/security/razorback-officeCat/files/patch-common__m4_compiler__options.m4
@@ -0,0 +1,11 @@
+--- common_m4/compiler_options.m4.orig 2012-01-04 18:17:09 UTC
++++ common_m4/compiler_options.m4
+@@ -28,7 +28,7 @@ if test "$GCC" = yes ; then
+
+ CFLAGS="$CFLAGS -std=c99 -fno-strict-aliasing"
+ CPPFLAGS="$CPPFLAGS -fno-strict-aliasing"
+- CWARNINGS="$CWARNINGS -Wall -Werror -Wwrite-strings -Wformat -fdiagnostics-show-option -Wextra -Wformat-security -Wsign-compare -Wcast-align -Wno-unused-parameter"
++ CWARNINGS="$CWARNINGS -Wall -Wwrite-strings -Wformat -fdiagnostics-show-option -Wextra -Wformat-security -Wsign-compare -Wcast-align -Wno-unused-parameter"
+ if test "x$NOT_PEDANTIC" = "x"; then
+ CWARNINGS="$CWARNINGS -pedantic"
+ fi