aboutsummaryrefslogtreecommitdiff
path: root/security/retranslator
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-06-05 21:22:25 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-06-05 21:22:25 +0000
commita7e75a5d1410590abe6f9dd1d09d843739b5f9fe (patch)
tree8aa613a9fee3a3108c880a46416fddc917bfa581 /security/retranslator
parent21e8c1ba62145e06ffb372b6325ec0ab6a929c9b (diff)
downloadports-a7e75a5d1410590abe6f9dd1d09d843739b5f9fe.tar.gz
ports-a7e75a5d1410590abe6f9dd1d09d843739b5f9fe.zip
The update utility is designed to download and save updates and modules
of the Kaspersky Lab's applications into a separate folder. With the help of the utility you can download updates for selected Kaspersky Lab's applications installed either in your network or at a home PC. The utility has a function for saving downloaded updates and autopatches in a local folder, a network folder connected as a disc to the computer file system, or onto a flash-carrier. WWW: http://support.kaspersky.com/updater?level=2 PR: ports/147116 Submitted by: Gvozdikov Veniamin <g.veniamin at googlemail.com>
Notes
Notes: svn path=/head/; revision=255843
Diffstat (limited to 'security/retranslator')
-rw-r--r--security/retranslator/Makefile49
-rw-r--r--security/retranslator/distinfo3
-rw-r--r--security/retranslator/pkg-descr10
-rw-r--r--security/retranslator/pkg-plist4
4 files changed, 66 insertions, 0 deletions
diff --git a/security/retranslator/Makefile b/security/retranslator/Makefile
new file mode 100644
index 000000000000..e08e71530b6e
--- /dev/null
+++ b/security/retranslator/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: retranslator
+# Date created: 2010-05-25
+# Whom: Gvozdikov Veniamin <g.veniamin@googlemail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= retranslator
+PORTVERSION= 5.0.0
+CATEGORIES= security
+MASTER_SITES= http://utils.kaspersky.com/updater/retranslator_5.0.0.7/FreeBSD_6.3/ \
+ http://fbsd.zlonet.ru/distfiles/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-7
+
+MAINTAINER= g.veniamin@googlemail.com
+COMMENT= The update utility for Kaspersky applications
+
+NO_BUILD= yes
+ONLY_FOR_ARCHS= i386 amd64
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 630000
+LIB_DEPENDS+= m.4:${PORTSDIR}/misc/compat6x
+.endif
+
+do-configure:
+
+.for f in 's,./backup/,/var/db/${PORTNAME}/backup,g' \
+ 's,./bases/,/var/db/${PORTNAME}/bases,g' \
+ 's,./${PORTNAME}.log,/var/log/${PORTNAME}.log,g'
+ @${REINPLACE_CMD} -e ${f} \
+ ${WRKSRC}/${PORTNAME}.conf
+.endfor
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME}.bin \
+ ${PREFIX}/bin/${PORTNAME}
+
+post-install:
+ @${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.conf \
+ ${PREFIX}/etc/${PORTNAME}.conf.sample
+ @if [ ! -f ${PREFIX}/etc/${PORTNAME}.conf ]; then \
+ ${CP} -p ${PREFIX}/etc/${PORTNAME}.conf.sample ${PREFIX}/etc/${PORTNAME}.conf ; \
+ fi
+
+.include <bsd.port.post.mk>
diff --git a/security/retranslator/distinfo b/security/retranslator/distinfo
new file mode 100644
index 000000000000..0f83ed0920e5
--- /dev/null
+++ b/security/retranslator/distinfo
@@ -0,0 +1,3 @@
+MD5 (retranslator-5.0.0-7.tar.gz) = 263c4afecba530cce614fb7474b44dc2
+SHA256 (retranslator-5.0.0-7.tar.gz) = ad32b535ddf0c13f95cdbba2de0d2d6b157cb6ff62b5a61766a0a93c77f33f97
+SIZE (retranslator-5.0.0-7.tar.gz) = 671996
diff --git a/security/retranslator/pkg-descr b/security/retranslator/pkg-descr
new file mode 100644
index 000000000000..3eada1855d2a
--- /dev/null
+++ b/security/retranslator/pkg-descr
@@ -0,0 +1,10 @@
+The update utility is designed to download and save updates and modules
+of the Kaspersky Lab's applications into a separate folder.
+
+With the help of the utility you can download updates for selected
+Kaspersky Lab's applications installed either in your network or at
+a home PC. The utility has a function for saving downloaded updates
+and autopatches in a local folder, a network folder connected as a
+disc to the computer file system, or onto a flash-carrier.
+
+WWW: http://support.kaspersky.com/updater?level=2
diff --git a/security/retranslator/pkg-plist b/security/retranslator/pkg-plist
new file mode 100644
index 000000000000..d4207e4cd88d
--- /dev/null
+++ b/security/retranslator/pkg-plist
@@ -0,0 +1,4 @@
+bin/retranslator
+@unexec if cmp -s %D/etc/retranslator.conf.sample %D/etc/retranslator.conf; then rm -f %D/etc/retranslator.conf; fi
+etc/retranslator.conf.sample
+@exec if [ ! -f %D/etc/retranslator.conf ] ; then cp -p %D/%F %B/retranslator.conf; fi