aboutsummaryrefslogtreecommitdiff
path: root/security/revelation/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-08-19 18:49:02 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-08-19 18:49:02 +0000
commitb16ba3c223b95f57fcf02b5cd6f05532c311e56d (patch)
tree08750092407f01de519264bff9c9a6073a9a3d8e /security/revelation/Makefile
parentdb3b14ca74b5255eb7b044d4dcf05830c26f477f (diff)
downloadports-b16ba3c223b95f57fcf02b5cd6f05532c311e56d.tar.gz
ports-b16ba3c223b95f57fcf02b5cd6f05532c311e56d.zip
Add revelation, a password manager for the GNOME 2 desktop. It stores all
your account and passwords in a single, secure, place, and give you access to them all through a user-friendly graphical interface. PR: 70653 Submitted by: ports@c0decafe.net <ports@c0decafe.net>
Notes
Notes: svn path=/head/; revision=116719
Diffstat (limited to 'security/revelation/Makefile')
-rw-r--r--security/revelation/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/security/revelation/Makefile b/security/revelation/Makefile
new file mode 100644
index 000000000000..8b7ea528b10c
--- /dev/null
+++ b/security/revelation/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: revelation
+# Date created: 2004-08-10
+# Whom: ports@c0decafe.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= revelation
+PORTVERSION= 0.3.2
+CATEGORIES= security gnome
+MASTER_SITES= ftp://oss.codepoet.no/revelation/
+
+MAINTAINER= ports@c0decafe.net
+COMMENT= Password manager for the GNOME 2 desktop
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/libxml2.py:${PORTSDIR}/textproc/py-libxml2\
+ ${PYTHON_SITELIBDIR}/Crypto/test.py:${PORTSDIR}/security/py-pycrypto
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_GNOME= pygnome2
+USE_PYTHON= yes
+USE_PYDISTUTILS=yes
+USE_REINPLACE= yes
+
+post-patch:
+ @${REINPLACE_CMD} 's#share/#share/gnome/#g' \
+ ${WRKSRC}/setup.py ${WRKSRC}/src/lib/__init__.py
+ @${REINPLACE_CMD} 's#sys\.prefix#"${PREFIX}"#g' \
+ ${WRKSRC}/src/lib/__init__.py
+
+.include <bsd.port.mk>