aboutsummaryrefslogtreecommitdiff
path: root/security/ruby-crypt
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-08-10 15:47:15 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-08-10 15:47:15 +0000
commita9fbcd3d1d3b5ba8eab1a701fd2a1925751f8f49 (patch)
tree36337a434dc0fe7640890f307efa78886952a3a5 /security/ruby-crypt
parent1401bbab2feef853042890f5700c83d024384e0f (diff)
downloadports-a9fbcd3d1d3b5ba8eab1a701fd2a1925751f8f49.tar.gz
ports-a9fbcd3d1d3b5ba8eab1a701fd2a1925751f8f49.zip
- ruby-crypt is a pure-ruby implementation of a number of popular
encryption algorithms.
Notes
Notes: svn path=/head/; revision=170283
Diffstat (limited to 'security/ruby-crypt')
-rw-r--r--security/ruby-crypt/Makefile27
-rw-r--r--security/ruby-crypt/distinfo3
-rw-r--r--security/ruby-crypt/pkg-descr10
-rw-r--r--security/ruby-crypt/pkg-plist10
4 files changed, 50 insertions, 0 deletions
diff --git a/security/ruby-crypt/Makefile b/security/ruby-crypt/Makefile
new file mode 100644
index 000000000000..a219e9fbc79e
--- /dev/null
+++ b/security/ruby-crypt/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: ruby-crypt
+# Date created: 2006-08-10
+# Whom: Cheng-Lung Sung <clsung@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= crypt
+PORTVERSION= 1.1.4
+CATEGORIES= security ruby
+MASTER_SITES= ${MASTER_SITE_RUBYFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DIST_SUBDIR= ruby
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= Pure-ruby implementation of popular encryption algorithms
+
+USE_RUBY= yes
+
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}
+
+do-install:
+ @cd ${WRKSRC}; ${RUBY} install.rb
+
+.include <bsd.port.mk>
diff --git a/security/ruby-crypt/distinfo b/security/ruby-crypt/distinfo
new file mode 100644
index 000000000000..733cd6feee4c
--- /dev/null
+++ b/security/ruby-crypt/distinfo
@@ -0,0 +1,3 @@
+MD5 (ruby/crypt-1.1.4.tar.gz) = 68e6bc4bdc952f5a7919f6bc4fdb1348
+SHA256 (ruby/crypt-1.1.4.tar.gz) = 92d6d5f391aba825f55c9c886ce6aeb4f5241822e3b45f8e80a3cd56242fc4fc
+SIZE (ruby/crypt-1.1.4.tar.gz) = 19824
diff --git a/security/ruby-crypt/pkg-descr b/security/ruby-crypt/pkg-descr
new file mode 100644
index 000000000000..7b0c897a7af0
--- /dev/null
+++ b/security/ruby-crypt/pkg-descr
@@ -0,0 +1,10 @@
+The Crypt library is a pure-ruby implementation of a number of
+popular encryption algorithms. Block cyphers currently available
+include Blowfish, GOST, IDEA, and Rijndael (AES).
+Cypher Block Chaining (CBC) has been implemented.
+Twofish, Serpent, and CAST256 are planned for release soon.
+
+Crypt is written entirely in ruby so deployment is simple -
+no platform concerns, no library dependencies, nothing to compile.
+
+WWW: http://crypt.rubyforge.org/
diff --git a/security/ruby-crypt/pkg-plist b/security/ruby-crypt/pkg-plist
new file mode 100644
index 000000000000..7e42137cc1a3
--- /dev/null
+++ b/security/ruby-crypt/pkg-plist
@@ -0,0 +1,10 @@
+%%RUBY_SITELIBDIR%%/crypt/blowfish.rb
+%%RUBY_SITELIBDIR%%/crypt/blowfish-tables.rb
+%%RUBY_SITELIBDIR%%/crypt/cbc.rb
+%%RUBY_SITELIBDIR%%/crypt/gost.rb
+%%RUBY_SITELIBDIR%%/crypt/idea.rb
+%%RUBY_SITELIBDIR%%/crypt/noise.rb
+%%RUBY_SITELIBDIR%%/crypt/rijndael-tables.rb
+%%RUBY_SITELIBDIR%%/crypt/rijndael.rb
+%%RUBY_SITELIBDIR%%/crypt/stringxor.rb
+@dirrm %%RUBY_SITELIBDIR%%/crypt