aboutsummaryrefslogtreecommitdiff
path: root/security/ruby-gpgme
diff options
context:
space:
mode:
authorClement Laforet <clement@FreeBSD.org>2004-12-21 08:59:42 +0000
committerClement Laforet <clement@FreeBSD.org>2004-12-21 08:59:42 +0000
commit7ef18bc03149b2fd5fc002e2e5a219c3796ee2e8 (patch)
tree14e5daf0321e5bcec6a69cf36c14c650a67788ed /security/ruby-gpgme
parent01b976f45a05e3b5dd2a265a53effbf87560d087 (diff)
downloadports-7ef18bc03149b2fd5fc002e2e5a219c3796ee2e8.tar.gz
ports-7ef18bc03149b2fd5fc002e2e5a219c3796ee2e8.zip
- Rework gpgme03 port to avoid conflict with gpgme 1.0
- Make ports depending on it use new layout - Bump PORTREVISION (except elmo*) Approved by: portmgr (marcus)
Notes
Notes: svn path=/head/; revision=124666
Diffstat (limited to 'security/ruby-gpgme')
-rw-r--r--security/ruby-gpgme/Makefile3
-rw-r--r--security/ruby-gpgme/files/patch-extconf.rb9
-rw-r--r--security/ruby-gpgme/files/patch-gpgme_n.c11
3 files changed, 22 insertions, 1 deletions
diff --git a/security/ruby-gpgme/Makefile b/security/ruby-gpgme/Makefile
index 9f62f62626b4..61f9bcfb623a 100644
--- a/security/ruby-gpgme/Makefile
+++ b/security/ruby-gpgme/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gpgme
PORTVERSION= 0.2
+PORTREVISION= 1
CATEGORIES= security ruby
MASTER_SITES= http://deisui.org/~ueno/ruby/ruby-gpgme/
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
@@ -16,7 +17,7 @@ DIST_SUBDIR= ruby
MAINTAINER= knu@FreeBSD.org
COMMENT= A Ruby interface to GnuPG Made Easy (GPGME)
-LIB_DEPENDS= gpgme.9:${PORTSDIR}/security/gpgme03
+LIB_DEPENDS= gpgme03.9:${PORTSDIR}/security/gpgme03
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
diff --git a/security/ruby-gpgme/files/patch-extconf.rb b/security/ruby-gpgme/files/patch-extconf.rb
new file mode 100644
index 000000000000..cb44912b92f3
--- /dev/null
+++ b/security/ruby-gpgme/files/patch-extconf.rb
@@ -0,0 +1,9 @@
+--- extconf.rb.orig Mon Dec 20 21:35:54 2004
++++ extconf.rb Mon Dec 20 21:36:21 2004
+@@ -1,5 +1,5 @@
+ require 'mkmf'
+
+-if have_library('gpgme', 'gpgme_check_version') and have_header('gpgme.h')
++if have_library('gpgme03', 'gpgme_check_version') and have_header('gpgme03/gpgme.h')
+ create_makefile ('gpgme_n')
+ end
diff --git a/security/ruby-gpgme/files/patch-gpgme_n.c b/security/ruby-gpgme/files/patch-gpgme_n.c
new file mode 100644
index 000000000000..43b3f82a055e
--- /dev/null
+++ b/security/ruby-gpgme/files/patch-gpgme_n.c
@@ -0,0 +1,11 @@
+--- gpgme_n.c.orig Mon Dec 20 21:38:14 2004
++++ gpgme_n.c Mon Sep 29 21:35:59 2003
+@@ -34,7 +34,7 @@
+ this purpose. */
+
+ #include "ruby.h"
+-#include "gpgme.h"
++#include "gpgme03/gpgme.h"
+
+ /* StringValuePtr is not available in 1.6. */
+ #ifndef StringValuePtr