aboutsummaryrefslogtreecommitdiff
path: root/security/rubygem-net-ssh-gateway
diff options
context:
space:
mode:
authorMarcelo Araujo <araujo@FreeBSD.org>2008-07-05 23:06:19 +0000
committerMarcelo Araujo <araujo@FreeBSD.org>2008-07-05 23:06:19 +0000
commitc8d9993367ccbc6c071bf73ee12bd642dfc575ed (patch)
tree7ffbdeca178d7604e7d30903a3971ef74556fcb3 /security/rubygem-net-ssh-gateway
parent38fff32d11ef45e34a6ffb91a8c806f38b558177 (diff)
downloadports-c8d9993367ccbc6c071bf73ee12bd642dfc575ed.tar.gz
ports-c8d9993367ccbc6c071bf73ee12bd642dfc575ed.zip
Net::SSH::Gateway is a library for programmatically tunneling connections to
servers via a single "gateway" host. It is useful for establishing Net::SSH connections to servers behind firewalls, but can also be used to forward ports and establish connections of other types, like HTTP, to servers with i restricted access. * Easily manage forwarded ports * Establish Net::SSH connections through firewalls WWW: http://net-ssh.rubyforge.org/gateway PR: ports/125053 Submitted by: Philip M. Gollucci <pgollucci@p6m7g8.com>
Notes
Notes: svn path=/head/; revision=216387
Diffstat (limited to 'security/rubygem-net-ssh-gateway')
-rw-r--r--security/rubygem-net-ssh-gateway/Makefile22
-rw-r--r--security/rubygem-net-ssh-gateway/distinfo3
-rw-r--r--security/rubygem-net-ssh-gateway/pkg-descr10
-rw-r--r--security/rubygem-net-ssh-gateway/pkg-plist43
4 files changed, 78 insertions, 0 deletions
diff --git a/security/rubygem-net-ssh-gateway/Makefile b/security/rubygem-net-ssh-gateway/Makefile
new file mode 100644
index 000000000000..9227c35c71c9
--- /dev/null
+++ b/security/rubygem-net-ssh-gateway/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: rubygem-net-ssh-gateway
+# Date created: June 27, 2008
+# Whom: Philip M. Gollucci <pgollucci@p6m7g8.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= net-ssh-gateway
+PORTVERSION= 1.0.0
+CATEGORIES= security rubygems
+MASTER_SITES= RF
+MASTER_SITE_SUBDIR= net-ssh
+
+MAINTAINER= pgollucci@p6m7g8.com
+COMMENT= Establish Net::SSH connections through firewalls
+
+RUN_DEPENDS= ${LOCALBASE}/${SPEC_DIR}/net-ssh-2.0.2.gemspec:${PORTSDIR}/security/rubygem-net-ssh
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+
+.include <bsd.port.mk>
diff --git a/security/rubygem-net-ssh-gateway/distinfo b/security/rubygem-net-ssh-gateway/distinfo
new file mode 100644
index 000000000000..1f8398353d06
--- /dev/null
+++ b/security/rubygem-net-ssh-gateway/distinfo
@@ -0,0 +1,3 @@
+MD5 (rubygem/net-ssh-gateway-1.0.0.gem) = c6ba0ee4787a4c3623f5d86d7a45e006
+SHA256 (rubygem/net-ssh-gateway-1.0.0.gem) = ec9de7fd571df2bee0eeaa517e1c42cac9fde313ba5a7ed6aa1bc335fa978808
+SIZE (rubygem/net-ssh-gateway-1.0.0.gem) = 18432
diff --git a/security/rubygem-net-ssh-gateway/pkg-descr b/security/rubygem-net-ssh-gateway/pkg-descr
new file mode 100644
index 000000000000..3d2a82b06e80
--- /dev/null
+++ b/security/rubygem-net-ssh-gateway/pkg-descr
@@ -0,0 +1,10 @@
+Net::SSH::Gateway is a library for programmatically tunneling connections to
+servers via a single "gateway" host. It is useful for establishing Net::SSH
+connections to servers behind firewalls, but can also be used to forward ports
+and establish connections of other types, like HTTP, to servers with i
+restricted access.
+
+* Easily manage forwarded ports
+* Establish Net::SSH connections through firewalls
+
+WWW: http://net-ssh.rubyforge.org/gateway
diff --git a/security/rubygem-net-ssh-gateway/pkg-plist b/security/rubygem-net-ssh-gateway/pkg-plist
new file mode 100644
index 000000000000..c6e16cb10f7a
--- /dev/null
+++ b/security/rubygem-net-ssh-gateway/pkg-plist
@@ -0,0 +1,43 @@
+%%GEM_CACHE%%
+%%GEM_SPEC%%
+%%GEM_DOC_DIR%%/rdoc/rdoc-style.css
+%%GEM_DOC_DIR%%/rdoc/files/lib/net/ssh/gateway_rb.html
+%%GEM_DOC_DIR%%/rdoc/classes/Net/SSH/Gateway.src/M000001.html
+%%GEM_DOC_DIR%%/rdoc/classes/Net/SSH/Gateway.src/M000002.html
+%%GEM_DOC_DIR%%/rdoc/classes/Net/SSH/Gateway.src/M000003.html
+%%GEM_DOC_DIR%%/rdoc/classes/Net/SSH/Gateway.src/M000004.html
+%%GEM_DOC_DIR%%/rdoc/classes/Net/SSH/Gateway.src/M000005.html
+%%GEM_DOC_DIR%%/rdoc/classes/Net/SSH/Gateway.src/M000006.html
+%%GEM_DOC_DIR%%/rdoc/classes/Net/SSH/Gateway.html
+%%GEM_DOC_DIR%%/rdoc/classes/Net/SSH/Gateway/Version.html
+%%GEM_DOC_DIR%%/rdoc/classes/Net/SSH.html
+%%GEM_DOC_DIR%%/rdoc/classes/Net.html
+%%GEM_DOC_DIR%%/rdoc/fr_file_index.html
+%%GEM_DOC_DIR%%/rdoc/fr_class_index.html
+%%GEM_DOC_DIR%%/rdoc/fr_method_index.html
+%%GEM_DOC_DIR%%/rdoc/index.html
+%%GEM_DOC_DIR%%/rdoc/created.rid
+%%GEM_LIB_DIR%%/CHANGELOG.rdoc
+%%GEM_LIB_DIR%%/lib/net/ssh/gateway.rb
+%%GEM_LIB_DIR%%/Manifest
+%%GEM_LIB_DIR%%/Rakefile
+%%GEM_LIB_DIR%%/README.rdoc
+%%GEM_LIB_DIR%%/setup.rb
+%%GEM_LIB_DIR%%/test/gateway_test.rb
+%%GEM_LIB_DIR%%/net-ssh-gateway.gemspec
+@dirrm %%GEM_LIB_DIR%%/test
+@dirrm %%GEM_LIB_DIR%%/lib/net/ssh
+@dirrm %%GEM_LIB_DIR%%/lib/net
+@dirrm %%GEM_LIB_DIR%%/lib
+@dirrm %%GEM_LIB_DIR%%
+@dirrm %%GEM_DOC_DIR%%/rdoc/files/lib/net/ssh
+@dirrm %%GEM_DOC_DIR%%/rdoc/files/lib/net
+@dirrm %%GEM_DOC_DIR%%/rdoc/files/lib
+@dirrm %%GEM_DOC_DIR%%/rdoc/files
+@dirrm %%GEM_DOC_DIR%%/rdoc/classes/Net/SSH/Gateway.src
+@dirrm %%GEM_DOC_DIR%%/rdoc/classes/Net/SSH/Gateway
+@dirrm %%GEM_DOC_DIR%%/rdoc/classes/Net/SSH
+@dirrm %%GEM_DOC_DIR%%/rdoc/classes/Net
+@dirrm %%GEM_DOC_DIR%%/rdoc/classes
+@dirrm %%GEM_DOC_DIR%%/rdoc
+@dirrm %%GEM_DOC_DIR%%