aboutsummaryrefslogtreecommitdiff
path: root/security/safesh
diff options
context:
space:
mode:
authorEivind Eklund <eivind@FreeBSD.org>2002-01-30 18:20:17 +0000
committerEivind Eklund <eivind@FreeBSD.org>2002-01-30 18:20:17 +0000
commit2f056dc832b7f191aceb52cb3730edcbc78e6b1a (patch)
treecc9356ddeedf6ace285e0fb5fa74abf897339e65 /security/safesh
parentf4c186040290afcf5123d445582ee2b97ade2997 (diff)
downloadports-2f056dc832b7f191aceb52cb3730edcbc78e6b1a.tar.gz
ports-2f056dc832b7f191aceb52cb3730edcbc78e6b1a.zip
Update to 1.2: Single line bugfix.
I hope I got it right *this* time, at least.
Notes
Notes: svn path=/head/; revision=54037
Diffstat (limited to 'security/safesh')
-rw-r--r--security/safesh/Makefile2
-rw-r--r--security/safesh/src/safesh.sh2
2 files changed, 2 insertions, 2 deletions
diff --git a/security/safesh/Makefile b/security/safesh/Makefile
index 1f3c0403665d..4c773a23e32b 100644
--- a/security/safesh/Makefile
+++ b/security/safesh/Makefile
@@ -8,7 +8,7 @@
#
PORTNAME= safesh
-PORTVERSION= 1.1
+PORTVERSION= 1.2
CATEGORIES= security
MASTER_SITES= # none
DISTFILES= # none
diff --git a/security/safesh/src/safesh.sh b/security/safesh/src/safesh.sh
index bd7417964516..8db88109d122 100644
--- a/security/safesh/src/safesh.sh
+++ b/security/safesh/src/safesh.sh
@@ -68,7 +68,7 @@ fi
for i in $USER@${HOST}-22 `cat $HOSTDIR/extra_keys 2> /dev/null`; do
tmpuser=`echo $i | sed -e "/^[^@]*\$/s/.*/$USER/" -e "/@/s/\\(.*\\)@.*/\\1/"`
tmpport=`echo $i | sed -e '/-\([0-9][0-9]*\)/!s/$/-22/' -e 's/.*-\([0-9][0-9]*\)/\1/'`
- tmphost=`echo $1 | sed -e 's/.*@\(.*\)//' -e 's/-[0-9][0-9]*$//' | tr A-Z a-z`
+ tmphost=`echo $i | sed -e 's/.*@\(.*\)/\1/' -e 's/-[0-9][0-9]*$//' | tr A-Z a-z`
tmp=$USER@`normalizehost $tmphost`-$tmpport
if [ -f $HOSTDIR/$tmp ]; then
IDENTITY=$HOSTDIR/$tmp