aboutsummaryrefslogtreecommitdiff
path: root/security/samhain/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-04-13 13:17:14 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-04-13 13:17:14 +0000
commit5db5ae58ad96fdd52668ccb510982a808a54954a (patch)
tree6877a47e3badb231e866f575877b380e73961def /security/samhain/Makefile
parent5ac350dec8cdb3600c2b17e79fe9d1aca763b52c (diff)
downloadports-5db5ae58ad96fdd52668ccb510982a808a54954a.tar.gz
ports-5db5ae58ad96fdd52668ccb510982a808a54954a.zip
The Samhain Intrusion Detection System
Samhain is a host-based Intrusion Detection System and integrity checker with advanced features such as centralized logging, MySQL/PostgreSQL support, and rootkit detection. PR: ports/46982 Submitted by: David Thiel <lx@redundancy.redundancy.org>
Notes
Notes: svn path=/head/; revision=78891
Diffstat (limited to 'security/samhain/Makefile')
-rw-r--r--security/samhain/Makefile86
1 files changed, 86 insertions, 0 deletions
diff --git a/security/samhain/Makefile b/security/samhain/Makefile
new file mode 100644
index 000000000000..a2cbf419d424
--- /dev/null
+++ b/security/samhain/Makefile
@@ -0,0 +1,86 @@
+# New ports collection makefile for: samhain
+# Date created: 9 January 2003
+# Whom: lx
+#
+# $FreeBSD$
+#
+
+PORTNAME= samhain
+PORTVERSION= 1.7.4
+CATEGORIES= security
+MASTER_SITES= http://la-samhna.de/samhain/
+DISTFILES= samhain_signed-${PORTVERSION}.tar.gz
+
+MAINTAINER= lx@redundancy.redundancy.org
+COMMENT= The Samhain Intrusion Detection System
+
+.if defined(WITH_GPG)
+RUN_DEPENDS= gpg:${PORTSDIR}/security/gnupg
+.endif
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-login-watch --localstatedir=/var --mandir=${PREFIX}/man
+
+.if defined(TRUSTED_USER)
+CONFIGURE_ARGS+= --enable-identity=${TRUSTED_USER}
+.endif
+.if defined(WITH_KCHECK)
+CONFIGURE_ARGS+= --with-kcheck
+.endif
+.if defined(WITH_GPG)
+CONFIGURE_ARGS+= --with-gpg=${PREFIX}/bin/gpg
+.endif
+.if defined(WITH_MYSQL)
+CONFIGURE_ARGS+= --with-database=mysql
+.endif
+.if defined(WITH_POSTGRES)
+CONFIGURE_ARGS+= --with-database=postgresql
+.endif
+.if defined(CLIENT)
+CONFIGURE_ARGS+= --enable-network=client
+PLIST_SUB+= SAMHAIN="" SETPWD="" YULE="@comment "
+MAN5= samhainrc.5
+MAN8= samhain.8
+.elif defined(SERVER)
+CONFIGURE_ARGS+= --enable-network=server
+PLIST_SUB+= YULE="" SAMHAIN="@comment " SETPWD="@comment "
+MAN5= yulerc.5
+MAN8= yule.8
+.else
+PLIST_SUB+= SAMHAIN="" YULE="@comment " SETPWD="@comment "
+MAN5= samhainrc.5
+MAN8= samhain.8
+.endif
+
+pre-everything::
+
+.if !defined(CLIENT) && !defined(SERVER)
+ @${ECHO_MSG} "Building in standalone mode."
+ @${ECHO_MSG} "If you wish to enable networked mode, please hit CTRL-C"
+ @${ECHO_MSG} "now and make with SERVER=yes or CLIENT=yes."
+.endif
+
+post-extract:
+ @${TAR} -C ${WRKDIR} -xzf ${WRKSRC}.tar.gz
+ @${RM} ${WRKSRC}.tar.gz ${WRKSRC}.tar.gz.asc
+
+post-install:
+.if !defined(SERVER)
+ @${CP} ${WRKSRC}/init/samhain.startFreeBSD ${PREFIX}/etc/rc.d/samhain.sh.sample
+.else
+ @${CP} ${WRKSRC}/init/samhain.startFreeBSD ${PREFIX}/etc/rc.d/yule.sh.sample
+.endif
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/samhain
+ ${INSTALL_MAN} ${WRKSRC}/docs/MANUAL-1_7.ps ${PREFIX}/share/doc/samhain
+ ${INSTALL_MAN} ${WRKSRC}/docs/MANUAL-1_7.html.tar ${PREFIX}/share/doc/samhain
+ ${INSTALL_MAN} ${WRKSRC}/docs/HOWTO-client+server.html ${PREFIX}/share/doc/samhain
+.if defined(WITH_GPG)
+ ${INSTALL_MAN} ${WRKSRC}/docs/HOWTO-samhain+GnuPG.html ${PREFIX}/share/doc/samhain
+.endif
+.endif
+
+install-user:
+ @(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} install-user)
+
+.include <bsd.port.mk>