aboutsummaryrefslogtreecommitdiff
path: root/security/samhain/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-11-01 14:05:52 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-11-01 14:05:52 +0000
commitf864a51ed0a2d6cd1e00c19bbf9eb4c5204350e3 (patch)
tree4b119a4bdcb31e11f9908119cb4798092c6044b0 /security/samhain/Makefile
parent66f15be23fd2142a0a0987eb5bd527e37c7b2aa7 (diff)
downloadports-f864a51ed0a2d6cd1e00c19bbf9eb4c5204350e3.tar.gz
ports-f864a51ed0a2d6cd1e00c19bbf9eb4c5204350e3.zip
- Update to version 1.8.0
PR: 58790 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=92778
Diffstat (limited to 'security/samhain/Makefile')
-rw-r--r--security/samhain/Makefile42
1 files changed, 24 insertions, 18 deletions
diff --git a/security/samhain/Makefile b/security/samhain/Makefile
index 46809f4c8aef..d6ef02dc71b2 100644
--- a/security/samhain/Makefile
+++ b/security/samhain/Makefile
@@ -25,6 +25,9 @@
# WITH_POSTGRESQL:
# Enable support for logging to a Postgres database. Untested.
#
+# WITH_LIBWRAP:
+# Enable support for TCP wrappers.
+#
# SERVER:
# Builds as Yule, Samhain's central logging server. Mutually exclusive
# with CLIENT.
@@ -35,7 +38,7 @@
#
PORTNAME= samhain
-PORTVERSION= 1.7.12
+PORTVERSION= 1.8.0
CATEGORIES= security
MASTER_SITES= http://la-samhna.de/archive/ \
http://cold.darkambient.net/
@@ -48,8 +51,8 @@ COMMENT= The Samhain Intrusion Detection System
BUILD_DEPENDS= gpg:${PORTSDIR}/security/gnupg
.endif
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-login-watch --localstatedir=/var \
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-login-watch --localstatedir=/var \
--mandir=${PREFIX}/man --enable-suidcheck
.if defined(RUNAS_USER)
@@ -69,25 +72,28 @@ CONFIGURE_ARGS+= --with-database=mysql \
.if defined(WITH_POSTGRES)
CONFIGURE_ARGS+= --with-database=postgresql --enable-xml-log
.endif
+.if defined(WITH_LIBWRAP)
+CONFIGURE_ARGS+= --with-libwrap
+.endif
.if defined(CLIENT)
-CONFIGURE_ARGS+= --enable-network=client \
+CONFIGURE_ARGS+= --enable-network=client \
--with-data-file=REQ_FROM_SERVER/var/lib/samhain/data.samhain \
--with-config-file=REQ_FROM_SERVER --with-logserver=${LOG_SERVER}
PLIST_SUB+= SAMHAIN="" SETPWD="" YULE="@comment "
-EXTRA_PATCHES+= ${FILESDIR}/fixsamhainrc.patch
-MAN5= samhainrc.5
-MAN8= samhain.8
+EXTRA_PATCHES+= ${FILESDIR}/fixsamhainrc.patch
+MAN5= samhainrc.5
+MAN8= samhain.8
.elif defined(SERVER)
CONFIGURE_ARGS+= --enable-network=server
PLIST_SUB+= YULE="" SAMHAIN="@comment " SETPWD="@comment "
-EXTRA_PATCHES+= ${FILESDIR}/fixyulerc.patch
-MAN5= yulerc.5
-MAN8= yule.8
+EXTRA_PATCHES+= ${FILESDIR}/fixyulerc.patch
+MAN5= yulerc.5
+MAN8= yule.8
.else
PLIST_SUB+= SAMHAIN="" YULE="@comment " SETPWD="@comment "
-EXTRA_PATCHES+= ${FILESDIR}/fixsamhainrc.patch
-MAN5= samhainrc.5
-MAN8= samhain.8
+EXTRA_PATCHES+= ${FILESDIR}/fixsamhainrc.patch
+MAN5= samhainrc.5
+MAN8= samhain.8
.endif
.if defined(ALT_LOG_SERVER)
CONFIGURE_ARGS+= --with-altlogserver=${ALT_LOG_SERVER}
@@ -137,11 +143,11 @@ post-install:
@${CP} ${WRKSRC}/init/samhain.startFreeBSD ${PREFIX}/etc/rc.d/yule.sh.sample
.endif
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/samhain
- ${INSTALL_MAN} ${WRKSRC}/docs/MANUAL-1_7.ps ${PREFIX}/share/doc/samhain
- ${INSTALL_MAN} ${WRKSRC}/docs/MANUAL-1_7.html.tar ${PREFIX}/share/doc/samhain
- ${INSTALL_MAN} ${WRKSRC}/docs/HOWTO-client+server.html ${PREFIX}/share/doc/samhain
- ${INSTALL_MAN} ${WRKSRC}/docs/HOWTO-samhain+GnuPG.html ${PREFIX}/share/doc/samhain
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/docs/MANUAL-1_8.ps ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/docs/MANUAL-1_8.html.tar ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/docs/HOWTO-client+server.html ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/docs/HOWTO-samhain+GnuPG.html ${DOCSDIR}
.endif
install-user: