aboutsummaryrefslogtreecommitdiff
path: root/security/scanssh
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2003-03-03 23:37:22 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2003-03-03 23:37:22 +0000
commit4bcd02edbf59c5714ccb694ada0986e6f99eb093 (patch)
treeb2002dfd44ece6b889dc229e0baea9049d41fe8a /security/scanssh
parent423e0fbe6eb6d0a0820a24d60c7cf95be1aa6a1d (diff)
downloadports-4bcd02edbf59c5714ccb694ada0986e6f99eb093.tar.gz
ports-4bcd02edbf59c5714ccb694ada0986e6f99eb093.zip
Fix -p option on 64-bit archs.
Approved by: kris Obtained from: OpenBSD
Notes
Notes: svn path=/head/; revision=76821
Diffstat (limited to 'security/scanssh')
-rw-r--r--security/scanssh/Makefile1
-rw-r--r--security/scanssh/files/patch-pcapu.c16
2 files changed, 17 insertions, 0 deletions
diff --git a/security/scanssh/Makefile b/security/scanssh/Makefile
index bdb372a43d47..f02f06c34222 100644
--- a/security/scanssh/Makefile
+++ b/security/scanssh/Makefile
@@ -7,6 +7,7 @@
PORTNAME= scanssh
PORTVERSION= 1.60b
+PORTREVISION= 1
CATEGORIES= security net
MASTER_SITES= http://www.monkey.org/~provos/
DISTNAME= ${PORTNAME}-1.6b
diff --git a/security/scanssh/files/patch-pcapu.c b/security/scanssh/files/patch-pcapu.c
new file mode 100644
index 000000000000..2d2de113dc46
--- /dev/null
+++ b/security/scanssh/files/patch-pcapu.c
@@ -0,0 +1,16 @@
+
+$FreeBSD$
+
+--- pcapu.c.orig Mon Mar 3 17:55:38 2003
++++ pcapu.c Mon Mar 3 17:56:03 2003
+@@ -47,8 +47,8 @@
+ #include "config.h"
+
+ struct phdr {
+- unsigned long saddr;
+- unsigned long daddr;
++ in_addr_t saddr;
++ in_addr_t daddr;
+ char zero;
+ unsigned char protocol;
+ unsigned short length;