aboutsummaryrefslogtreecommitdiff
path: root/security/seahorse
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2008-05-26 23:02:29 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2008-05-26 23:02:29 +0000
commit1f74f7fc5451e25250ee01942fe458885a3eb6ae (patch)
tree0cabfa647ae820fb1ac819bb6282718f4faf7fdf /security/seahorse
parent66e0731bd76d3d1d19b29263ba6c7642d05e9e1a (diff)
downloadports-1f74f7fc5451e25250ee01942fe458885a3eb6ae.tar.gz
ports-1f74f7fc5451e25250ee01942fe458885a3eb6ae.zip
Update to 2.22.2.
Notes
Notes: svn path=/head/; revision=213722
Diffstat (limited to 'security/seahorse')
-rw-r--r--security/seahorse/Makefile3
-rw-r--r--security/seahorse/distinfo6
-rw-r--r--security/seahorse/files/patch-libseahorse_seahorse-secure-memory.c42
-rw-r--r--security/seahorse/files/patch-libseahorse_seahorse-secure-memory.h11
4 files changed, 4 insertions, 58 deletions
diff --git a/security/seahorse/Makefile b/security/seahorse/Makefile
index f993c9aeea58..4dd8f43a385b 100644
--- a/security/seahorse/Makefile
+++ b/security/seahorse/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= seahorse
-PORTVERSION= 2.22.1
-PORTREVISION= 3
+PORTVERSION= 2.22.2
CATEGORIES= security gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
diff --git a/security/seahorse/distinfo b/security/seahorse/distinfo
index bf887594f435..c653ae02e18e 100644
--- a/security/seahorse/distinfo
+++ b/security/seahorse/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/seahorse-2.22.1.tar.bz2) = e0e409ab825c954b5937b8b115dd5118
-SHA256 (gnome2/seahorse-2.22.1.tar.bz2) = e9791ad2d5ca9013db14310340227f8e5b1a519f2525066d10061c6d1b6f9c47
-SIZE (gnome2/seahorse-2.22.1.tar.bz2) = 2195121
+MD5 (gnome2/seahorse-2.22.2.tar.bz2) = 729654701cba82ce4b3cf26c73af1dd9
+SHA256 (gnome2/seahorse-2.22.2.tar.bz2) = c0b217462274eb07223c97651e15e633c2fa1087886362848e94cd696158aeba
+SIZE (gnome2/seahorse-2.22.2.tar.bz2) = 2121631
diff --git a/security/seahorse/files/patch-libseahorse_seahorse-secure-memory.c b/security/seahorse/files/patch-libseahorse_seahorse-secure-memory.c
deleted file mode 100644
index 4a6300bd26b9..000000000000
--- a/security/seahorse/files/patch-libseahorse_seahorse-secure-memory.c
+++ /dev/null
@@ -1,42 +0,0 @@
---- libseahorse/seahorse-secure-memory.c.orig 2008-04-12 12:09:58.000000000 -0400
-+++ libseahorse/seahorse-secure-memory.c 2008-04-12 12:10:05.000000000 -0400
-@@ -97,13 +97,31 @@
- void
- seahorse_secure_memory_init ()
- {
-- GMemVTable vtable;
--
-- memset (&vtable, 0, sizeof (vtable));
-- vtable.malloc = switch_malloc;
-- vtable.realloc = switch_realloc;
-- vtable.free = switch_free;
-- vtable.calloc = switch_calloc;
-- g_mem_set_vtable (&vtable);
-+ if (seahorse_try_gk_secure_memory() == TRUE) {
-+ GMemVTable vtable;
-+
-+ memset (&vtable, 0, sizeof (vtable));
-+ vtable.malloc = switch_malloc;
-+ vtable.realloc = switch_realloc;
-+ vtable.free = switch_free;
-+ vtable.calloc = switch_calloc;
-+ g_mem_set_vtable (&vtable);
-+ } else {
-+ g_warning ("Unable to allocate secure memory from gnome-keyring.\n");
-+ g_warning ("Proceeding with insecure password memory instead.\n");
-+ }
- }
-
-+gboolean
-+seahorse_try_gk_secure_memory ()
-+{
-+ gpointer p;
-+
-+ p = gnome_keyring_memory_try_alloc (10);
-+ if (p != NULL) {
-+ gnome_keyring_memory_free (p);
-+ return TRUE;
-+ }
-+
-+ return FALSE;
-+}
diff --git a/security/seahorse/files/patch-libseahorse_seahorse-secure-memory.h b/security/seahorse/files/patch-libseahorse_seahorse-secure-memory.h
deleted file mode 100644
index 354b563ac779..000000000000
--- a/security/seahorse/files/patch-libseahorse_seahorse-secure-memory.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- libseahorse/seahorse-secure-memory.h.orig 2008-04-11 09:33:34.000000000 -0400
-+++ libseahorse/seahorse-secure-memory.h 2008-04-11 09:34:12.000000000 -0400
-@@ -34,6 +34,7 @@
- } while (0)
-
- /* This must be called before any glib/gtk/gnome functions */
--void seahorse_secure_memory_init (void);
-+void seahorse_secure_memory_init (void);
-+gboolean seahorse_try_gk_secure_memory (void);
-
- #endif /* _SEAHORSE_SECURE_MEMORY_H_ */