aboutsummaryrefslogtreecommitdiff
path: root/security/shishi/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-04-28 20:17:43 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-04-28 20:17:43 +0000
commit0f84100cec9f68c7e7bc2ae2b6edc524cd954eb4 (patch)
tree96128de421626ed817865ebce96f17f92af13bb2 /security/shishi/Makefile
parent0c64c49cbd3750e5c6a0ae3338e32a2436312154 (diff)
downloadports-0f84100cec9f68c7e7bc2ae2b6edc524cd954eb4.tar.gz
ports-0f84100cec9f68c7e7bc2ae2b6edc524cd954eb4.zip
- Fix LIB_DEPENDS
- Fix handling PKGMESSAGE PR: ports/65996 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=107865
Diffstat (limited to 'security/shishi/Makefile')
-rw-r--r--security/shishi/Makefile22
1 files changed, 14 insertions, 8 deletions
diff --git a/security/shishi/Makefile b/security/shishi/Makefile
index 99bd36473be2..7b96af56634d 100644
--- a/security/shishi/Makefile
+++ b/security/shishi/Makefile
@@ -8,6 +8,7 @@
PORTNAME= shishi
PORTVERSION= 0.0.15
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://josefsson.org/${PORTNAME}/releases/
@@ -15,35 +16,40 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A free implementation of the Kerberos 5 network security system
LIB_DEPENDS= idn.13:${PORTSDIR}/devel/libidn \
+ gcrypt.10:${PORTSDIR}/security/libgcrypt-devel \
tasn1.2:${PORTSDIR}/security/libtasn1
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
USE_PERL5_BUILD= yes
USE_GNOME= gnomehack gnometarget pkgconfig
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib" \
MAKEINFO="makeinfo --no-split"
-CONFIGURE_ARGS= --without-libgcrypt --disable-starttls \
+CONFIGURE_ARGS= --disable-starttls \
--with-db-dir=/var/shishi
INSTALLS_SHLIB= yes
INFO= shishi
-.if !defined(WITHOUT_NLS)
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.else
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
-.else
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
.endif
-SED_SCRIPT+= -e 's,%%PREFIX%%,${PREFIX},g'
-
post-extract:
@${RM} -f ${WRKSRC}/doc/shishi.info*
+post-patch:
+ @${SED} -e 's,%%PREFIX%%,${PREFIX},g' \
+ ${FILESDIR}/pkg-message.in > ${PKGMESSAGE}
+
post-install:
- @${SED} ${SED_SCRIPT} < ${PKGMESSAGE}
+ @${CAT} ${PKGMESSAGE}
.include "Makefile.man"
.include <bsd.port.mk>