aboutsummaryrefslogtreecommitdiff
path: root/security/silktools
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-11-17 08:42:13 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-11-17 08:42:13 +0000
commit36377539599cc786b82de8e10ffcb08f0dcc30c3 (patch)
tree509740d138c2d46d9df2f5eddf722ae71c4c897d /security/silktools
parent27c05cfbd320b31c91961e4a0a87bafb88c9e7d7 (diff)
downloadports-36377539599cc786b82de8e10ffcb08f0dcc30c3.tar.gz
ports-36377539599cc786b82de8e10ffcb08f0dcc30c3.zip
- Update to 0.10.3
PR: ports/105591 Submitted by: David Thiel <lx@redundancy.redundancy.org> (maintainer)
Notes
Notes: svn path=/head/; revision=177437
Diffstat (limited to 'security/silktools')
-rw-r--r--security/silktools/Makefile33
-rw-r--r--security/silktools/distinfo6
-rw-r--r--security/silktools/files/patch-src_rw_rwpmatch_rwpdedupe.c38
-rw-r--r--security/silktools/pkg-plist19
4 files changed, 51 insertions, 45 deletions
diff --git a/security/silktools/Makefile b/security/silktools/Makefile
index 2ada95a719f6..1376666ca55f 100644
--- a/security/silktools/Makefile
+++ b/security/silktools/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= silktools
-PORTVERSION= 0.8.2
+PORTVERSION= 0.10.3
CATEGORIES= security net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -14,9 +14,36 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= lx@redundancy.redundancy.org
COMMENT= Tools for large-scale network capture analysis
+LIB_DEPENDS= lzo:${PORTSDIR}/archivers/lzo
+
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-lzo=${LOCALBASE}
USE_GMAKE= yes
MAKE_ARGS= CC="${CC}" GCC_FLAGS="" CFLAGS_RELEASE=""
-ALL_TARGET= release
+USE_LDCONFIG= yes
+USE_PERL5_BUILD= yes
+
+MAN1= rwip2cc.1 rwpmapbuild.1 mapsid.1 num2dot.1 rwaddrcount.1 rwappend.1 \
+ rwbag.1 rwbagbuild.1 rwbagcat.1 rwbagtool.1 rwcat.1 rwcount.1 \
+ rwcut.1 rwfileinfo.1 rwfilter.1 rwfglob.1 rwgroup.1 rwmatch.1 \
+ rwnetmask.1 rwrandomizeip.1 rwset.1 rwsetbuild.1 rwsetcat.1 rwsort.1 \
+ rwsetintersect.1 rwsetunion.1 rwstats.1 rwswapbytes.1 rwtotal.1 \
+ rwtuc.1 rwuniq.1 rwptoflow.1 rwpmatch.1 rwpdedupe.1 rwpcut.1
+
+MAN3= libaddrtype.3 libccfilter.3 libpmapfilter.3
+
+MAN5= sensorconf.5
+
+MAN8= rwflowpack.8 flowcap.8
+
+post-install:
+ @${MV} ${PREFIX}/share/silk/rwfpd.conf ${PREFIX}/share/silk/rwfpd.conf.sample
+ @${MV} ${PREFIX}/share/silk/flowcap.conf ${PREFIX}/share/silk/flowcap.conf.sample
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= Does not build on 4.x
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/security/silktools/distinfo b/security/silktools/distinfo
index 2fcde3651d4b..c09d08a5f4b4 100644
--- a/security/silktools/distinfo
+++ b/security/silktools/distinfo
@@ -1,3 +1,3 @@
-MD5 (silktools-0.8.2.tar.gz) = 2de3ff09eef509d7305c015256b27c94
-SHA256 (silktools-0.8.2.tar.gz) = 02dbbc2577740ad8383d493da1f98ea501d4457830761c50bcc0a4418d62509b
-SIZE (silktools-0.8.2.tar.gz) = 668647
+MD5 (silktools-0.10.3.tar.gz) = 6c00a89e4be16f9cea6cd1a376c8938e
+SHA256 (silktools-0.10.3.tar.gz) = 9a53c7acdb3cda500f47a5c26f0d2fae059bfa0253b38a12e4948c282ff016fd
+SIZE (silktools-0.10.3.tar.gz) = 1037403
diff --git a/security/silktools/files/patch-src_rw_rwpmatch_rwpdedupe.c b/security/silktools/files/patch-src_rw_rwpmatch_rwpdedupe.c
deleted file mode 100644
index 57c2ee9f4a5c..000000000000
--- a/security/silktools/files/patch-src_rw_rwpmatch_rwpdedupe.c
+++ /dev/null
@@ -1,38 +0,0 @@
---- src/rw/rwpmatch/rwpdedupe.c.orig Sun Mar 19 23:57:23 2006
-+++ src/rw/rwpmatch/rwpdedupe.c Sun Mar 19 23:57:45 2006
-@@ -782,13 +782,14 @@
- input_t *buffers,
- int index )
- {
-+ pcap_pkt_t *pkt;
-+ sk_link_err_t rv;
-+ sk_link_item_t *node;
-+
- assert( buffers != NULL );
- assert( index >= 0 );
- assert( index < g_input_count );
-
-- pcap_pkt_t *pkt;
-- sk_link_err_t rv;
-- sk_link_item_t *node;
- rv = skLinkGetHead( &node, buffers[index].head );
- if ( rv != SKLINK_OK ) {
- return NULL;
-@@ -808,13 +809,14 @@
- input_t *buffers,
- int index )
- {
-+ pcap_pkt_t *pkt;
-+ sk_link_err_t rv;
-+ sk_link_item_t *node;
-+
- assert( buffers != NULL );
- assert( index >= 0 );
- assert( index < g_input_count );
-
-- pcap_pkt_t *pkt;
-- sk_link_err_t rv;
-- sk_link_item_t *node;
- rv = skLinkGetTail( &node, buffers[index].head );
- if ( rv != SKLINK_OK ) {
- return NULL;
diff --git a/security/silktools/pkg-plist b/security/silktools/pkg-plist
index 909baddf132f..df10f316a5a4 100644
--- a/security/silktools/pkg-plist
+++ b/security/silktools/pkg-plist
@@ -4,6 +4,7 @@ bin/mapsid
bin/num2dot
bin/readset
bin/rwaddrcount
+bin/rwallformats
bin/rwappend
bin/rwbag
bin/rwbagbuild
@@ -18,6 +19,8 @@ bin/rwfilter
bin/rwflowpack
bin/rwfpd
bin/rwgroup
+bin/rwip2cc
+bin/rwpmapbuild
bin/rwmatch
bin/rwnetmask
bin/rwpcut
@@ -27,14 +30,28 @@ bin/rwptoflow
bin/rwrandomizeip
bin/rwrtd2split
bin/rwset
+bin/rwsetcat
+bin/rwsetintersect
+bin/rwsetbuild
+bin/rwsetunion
bin/rwset-union
bin/rwsort
bin/rwstats
bin/rwswapbytes
bin/rwtotal
+bin/rwtuc
bin/rwuniq
bin/setintersect
-lib/libccfilter_new.so
+bin/flowcap
+bin/rwflowcapd
+lib/libaddrtype.so
+lib/libccfilter.so
lib/libipfilter.so
+lib/libipport.so
+lib/libpmapfilter.so
+lib/librwp2f_minbytes.so
lib/librwslammer.so
lib/librwsynackfin.so
+share/silk/rwfpd.conf.sample
+share/silk/flowcap.conf.sample
+@dirrmtry share/silk