aboutsummaryrefslogtreecommitdiff
path: root/security/ssh2
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-01-02 19:35:26 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-01-02 19:35:26 +0000
commitcff16e3928514749f01f78399db6e69f46036010 (patch)
tree3be6f66540a91cec4c85907fd98147b235481317 /security/ssh2
parent1fa008a4fe05f7618801c9886afdacc60b4afb5f (diff)
downloadports-cff16e3928514749f01f78399db6e69f46036010.tar.gz
ports-cff16e3928514749f01f78399db6e69f46036010.zip
1.) If WITH_STATIC_SFTP is defined, ssh-chrootmgr works.
2.) If libX11.a exists and xauth not, the build of ssh2 fails. This patch fix this. 3.) ssh2/files/sshd.sh looks for the wrong pid file in /var/run. This patch fix this and adds 2> /dev/null to the sshd2 startup PR: 46012 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=72287
Diffstat (limited to 'security/ssh2')
-rw-r--r--security/ssh2/Makefile8
-rw-r--r--security/ssh2/files/sshd.sh12
2 files changed, 13 insertions, 7 deletions
diff --git a/security/ssh2/Makefile b/security/ssh2/Makefile
index d1dfe1689841..1af0638877fd 100644
--- a/security/ssh2/Makefile
+++ b/security/ssh2/Makefile
@@ -52,8 +52,14 @@ LIB_DEPENDS+= wrap.7:${PORTSDIR}/security/tcp_wrapper
.include <bsd.port.pre.mk>
+# This is necessary for a working ssh-chrootmgr. Added by mic@nethack.at
+#
+.if defined(WITH_STATIC_SFTP)
+CONFIGURE_ARGS+= --enable-static
+.endif
+
.if defined(WITH_X11) || (exists(${X11BASE}/lib/libX11.a) \
- && !defined(WITHOUT_X11))
+ && exists(${X11BASE}/bin/xauth) && !defined(WITHOUT_X11))
USE_XLIB= yes
PLIST_SUB= WITH_X11:=""
.else
diff --git a/security/ssh2/files/sshd.sh b/security/ssh2/files/sshd.sh
index dd882003037c..b7c5ac8d80e3 100644
--- a/security/ssh2/files/sshd.sh
+++ b/security/ssh2/files/sshd.sh
@@ -1,19 +1,19 @@
#!/bin/sh
case "$1" in
start)
- !!PREFIX!!/sbin/sshd
+ !!PREFIX!!/sbin/sshd 2> /dev/null
echo -n ' sshd'
;;
stop)
- if [ -f /var/run/sshd.pid ]; then
- kill -TERM `cat /var/run/sshd.pid`
- rm -f /var/run/sshd.pid
+ if [ -f /var/run/sshd2_22.pid ]; then
+ kill -TERM `cat /var/run/sshd2_22.pid`
+ rm -f /var/run/sshd2_22.pid
echo -n ' sshd'
fi
;;
restart)
- if [ -f /var/run/sshd.pid ]; then
- kill -HUP `cat /var/run/sshd.pid`
+ if [ -f /var/run/sshd2_22.pid ]; then
+ kill -HUP `cat /var/run/sshd2_22.pid`
echo 'sshd restarted'
fi
;;