aboutsummaryrefslogtreecommitdiff
path: root/security/sslscan
diff options
context:
space:
mode:
authorDennis Herrmann <dhn@FreeBSD.org>2011-06-21 15:52:37 +0000
committerDennis Herrmann <dhn@FreeBSD.org>2011-06-21 15:52:37 +0000
commit1bafd97ad031ab47bb28534559d321e2fc140f1d (patch)
tree5866b1b0e7fa244aead7799af01b7eeb16ccd2bf /security/sslscan
parent6ed83a7a19b34038b16479a998d89befa22f96be (diff)
downloadports-1bafd97ad031ab47bb28534559d321e2fc140f1d.tar.gz
ports-1bafd97ad031ab47bb28534559d321e2fc140f1d.zip
SSLScan is a fast SSL port scanner. SSLScan connects to SSL ports and determines
what ciphers are supported, which are the servers prefered ciphers, which SSL protocols are supported and returns the SSL certificate. Client certificates and private key can be configured and output is to text / XML. PR: ports/158111 Submitted by: Matthieu BOUTHORS <matthieu@labs.fr>
Notes
Notes: svn path=/head/; revision=276005
Diffstat (limited to 'security/sslscan')
-rw-r--r--security/sslscan/Makefile23
-rw-r--r--security/sslscan/distinfo2
-rw-r--r--security/sslscan/files/patch-Makefile22
-rw-r--r--security/sslscan/files/patch-sslscan.c10
-rw-r--r--security/sslscan/pkg-descr4
5 files changed, 61 insertions, 0 deletions
diff --git a/security/sslscan/Makefile b/security/sslscan/Makefile
new file mode 100644
index 000000000000..155018491567
--- /dev/null
+++ b/security/sslscan/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: sslscan
+# Date created: 21/6/2011
+# Whom: Matthieu BOUTHORS
+#
+# $FreeBSD$
+#
+
+PORTNAME= sslscan
+PORTVERSION= 1.8.2
+CATEGORIES= security
+MASTER_SITES= http://downloads.sourceforge.net/project/sslscan/sslscan/ \
+ http://mirror.labs.fr/pub/FreeBSD/distfiles/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= matthieu@labs.fr
+COMMENT= SSLScan is a fast SSL port scanner
+
+MAKE_ARGS= CC="${CC}" CFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+
+MAN1= sslscan.1
+PLIST_FILES= bin/sslscan
+
+.include <bsd.port.mk>
diff --git a/security/sslscan/distinfo b/security/sslscan/distinfo
new file mode 100644
index 000000000000..fa14826ee0eb
--- /dev/null
+++ b/security/sslscan/distinfo
@@ -0,0 +1,2 @@
+SHA256 (sslscan-1.8.2.tgz) = 3b728804456042d96d5c8ccd42326f8e5719d091986793bb7b852a36b50d2b3e
+SIZE (sslscan-1.8.2.tgz) = 22176
diff --git a/security/sslscan/files/patch-Makefile b/security/sslscan/files/patch-Makefile
new file mode 100644
index 000000000000..c1433953ab8c
--- /dev/null
+++ b/security/sslscan/files/patch-Makefile
@@ -0,0 +1,22 @@
+--- ./Makefile.orig 2009-09-01 14:35:59.000000000 +0200
++++ ./Makefile 2011-06-21 17:37:30.000000000 +0200
+@@ -1,13 +1,14 @@
+ SRCS = sslscan.c
+-BINPATH = /usr/bin/
+-MANPATH = /usr/share/man/
++BINPATH = ${PREFIX}/bin/
++MANPATH = ${PREFIX}/man
++CC = ${CC}
+
+ all:
+- gcc -g -Wall -lssl -o sslscan $(SRCS) $(LDFLAGS) $(CFLAGS)
++ ${CC} -g -Wall -lssl -o sslscan $(SRCS) $(LDFLAGS) $(CFLAGS)
+
+ install:
+- cp sslscan $(BINPATH)
+- cp sslscan.1 $(MANPATH)man1
++ install -s -m 755 sslscan $(BINPATH)
++ install -m 644 sslscan.1 $(MANPATH)/man1
+
+ uninstall:
+ rm -f $(BINPATH)sslscan
diff --git a/security/sslscan/files/patch-sslscan.c b/security/sslscan/files/patch-sslscan.c
new file mode 100644
index 000000000000..1bf34c61872c
--- /dev/null
+++ b/security/sslscan/files/patch-sslscan.c
@@ -0,0 +1,10 @@
+--- ./sslscan.c.orig 2009-09-01 14:35:59.000000000 +0200
++++ ./sslscan.c 2011-06-21 17:36:13.000000000 +0200
+@@ -41,6 +41,7 @@
+ #include <openssl/pkcs12.h>
+ #include <openssl/x509.h>
+ #include <openssl/x509v3.h>
++#include <netinet/in.h>
+
+ // Defines...
+ #define false 0
diff --git a/security/sslscan/pkg-descr b/security/sslscan/pkg-descr
new file mode 100644
index 000000000000..112c7f429b82
--- /dev/null
+++ b/security/sslscan/pkg-descr
@@ -0,0 +1,4 @@
+SSLScan is a fast SSL port scanner. SSLScan connects to SSL ports and determines
+what ciphers are supported, which are the servers prefered ciphers, which SSL
+protocols are supported and returns the SSL certificate. Client certificates and
+private key can be configured and output is to text / XML.