aboutsummaryrefslogtreecommitdiff
path: root/security/vida/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2007-01-31 14:09:55 +0000
committerPav Lucistnik <pav@FreeBSD.org>2007-01-31 14:09:55 +0000
commiteb81a88093e7d71530eebb2957f8ba4317b26ee6 (patch)
tree9290c97700f22b8ed6b87a10fda7d195dac09f04 /security/vida/Makefile
parente6b247dce1d9f6355a583ef6269fdbba110eaea8 (diff)
downloadports-eb81a88093e7d71530eebb2957f8ba4317b26ee6.tar.gz
ports-eb81a88093e7d71530eebb2957f8ba4317b26ee6.zip
- Patch net/libnet* to versioned libraries and header files, so they can
coexist PR: ports/103861 Submitted by: alepulver Tested by: pointyhat With hat: portmgr
Notes
Notes: svn path=/head/; revision=183770
Diffstat (limited to 'security/vida/Makefile')
-rw-r--r--security/vida/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/security/vida/Makefile b/security/vida/Makefile
index 3e8635cd9308..059fa7514985 100644
--- a/security/vida/Makefile
+++ b/security/vida/Makefile
@@ -7,23 +7,25 @@
PORTNAME= vida
PORTVERSION= 0.7.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
MASTER_SITES= http://vidatapipe.sourceforge.net/
MAINTAINER= mich@FreeBSD.org
COMMENT= Vida is a multi-datapipe handler
-BUILD_DEPENDS= libnet*<=1.1.0,1:${PORTSDIR}/net/libnet10
+BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet10
-LDFLAGS+= -pthread -lncurses -lpcap -lnet
+LDFLAGS+= ${PTHREAD_LIBS} -lncurses -lpcap `${LIBNET_CONFIG} --libs`
WRKSRC= ${WRKDIR}/${PORTNAME}
+LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet10-config
+
do-build:
cd ${WRKSRC} && \
- ${CC} -I${LOCALBASE}/include -L${LOCALBASE}/lib ${CFLAGS} vida.c funz.c dnshijacking.c \
- ${LDFLAGS} `libnet-config --defines` -o ${PORTNAME}
+ ${CC} `${LIBNET_CONFIG} --defines --cflags` ${CFLAGS} \
+ vida.c funz.c dnshijacking.c ${LDFLAGS} -o ${PORTNAME}
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin