aboutsummaryrefslogtreecommitdiff
path: root/security/webfwlog
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2005-10-13 02:16:48 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2005-10-13 02:16:48 +0000
commit9dcc875fb5c81bddfd3f885da24baadf037ad5d8 (patch)
treecc2942bd3ff769e37d26642990ac0c93dd4cf178 /security/webfwlog
parent67b2b68c5ba4b19104976c79df4f7bb412f0819d (diff)
downloadports-9dcc875fb5c81bddfd3f885da24baadf037ad5d8.tar.gz
ports-9dcc875fb5c81bddfd3f885da24baadf037ad5d8.zip
New port: security/webfwlog Web-based firewall log analyzer
Webfwlog is a web-based firewall log analysis and reporting tool, and supports ipfilter and ipfw log file formats. It is interactive and allow the user to "drill-down" from a summary report to packet details logged. It also has great flexibility in the format of the output and which logged records are included. Sample report definitions are included and are saved in a database (MySQL or PostgreSQL) and can be modified by the user. More info at: http://www.webfwlog.net PR: ports/80352 Submitted by: Bob Hockney <zeus@ix.netcom.com>
Notes
Notes: svn path=/head/; revision=145189
Diffstat (limited to 'security/webfwlog')
-rw-r--r--security/webfwlog/Makefile103
-rw-r--r--security/webfwlog/distinfo4
-rw-r--r--security/webfwlog/files/pkg-message.in5
-rw-r--r--security/webfwlog/pkg-descr16
-rw-r--r--security/webfwlog/pkg-message5
-rw-r--r--security/webfwlog/pkg-plist73
6 files changed, 206 insertions, 0 deletions
diff --git a/security/webfwlog/Makefile b/security/webfwlog/Makefile
new file mode 100644
index 000000000000..a2ddf456e8a1
--- /dev/null
+++ b/security/webfwlog/Makefile
@@ -0,0 +1,103 @@
+# New ports collection makefile for: webfwlog
+# Date created: 21 November 2004
+# Whom: Bob Hockney <zeus@ix.netcom.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= webfwlog
+PORTVERSION= 0.91
+CATEGORIES= security
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+PATCH_SITES= http://devel.webfwlog.net/download/patches/
+PATCHFILES= webfwlog-0.91-order_state.patch
+PATCH_DIST_STRIP= -p1
+
+MAINTAINER= zeus@ix.netcom.com
+COMMENT= A web-based firewall log analyzer
+
+OPTIONS= MYSQL "Include MySQL Support" on \
+ POSTGRESQL "Include PostgreSQL Support" off
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+=--with-html-doc-root=${PREFIX}/${HTML_DOC_ROOT}
+CONFIGURE_ARGS+=--enable-syslog
+
+USE_PHP= yes
+WANT_PHP_WEB= yes
+
+# Set HTML_DOC_ROOT to your webserver's Document Root where you
+# want to install webfwlog, relative to ${PREFIX}.
+
+HTML_DOC_ROOT?= www/data
+
+PLIST_SUB= HTML_DOC_ROOT=${HTML_DOC_ROOT}
+
+SUB_FILES= pkg-message
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_MYSQL)
+USE_MYSQL= yes
+CONFIGURE_ARGS+=--with-mysql
+.endif
+
+.if defined(WITH_POSTGRESQL)
+USE_PGSQL=
+CONFIGURE_ARGS+=--with-pgsql
+.endif
+
+BINGRP= ${WWWGRP}
+BINMODE= 4550
+
+pre-install:
+ @${MKDIR} ${PREFIX}/${HTML_DOC_ROOT}
+
+post-install:
+
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_MAN} ${WRKSRC}/COPYING ${WRKSRC}/AUTHORS ${WRKSRC}/README \
+ ${WRKSRC}/INSTALL ${WRKSRC}/CREDITS ${DOCSDIR}
+ @${INSTALL_MAN} ${WRKSRC}/ChangeLog ${WRKSRC}/ReleaseNotes ${DOCSDIR}
+
+ @${MKDIR} ${DOCSDIR}/mysql/scripts
+ @${INSTALL_MAN} ${WRKSRC}/mysql/README ${WRKSRC}/mysql/setup ${DOCSDIR}/mysql
+ @${INSTALL_MAN} ${WRKSRC}/mysql/scripts/* ${DOCSDIR}/mysql/scripts
+ @${CHMOD} a+x ${DOCSDIR}/mysql/setup
+
+ @${MKDIR} ${DOCSDIR}/pgsql/scripts
+ @${INSTALL_MAN} ${WRKSRC}/pgsql/README ${WRKSRC}/pgsql/setup ${DOCSDIR}/pgsql
+ @${INSTALL_MAN} ${WRKSRC}/pgsql/scripts/* ${DOCSDIR}/pgsql/scripts
+ @${CHMOD} a+x ${DOCSDIR}/pgsql/setup
+
+ @${MKDIR} ${EXAMPLESDIR}
+ @${INSTALL_MAN} ${WRKSRC}/examples/* ${EXAMPLESDIR}
+.endif
+
+ @if test -f ${PREFIX}/etc/webfwlog.conf; \
+ then \
+ ${CHOWN} :${WWWGRP} ${PREFIX}/etc/webfwlog.conf; \
+ ${CHMOD} 0640 ${PREFIX}/etc/webfwlog.conf; \
+ fi
+ @${INSTALL_DATA} ${WRKSRC}/webfwlog.conf ${PREFIX}/etc/webfwlog.conf.sample
+ @${CHOWN} :${WWWGRP} ${PREFIX}/etc/webfwlog.conf.sample
+ @${CHMOD} 0640 ${PREFIX}/etc/webfwlog.conf.sample
+ @if test -f ${PREFIX}/etc/webfwlog.conf && \
+ test -f ${PREFIX}/etc/webfwlog.conf.sample && \
+ test "`diff ${PREFIX}/etc/webfwlog.conf ${PREFIX}/etc/webfwlog.conf.sample`" ; \
+ then :; \
+ else \
+ ${RM} -f ${PREFIX}/etc/webfwlog.conf; \
+ fi
+ @${RM} -f ${PREFIX}/etc/webfwlog.conf.new
+ @${CHMOD} 0555 ${PREFIX}/${HTML_DOC_ROOT}/webfwlog
+ @${CHMOD} 0555 ${PREFIX}/${HTML_DOC_ROOT}/webfwlog/include
+
+ @${ECHO}
+ @${CAT} pkg-message
+ @${ECHO}
+
+.include <bsd.port.post.mk>
diff --git a/security/webfwlog/distinfo b/security/webfwlog/distinfo
new file mode 100644
index 000000000000..92f930e5ad01
--- /dev/null
+++ b/security/webfwlog/distinfo
@@ -0,0 +1,4 @@
+MD5 (webfwlog-0.91.tar.gz) = c60ffe77ffa92f339410dd43cf8b4825
+SIZE (webfwlog-0.91.tar.gz) = 244307
+MD5 (webfwlog-0.91-order_state.patch) = 9e4af7759320e08957915fc394f2e0d1
+SIZE (webfwlog-0.91-order_state.patch) = 1230
diff --git a/security/webfwlog/files/pkg-message.in b/security/webfwlog/files/pkg-message.in
new file mode 100644
index 000000000000..f7d96251a245
--- /dev/null
+++ b/security/webfwlog/files/pkg-message.in
@@ -0,0 +1,5 @@
+Webfwlog-0.91 has been installed. You should read the README in the mysql or
+pgsql directoy in %%DOCSDIR%% for information
+on setting up your MySQL or PostgreSQL server for use with webfwlog, and also
+copy the webfwlog.conf.sample file in %%PREFIX%%/etc to webfwlog.conf and
+adjust it to your installation. This file is well-commented.
diff --git a/security/webfwlog/pkg-descr b/security/webfwlog/pkg-descr
new file mode 100644
index 000000000000..c9b80ff078da
--- /dev/null
+++ b/security/webfwlog/pkg-descr
@@ -0,0 +1,16 @@
+Webfwlog is a flexible web-based analysis and reporting tool for firewall
+logs. It supports log files in standard ipfilter or ipfw format.
+
+With Webfwlog you can design reports to use on your firewall logs in whatever
+configuration you desire. Included are example reports as a starting
+point. You can sort a report with a single click, "drill-down" on the reports
+all the way to the packet level, and save your reports for later use. You can
+also create a link directly to any saved report.
+
+Webfwlog requires a web server with PHP support and a MySQL or PostgresSQL
+database server.
+
+WWW: http://www.webfwlog.net
+
+- Bob Hockney
+zeus@ix.netcom.com
diff --git a/security/webfwlog/pkg-message b/security/webfwlog/pkg-message
new file mode 100644
index 000000000000..cfa644a1aee0
--- /dev/null
+++ b/security/webfwlog/pkg-message
@@ -0,0 +1,5 @@
+Webfwlog-0.91 has been installed. You should read the README in the mysql or
+pgsql directoy in documentaton directory for information on setting up your
+MySQL or PostgreSQL server for use with webfwlog, and also copy the
+webfwlog.conf.sample file in etc to webfwlog.conf and adjust it to your
+installation. This file is well-commented.
diff --git a/security/webfwlog/pkg-plist b/security/webfwlog/pkg-plist
new file mode 100644
index 000000000000..b747498f0a07
--- /dev/null
+++ b/security/webfwlog/pkg-plist
@@ -0,0 +1,73 @@
+bin/wfwl_syslog
+etc/webfwlog.conf.sample
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/CREDITS
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/ReleaseNotes
+%%PORTDOCS%%%%DOCSDIR%%/mysql/README
+%%PORTDOCS%%%%DOCSDIR%%/mysql/setup
+%%PORTDOCS%%%%DOCSDIR%%/mysql/scripts/temp_grants
+%%PORTDOCS%%%%DOCSDIR%%/mysql/scripts/ulog_copy
+%%PORTDOCS%%%%DOCSDIR%%/mysql/scripts/ulog_local
+%%PORTDOCS%%%%DOCSDIR%%/mysql/scripts/ulogd_grants
+%%PORTDOCS%%%%DOCSDIR%%/mysql/scripts/wfwl_grants
+%%PORTDOCS%%%%DOCSDIR%%/mysql/scripts/wfwl_hostnames_create
+%%PORTDOCS%%%%DOCSDIR%%/mysql/scripts/wfwl_reports_addcol
+%%PORTDOCS%%%%DOCSDIR%%/mysql/scripts/wfwl_reports_altercol
+%%PORTDOCS%%%%DOCSDIR%%/mysql/scripts/wfwl_reports_create
+%%PORTDOCS%%%%DOCSDIR%%/mysql/scripts/wfwl_services_create
+%%PORTDOCS%%%%DOCSDIR%%/pgsql/README
+%%PORTDOCS%%%%DOCSDIR%%/pgsql/setup
+%%PORTDOCS%%%%DOCSDIR%%/pgsql/scripts/ulog_copy
+%%PORTDOCS%%%%DOCSDIR%%/pgsql/scripts/ulog_local
+%%PORTDOCS%%%%DOCSDIR%%/pgsql/scripts/ulogd_73_grants
+%%PORTDOCS%%%%DOCSDIR%%/pgsql/scripts/ulogd_grants
+%%PORTDOCS%%%%DOCSDIR%%/pgsql/scripts/wfwl_73_grants
+%%PORTDOCS%%%%DOCSDIR%%/pgsql/scripts/wfwl_functions
+%%PORTDOCS%%%%DOCSDIR%%/pgsql/scripts/wfwl_grants
+%%PORTDOCS%%%%DOCSDIR%%/pgsql/scripts/wfwl_hostnames_create
+%%PORTDOCS%%%%DOCSDIR%%/pgsql/scripts/wfwl_reports_addcol
+%%PORTDOCS%%%%DOCSDIR%%/pgsql/scripts/wfwl_reports_create
+%%PORTDOCS%%%%DOCSDIR%%/pgsql/scripts/wfwl_services_create
+%%PORTDOCS%%%%EXAMPLESDIR%%/basic
+%%PORTDOCS%%%%EXAMPLESDIR%%/current_count
+%%PORTDOCS%%%%EXAMPLESDIR%%/current_dport
+%%PORTDOCS%%%%EXAMPLESDIR%%/last20hosts
+%%PORTDOCS%%%%EXAMPLESDIR%%/latest_logged_packets
+%%PORTDOCS%%%%EXAMPLESDIR%%/recent_active
+%%PORTDOCS%%%%EXAMPLESDIR%%/tcpports
+%%PORTDOCS%%%%EXAMPLESDIR%%/tcpsyn
+%%PORTDOCS%%%%EXAMPLESDIR%%/udpports
+%%HTML_DOC_ROOT%%/webfwlog/include/config.php
+%%HTML_DOC_ROOT%%/webfwlog/include/criteria.php
+%%HTML_DOC_ROOT%%/webfwlog/include/debug.php
+%%HTML_DOC_ROOT%%/webfwlog/include/delete_report.php
+%%HTML_DOC_ROOT%%/webfwlog/include/edit_doc.php
+%%HTML_DOC_ROOT%%/webfwlog/include/edit_report.php
+%%HTML_DOC_ROOT%%/webfwlog/include/functions.php
+%%HTML_DOC_ROOT%%/webfwlog/include/home.php
+%%HTML_DOC_ROOT%%/webfwlog/include/html_out.php
+%%HTML_DOC_ROOT%%/webfwlog/include/import.php
+%%HTML_DOC_ROOT%%/webfwlog/include/orders.php
+%%HTML_DOC_ROOT%%/webfwlog/include/packet.php
+%%HTML_DOC_ROOT%%/webfwlog/include/save_report.php
+%%HTML_DOC_ROOT%%/webfwlog/include/selection.php
+%%HTML_DOC_ROOT%%/webfwlog/include/sorting.php
+%%HTML_DOC_ROOT%%/webfwlog/include/sql.php
+%%HTML_DOC_ROOT%%/webfwlog/include/state.php
+%%HTML_DOC_ROOT%%/webfwlog/include/static.php
+%%HTML_DOC_ROOT%%/webfwlog/include/syslog.php
+%%HTML_DOC_ROOT%%/webfwlog/include/update_cache.php
+%%HTML_DOC_ROOT%%/webfwlog/style.css
+%%HTML_DOC_ROOT%%/webfwlog/index.php
+@dirrm %%HTML_DOC_ROOT%%/webfwlog/include
+@dirrm %%HTML_DOC_ROOT%%/webfwlog
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/pgsql/scripts
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/pgsql
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/mysql/scripts
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/mysql
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%