aboutsummaryrefslogtreecommitdiff
path: root/security/xinetd
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1998-07-11 00:37:53 +0000
committerSteve Price <steve@FreeBSD.org>1998-07-11 00:37:53 +0000
commit4b2153bbb8c72c22cb9f43ec6e817f7b1289772d (patch)
tree220a57aabdad6a14b65e26f5d78348c36e18cc64 /security/xinetd
parent6fcb930953a87bfdc6e7a2aefb909cd4713c88cc (diff)
downloadports-4b2153bbb8c72c22cb9f43ec6e817f7b1289772d.tar.gz
ports-4b2153bbb8c72c22cb9f43ec6e817f7b1289772d.zip
Make this port ${PREFIX}-friendly and have it install its
files with the right permissions by hacking up the do-install target to do it ourselves. PR: 7194 Hinted at by: hoek@freebsd.org
Notes
Notes: svn path=/head/; revision=11818
Diffstat (limited to 'security/xinetd')
-rw-r--r--security/xinetd/Makefile9
-rw-r--r--security/xinetd/files/patch-aa32
2 files changed, 6 insertions, 35 deletions
diff --git a/security/xinetd/Makefile b/security/xinetd/Makefile
index 89e1e9f39682..e49b35c6ebed 100644
--- a/security/xinetd/Makefile
+++ b/security/xinetd/Makefile
@@ -3,7 +3,7 @@
# Date created: 28 June 1996
# Whom: markm
#
-# $Id: Makefile,v 1.3 1996/11/18 14:13:43 asami Exp $
+# $Id: Makefile,v 1.4 1997/12/04 03:40:06 vanilla Exp $
#
DISTNAME= xinetd-2.2.1
@@ -19,8 +19,10 @@ do-build:
cd ${WRKSRC} ; ./compile-src -os freebsd2
do-install:
- cd ${WRKSRC}/xinetd ; make install
- cd ${WRKSRC}/xinetd ; make install.man
+ ${INSTALL_PROGRAM} ${WRKSRC}/xinetd/xinetd ${PREFIX}/sbin
+ ${INSTALL_MAN} ${WRKSRC}/xinetd/xinetd.man ${PREFIX}/man/man1/xinetd.1
+ ${INSTALL_MAN} ${WRKSRC}/xinetd/xinetd.conf.man ${PREFIX}/man/man5/xinetd.conf.5
+ ${INSTALL_MAN} ${WRKSRC}/xinetd/xinetd.log.man ${PREFIX}/man/man5/xinetd.log.5
post-install:
@if [ ! -f ${PREFIX}/etc/rc.d/xinetd.sh ]; then \
@@ -29,4 +31,5 @@ post-install:
${ECHO} "[ -x ${PREFIX}/sbin/xinetd ] && ${PREFIX}/sbin/xinetd && echo -n' xinetd'" >> ${PREFIX}/etc/rc.d/xinetd.sh; \
chmod 751 ${PREFIX}/etc/rc.d/xinetd.sh; \
fi
+
.include <bsd.port.mk>
diff --git a/security/xinetd/files/patch-aa b/security/xinetd/files/patch-aa
index 98168ab42f0b..c336d6ba4e2c 100644
--- a/security/xinetd/files/patch-aa
+++ b/security/xinetd/files/patch-aa
@@ -18,35 +18,3 @@
/*
* When explicit values are given for enum's, that is because the structures
---- xinetd/Makefile.orig Mon Apr 14 05:29:01 1997
-+++ xinetd/Makefile Wed Sep 24 04:54:21 1997
-@@ -131,7 +131,8 @@
-
- XMODE = -m 700 # mode for executables
- FMODE = -m 640 # mode for anything but executables
--INSTALL = install -c
-+INSTALL_PROGRAM = install -c -s
-+INSTALL_DATA = install -c
-
- LINT_FLAGS = -hbux
- PAGER = less
-@@ -178,16 +179,16 @@
- rm -f $(OPT_SOURCE) $(OPT_HEADER)
-
- install: $(PROGRAM)
-- $(INSTALL) $(XMODE) $(PROGRAM) $(INSTALLDIR)
-+ $(INSTALL_PROGRAM) $(XMODE) $(PROGRAM) $(INSTALLDIR)
-
- install.man:
- if test "$(MANPROGDIR)" ; then \
-- $(INSTALL) $(FMODE) $(MANPROGFILE) $(MANPROGDIR)/$(MANPROGPAGE) ;\
-+ $(INSTALL_DATA) $(FMODE) $(MANPROGFILE) $(MANPROGDIR)/$(MANPROGPAGE) ;\
- fi
- if test "$(MANDATADIR)" ; then \
- for i in $(MANDATANAMES) ; do \
- name=$(PROGRAM).$$i ; \
-- $(INSTALL) $(FMODE) $$name.man $(MANDATADIR)/$$name.$(MANDATASECTION);\
-+ $(INSTALL_DATA) $(FMODE) $$name.man $(MANDATADIR)/$$name.$(MANDATASECTION);\
- done ;\
- fi
-