aboutsummaryrefslogtreecommitdiff
path: root/security/xinetd
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2000-03-26 09:25:40 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2000-03-26 09:25:40 +0000
commit49fb142d0b2866975bd3359d340e54f907c15fb0 (patch)
treed73408a65191269b094e415e8923a2770f3d3dd9 /security/xinetd
parent513bad06faa1944a78e07ee89a86347eed7d9fac (diff)
downloadports-49fb142d0b2866975bd3359d340e54f907c15fb0.tar.gz
ports-49fb142d0b2866975bd3359d340e54f907c15fb0.zip
Upgrade to 2.1.8.8p2, and add libwrap & loadavg support.
Notes
Notes: svn path=/head/; revision=27058
Diffstat (limited to 'security/xinetd')
-rw-r--r--security/xinetd/Makefile5
-rw-r--r--security/xinetd/distinfo2
-rw-r--r--security/xinetd/files/patch-ae21
3 files changed, 25 insertions, 3 deletions
diff --git a/security/xinetd/Makefile b/security/xinetd/Makefile
index 681c13d6b9d8..0a3da14a97e7 100644
--- a/security/xinetd/Makefile
+++ b/security/xinetd/Makefile
@@ -1,12 +1,12 @@
# New ports collection makefile for: xinetd
-# Version required: 2.1.8.8p1
+# Version required: 2.1.8.8p2
# Date created: 28 June 1996
# Whom: markm
#
# $FreeBSD$
#
-DISTNAME= xinetd-2.1.8.8p1
+DISTNAME= xinetd-2.1.8.8p2
CATEGORIES= security
MASTER_SITES= http://synack.net/xinetd/
@@ -15,6 +15,7 @@ MAINTAINER= vanilla@FreeBSD.org
FETCH_BEFORE_ARGS= -b
GNU_CONFIGURE= yes
ALL_TARGET= build
+CONFIGURE_ARGS= --with-loadavg --with-libwrap
MAN5= xinetd.conf.5
MAN8= xinetd.8 xinetd.log.8
diff --git a/security/xinetd/distinfo b/security/xinetd/distinfo
index 46cd0a072ece..c11aa6263a7e 100644
--- a/security/xinetd/distinfo
+++ b/security/xinetd/distinfo
@@ -1 +1 @@
-MD5 (xinetd-2.1.8.8p1.tar.gz) = 00d4dc83c562f36a9938ea5ce02665e3
+MD5 (xinetd-2.1.8.8p2.tar.gz) = e475241f875f47d5efa59ce886191f24
diff --git a/security/xinetd/files/patch-ae b/security/xinetd/files/patch-ae
new file mode 100644
index 000000000000..edf97c8a8cac
--- /dev/null
+++ b/security/xinetd/files/patch-ae
@@ -0,0 +1,21 @@
+--- xinetd/xgetloadavg.c.orig Sun Mar 26 12:17:16 2000
++++ xinetd/xgetloadavg.c Sun Mar 26 12:19:37 2000
+@@ -79,3 +79,18 @@
+ }
+ #endif /* HAVE_KSTAT */
+ #endif /* solaris */
++#ifdef __FreeBSD__
++
++#include <stdio.h>
++#include <sys/param.h>
++#include <sys/fcntl.h>
++
++double xgetloadavg ()
++{
++ double ret[3];
++
++ getloadavg (ret, sizeof (ret) / sizeof (ret[0]));
++
++ return ret[0];
++}
++#endif /* __FreeBSD__ */