aboutsummaryrefslogtreecommitdiff
path: root/security/xinetd
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2003-05-03 21:01:46 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2003-05-03 21:01:46 +0000
commitd046fccaefd3931f279c7f4214cec7f9fb6b4043 (patch)
tree843ac5a4024e1c49fa4bf429b244f0c717e86197 /security/xinetd
parentffc9c36caae708ba6e3ed9f9646c29e465792bbd (diff)
downloadports-d046fccaefd3931f279c7f4214cec7f9fb6b4043.tar.gz
ports-d046fccaefd3931f279c7f4214cec7f9fb6b4043.zip
Upgrade to 2.3.11.
PR: ports/51134 Submitted by: Christopher Nehren <apeiron@comcast.net>
Notes
Notes: svn path=/head/; revision=80068
Diffstat (limited to 'security/xinetd')
-rw-r--r--security/xinetd/Makefile2
-rw-r--r--security/xinetd/distinfo2
-rw-r--r--security/xinetd/files/patch-ad11
-rw-r--r--security/xinetd/files/patch-ae24
-rw-r--r--security/xinetd/files/patch-xinetd::signals.c40
5 files changed, 42 insertions, 37 deletions
diff --git a/security/xinetd/Makefile b/security/xinetd/Makefile
index b1e33b92305d..f3bf93f53c35 100644
--- a/security/xinetd/Makefile
+++ b/security/xinetd/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= xinetd
-PORTVERSION= 2.3.10
+PORTVERSION= 2.3.11
PORTREVISION= 0
CATEGORIES= security ipv6
MASTER_SITES= http://www.xinetd.org/
diff --git a/security/xinetd/distinfo b/security/xinetd/distinfo
index c0b97aefe18d..8016b43d28f4 100644
--- a/security/xinetd/distinfo
+++ b/security/xinetd/distinfo
@@ -1 +1 @@
-MD5 (xinetd-2.3.10.tar.gz) = c5178a634c0e621d644119f24d274885
+MD5 (xinetd-2.3.11.tar.gz) = 37df520fb367beae040daac2b63be5a5
diff --git a/security/xinetd/files/patch-ad b/security/xinetd/files/patch-ad
deleted file mode 100644
index 51a095c22621..000000000000
--- a/security/xinetd/files/patch-ad
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.orig Fri May 10 00:24:38 2002
-+++ configure Fri May 10 00:25:20 2002
-@@ -7096,7 +7096,7 @@
- echo "${ECHO_T}no" >&6
- fi;
- ;;
--linux*)
-+linux*|freebsd*)
-
- echo "$as_me:$LINENO: checking for main in -lcrypt" >&5
- echo $ECHO_N "checking for main in -lcrypt... $ECHO_C" >&6
diff --git a/security/xinetd/files/patch-ae b/security/xinetd/files/patch-ae
deleted file mode 100644
index 8aceb7d3f2f9..000000000000
--- a/security/xinetd/files/patch-ae
+++ /dev/null
@@ -1,24 +0,0 @@
---- xinetd/xgetloadavg.c.orig Wed Aug 16 01:32:49 2000
-+++ xinetd/xgetloadavg.c Sat Nov 11 14:48:29 2000
-@@ -77,6 +77,21 @@
- }
- #endif /* HAVE_KSTAT */
- #endif /* solaris */
-+#ifdef __FreeBSD__
-+
-+#include <stdio.h>
-+#include <sys/param.h>
-+#include <sys/fcntl.h>
-+
-+double xgetloadavg ()
-+{
-+ double ret[3];
-+
-+ getloadavg (ret, sizeof (ret) / sizeof (ret[0]));
-+
-+ return ret[0];
-+}
-+#endif /* __FreeBSD__ */
-
- #ifdef __osf__
-
diff --git a/security/xinetd/files/patch-xinetd::signals.c b/security/xinetd/files/patch-xinetd::signals.c
new file mode 100644
index 000000000000..1861275ac1b3
--- /dev/null
+++ b/security/xinetd/files/patch-xinetd::signals.c
@@ -0,0 +1,40 @@
+--- xinetd/signals.c.orig Sun May 4 04:56:37 2003
++++ xinetd/signals.c Sun May 4 04:57:19 2003
+@@ -353,7 +353,7 @@
+
+ switch (sig) {
+ case SIGSEGV:
+- switch (siginfo->si_code) {
++/* switch (siginfo->si_code) {
+ case SEGV_MAPERR:
+ msg(LOG_CRIT, func, "address is not mapped for object");
+ break;
+@@ -361,13 +361,13 @@
+ msg(LOG_CRIT, func,
+ "invalid permissions for mapped object");
+ break;
+- default:
++ default:*/
+ msg(LOG_CRIT, func, "unknown fault code");
+- }
++ // }
+ break;
+
+ case SIGBUS:
+- switch(siginfo->si_code) {
++/* switch(siginfo->si_code) {
+ case BUS_ADRALN:
+ msg(LOG_CRIT, func, "invalid address alignment");
+ break;
+@@ -377,9 +377,9 @@
+ case BUS_OBJERR:
+ msg(LOG_CRIT, func, "object-specific hardware error");
+ break;
+- default:
++ default:*/
+ msg(LOG_CRIT, func, "unknown fault code");
+- }
++ //}
+ break;
+ }
+