aboutsummaryrefslogtreecommitdiff
path: root/security/xyssl
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2007-04-08 10:15:35 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2007-04-08 10:15:35 +0000
commit9ac356527f65cc223d3c3c03d0934e14fd8c17cd (patch)
tree971796a4febb93fc7da97907ba5e0649ab2b2b09 /security/xyssl
parent4216d15514282e01b2242b97af1e00b29dedfbce (diff)
downloadports-9ac356527f65cc223d3c3c03d0934e14fd8c17cd.tar.gz
ports-9ac356527f65cc223d3c3c03d0934e14fd8c17cd.zip
Add xyssl 0.6, a liteweight SSL and TLS toolkit for C developers.
PR: ports/111279 Submitted by: mdh <mdh at solitox.net>
Notes
Notes: svn path=/head/; revision=189475
Diffstat (limited to 'security/xyssl')
-rw-r--r--security/xyssl/Makefile22
-rw-r--r--security/xyssl/distinfo3
-rw-r--r--security/xyssl/files/patch-Makefile37
-rw-r--r--security/xyssl/pkg-descr7
-rw-r--r--security/xyssl/pkg-plist29
5 files changed, 98 insertions, 0 deletions
diff --git a/security/xyssl/Makefile b/security/xyssl/Makefile
new file mode 100644
index 000000000000..aec22de446fe
--- /dev/null
+++ b/security/xyssl/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: xyssl
+# Date created: 2007-04-05
+# Whom: mdh <mdh@solitox.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xyssl
+PORTVERSION= 0.6
+CATEGORIES= security devel
+MASTER_SITES= http://xyssl.org/code/download/ \
+ ftp://ftp.solitox.net/pub/XySSL/
+DISTNAME= xyssl-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= mdh@solitox.net
+COMMENT= A liteweight SSL and TLS toolkit for C developers
+
+# HAS_CONFIGURE= no
+# GNU_CONFIGURE= no
+
+.include <bsd.port.mk>
diff --git a/security/xyssl/distinfo b/security/xyssl/distinfo
new file mode 100644
index 000000000000..32db02de9b2f
--- /dev/null
+++ b/security/xyssl/distinfo
@@ -0,0 +1,3 @@
+MD5 (xyssl-0.6.tgz) = 4528b29a7de7d850bd1cb95af2c6d3ab
+SHA256 (xyssl-0.6.tgz) = a4729988a7014cf5c20e6a2ffb4f2a57d48360c6ec584c7c11c7879073e1f3e0
+SIZE (xyssl-0.6.tgz) = 161714
diff --git a/security/xyssl/files/patch-Makefile b/security/xyssl/files/patch-Makefile
new file mode 100644
index 000000000000..e9eca1fe0841
--- /dev/null
+++ b/security/xyssl/files/patch-Makefile
@@ -0,0 +1,37 @@
+*** Makefile.orig Sat Mar 31 18:00:00 2007
+--- Makefile Thu Apr 5 14:17:48 2007
+***************
+*** 13,26 ****
+ mv html docs
+
+ install:
+! mkdir -p $(DESTDIR)/{include/xyssl,lib}
+! cp -v -r include $(DESTDIR)/include
+! cp -v library/libxyssl.a $(DESTDIR)/lib
+!
+! mkdir -p $(DESTDIR)/bin
+! for i in programs/*; do test -x $i && \
+! cp -v $i $(DESTDIR)/xyssl_$i; \
+! done
+
+ clean:
+ cd library && make clean && cd ..
+--- 13,30 ----
+ mv html docs
+
+ install:
+! /usr/bin/install -d -v -m 0755 $(DESTDIR)/include/xyssl
+! /usr/bin/install -v -m 0644 include/xyssl/* $(DESTDIR)/include/xyssl/
+! /usr/bin/install -v -m 0644 library/libxyssl.a $(DESTDIR)/lib
+!
+! /usr/bin/install -v -m 0755 programs/benchmark $(DESTDIR)/bin/xyssl_benchmark
+! /usr/bin/install -v -m 0755 programs/filecrypt $(DESTDIR)/bin/xyssl_filecrypt
+! /usr/bin/install -v -m 0755 programs/hello $(DESTDIR)/bin/xyssl_hello
+! /usr/bin/install -v -m 0755 programs/mpi_demo $(DESTDIR)/bin/xyssl_mpi_demo
+! /usr/bin/install -v -m 0755 programs/selftest $(DESTDIR)/bin/xyssl_selftest
+! /usr/bin/install -v -m 0755 programs/ssl_client1 $(DESTDIR)/bin/xyssl_ssl_client1
+! /usr/bin/install -v -m 0755 programs/ssl_client2 $(DESTDIR)/bin/xyssl_ssl_client2
+! /usr/bin/install -v -m 0755 programs/ssl_server $(DESTDIR)/bin/xyssl_ssl_server
+
+ clean:
+ cd library && make clean && cd ..
diff --git a/security/xyssl/pkg-descr b/security/xyssl/pkg-descr
new file mode 100644
index 000000000000..f9a33c63b77e
--- /dev/null
+++ b/security/xyssl/pkg-descr
@@ -0,0 +1,7 @@
+XySSL is a lite-weight SSL and TLS implementation library in C.
+It currently supports SSLv2, SSLv3, and TLSv1 using the AES, ARC4,
+and 3DES ciphers, and the MD2, MD4, MD5, SHA1, and SHA256 hashes.
+Support is also included for X.509 certificate structures,
+as well as an internal PRNG.
+
+WWW: http://xyssl.org
diff --git a/security/xyssl/pkg-plist b/security/xyssl/pkg-plist
new file mode 100644
index 000000000000..27f89396f8dd
--- /dev/null
+++ b/security/xyssl/pkg-plist
@@ -0,0 +1,29 @@
+lib/libxyssl.a
+bin/xyssl_benchmark
+bin/xyssl_filecrypt
+bin/xyssl_hello
+bin/xyssl_mpi_demo
+bin/xyssl_selftest
+bin/xyssl_ssl_client1
+bin/xyssl_ssl_client2
+bin/xyssl_ssl_server
+include/xyssl/aes.h
+include/xyssl/arc4.h
+include/xyssl/base64.h
+include/xyssl/bignum.h
+include/xyssl/certs.h
+include/xyssl/des.h
+include/xyssl/dhm.h
+include/xyssl/havege.h
+include/xyssl/md2.h
+include/xyssl/md4.h
+include/xyssl/md5.h
+include/xyssl/net.h
+include/xyssl/rsa.h
+include/xyssl/sha1.h
+include/xyssl/sha2.h
+include/xyssl/ssl.h
+include/xyssl/ssl_conf.h
+include/xyssl/timing.h
+include/xyssl/x509.h
+@dirrm include/xyssl