aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorBernard Spil <brnrd@FreeBSD.org>2018-10-29 18:07:39 +0000
committerBernard Spil <brnrd@FreeBSD.org>2018-10-29 18:07:39 +0000
commitb3eb45b124eaff77c917b9dcf652cd45375ffa5d (patch)
tree9362b24314a25e18080f40a520cd8ca14bb072ab /security
parent363cd2ea645d79f740c8245a7d0cbf035ea967e8 (diff)
downloadports-b3eb45b124eaff77c917b9dcf652cd45375ffa5d.tar.gz
ports-b3eb45b124eaff77c917b9dcf652cd45375ffa5d.zip
security/openssl111: Fix vulnerabilities
MFH: 2018Q4 Security: 238ae7de-dba2-11e8-b713-b499baebfeaf
Notes
Notes: svn path=/head/; revision=483393
Diffstat (limited to 'security')
-rw-r--r--security/openssl111/Makefile2
-rw-r--r--security/openssl111/files/patch-CVE-2018-073498
-rw-r--r--security/openssl111/files/patch-CVE-2018-073533
3 files changed, 132 insertions, 1 deletions
diff --git a/security/openssl111/Makefile b/security/openssl111/Makefile
index caf88744685c..310d55995369 100644
--- a/security/openssl111/Makefile
+++ b/security/openssl111/Makefile
@@ -3,7 +3,7 @@
PORTNAME= openssl
DISTVERSION= 1.1.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security devel
MASTER_SITES= https://www.openssl.org/source/ \
ftp://ftp.cert.dfn.de/pub/tools/net/openssl/source/
diff --git a/security/openssl111/files/patch-CVE-2018-0734 b/security/openssl111/files/patch-CVE-2018-0734
new file mode 100644
index 000000000000..b2e8ad5c87bd
--- /dev/null
+++ b/security/openssl111/files/patch-CVE-2018-0734
@@ -0,0 +1,98 @@
+Timing vulnerability in DSA signature generation (CVE-2018-0734).
+
+Avoid a timing attack that leaks information via a side channel that
+triggers when a BN is resized. Increasing the size of the BNs
+prior to doing anything with them suppresses the attack.
+
+Thanks due to Samuel Weiser for finding and locating this.
+
+Reviewed-by: Bernd Edlinger <bernd.edlinger@hotmail.de>
+(Merged from #7486)
+
+(cherry picked from commit a9cfb8c)
+
+https://github.com/openssl/openssl/commit/8abfe72e8c1de1b95f50aa0d9134803b4d00070f
+--- crypto/dsa/dsa_ossl.c.orig 2018-09-11 12:48:21 UTC
++++ crypto/dsa/dsa_ossl.c
+@@ -9,6 +9,7 @@
+
+ #include <stdio.h>
+ #include "internal/cryptlib.h"
++#include "internal/bn_int.h"
+ #include <openssl/bn.h>
+ #include <openssl/sha.h>
+ #include "dsa_locl.h"
+@@ -178,9 +179,9 @@ static int dsa_sign_setup(DSA *dsa, BN_C
+ {
+ BN_CTX *ctx = NULL;
+ BIGNUM *k, *kinv = NULL, *r = *rp;
+- BIGNUM *l, *m;
++ BIGNUM *l;
+ int ret = 0;
+- int q_bits;
++ int q_bits, q_words;
+
+ if (!dsa->p || !dsa->q || !dsa->g) {
+ DSAerr(DSA_F_DSA_SIGN_SETUP, DSA_R_MISSING_PARAMETERS);
+@@ -189,8 +190,7 @@ static int dsa_sign_setup(DSA *dsa, BN_C
+
+ k = BN_new();
+ l = BN_new();
+- m = BN_new();
+- if (k == NULL || l == NULL || m == NULL)
++ if (k == NULL || l == NULL)
+ goto err;
+
+ if (ctx_in == NULL) {
+@@ -201,9 +201,9 @@ static int dsa_sign_setup(DSA *dsa, BN_C
+
+ /* Preallocate space */
+ q_bits = BN_num_bits(dsa->q);
+- if (!BN_set_bit(k, q_bits)
+- || !BN_set_bit(l, q_bits)
+- || !BN_set_bit(m, q_bits))
++ q_words = bn_get_top(dsa->q);
++ if (!bn_wexpand(k, q_words + 2)
++ || !bn_wexpand(l, q_words + 2))
+ goto err;
+
+ /* Get random k */
+@@ -238,14 +238,17 @@ static int dsa_sign_setup(DSA *dsa, BN_C
+ * small timing information leakage. We then choose the sum that is
+ * one bit longer than the modulus.
+ *
+- * TODO: revisit the BN_copy aiming for a memory access agnostic
+- * conditional copy.
++ * There are some concerns about the efficacy of doing this. More
++ * specificly refer to the discussion starting with:
++ * https://github.com/openssl/openssl/pull/7486#discussion_r228323705
++ * The fix is to rework BN so these gymnastics aren't required.
+ */
+ if (!BN_add(l, k, dsa->q)
+- || !BN_add(m, l, dsa->q)
+- || !BN_copy(k, BN_num_bits(l) > q_bits ? l : m))
++ || !BN_add(k, l, dsa->q))
+ goto err;
+
++ BN_consttime_swap(BN_is_bit_set(l, q_bits), k, l, q_words + 2);
++
+ if ((dsa)->meth->bn_mod_exp != NULL) {
+ if (!dsa->meth->bn_mod_exp(dsa, r, dsa->g, k, dsa->p, ctx,
+ dsa->method_mont_p))
+@@ -258,7 +261,7 @@ static int dsa_sign_setup(DSA *dsa, BN_C
+ if (!BN_mod(r, r, dsa->q, ctx))
+ goto err;
+
+- /* Compute part of 's = inv(k) (m + xr) mod q' */
++ /* Compute part of 's = inv(k) (m + xr) mod q' */
+ if ((kinv = BN_mod_inverse(NULL, k, dsa->q, ctx)) == NULL)
+ goto err;
+
+@@ -273,7 +276,6 @@ static int dsa_sign_setup(DSA *dsa, BN_C
+ BN_CTX_free(ctx);
+ BN_clear_free(k);
+ BN_clear_free(l);
+- BN_clear_free(m);
+ return ret;
+ }
+
diff --git a/security/openssl111/files/patch-CVE-2018-0735 b/security/openssl111/files/patch-CVE-2018-0735
new file mode 100644
index 000000000000..2d216c4be249
--- /dev/null
+++ b/security/openssl111/files/patch-CVE-2018-0735
@@ -0,0 +1,33 @@
+Timing vulnerability in ECDSA signature generation (CVE-2018-0735)
+
+Preallocate an extra limb for some of the big numbers to avoid a reallocation
+that can potentially provide a side channel.
+
+Reviewed-by: Bernd Edlinger <bernd.edlinger@hotmail.de>
+(Merged from #7486)
+
+(cherry picked from commit 99540ec)
+
+https://www.openssl.org/news/secadv/20181029.txt
+--- crypto/ec/ec_mult.c.orig 2018-09-11 12:48:21 UTC
++++ crypto/ec/ec_mult.c
+@@ -206,8 +206,8 @@ int ec_scalar_mul_ladder(const EC_GROUP
+ */
+ cardinality_bits = BN_num_bits(cardinality);
+ group_top = bn_get_top(cardinality);
+- if ((bn_wexpand(k, group_top + 1) == NULL)
+- || (bn_wexpand(lambda, group_top + 1) == NULL)) {
++ if ((bn_wexpand(k, group_top + 2) == NULL)
++ || (bn_wexpand(lambda, group_top + 2) == NULL)) {
+ ECerr(EC_F_EC_SCALAR_MUL_LADDER, ERR_R_BN_LIB);
+ goto err;
+ }
+@@ -244,7 +244,7 @@ int ec_scalar_mul_ladder(const EC_GROUP
+ * k := scalar + 2*cardinality
+ */
+ kbit = BN_is_bit_set(lambda, cardinality_bits);
+- BN_consttime_swap(kbit, k, lambda, group_top + 1);
++ BN_consttime_swap(kbit, k, lambda, group_top + 2);
+
+ group_top = bn_get_top(group->field);
+ if ((bn_wexpand(s->X, group_top) == NULL)