aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2010-12-04 21:32:34 +0000
committerRene Ladan <rene@FreeBSD.org>2010-12-04 21:32:34 +0000
commit54c312bfe69c0115f4f905aca69a64c9eaa8ce62 (patch)
treef8fcb1fd521529485018ef01777c46548ac85bce /security
parent1fc582c4d03e00172af8f431e39a712e1f080ea4 (diff)
downloadports-54c312bfe69c0115f4f905aca69a64c9eaa8ce62.tar.gz
ports-54c312bfe69c0115f4f905aca69a64c9eaa8ce62.zip
Garbage collect old ports:
2010-11-15 archivers/linux-par2cmdline: Native version available 2010-11-15 audio/bmp-musepack: does not build with audio/musepack 2010-11-15 audio/libmpcdec: superseded by audio/musepack 2010-11-15 audio/py-musepack: does not build with audio/musepack 2010-12-01 chinese/chinput3: Development has ceased. 2010-12-01 emulators/dynagen-devel: Please install emulators/dynagen instead 2010-11-24 net-p2p/gift-fasttrack: unmaintained upstream 2010-11-24 net-p2p/gift-gnutella: unmaintained upstream 2010-11-24 net-p2p/gift-openft: unmaintained upstream 2010-11-24 net-p2p/pyslsk: unmantained upstream, use net-p2p/nicotine-plus 2010-11-11 security/pamsfs: SFS is dead, this project is dead, and site is gone 2010-11-10 www/p5-Catalyst-Plugin-CommandLine: The module is not needed any more. With new Catalyst (at least 5.7014) it works out of the box.
Notes
Notes: svn path=/head/; revision=265690
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/pamsfs/Makefile37
-rw-r--r--security/pamsfs/distinfo3
-rw-r--r--security/pamsfs/files/patch-pam_sfs.c102
-rw-r--r--security/pamsfs/pkg-descr5
5 files changed, 0 insertions, 148 deletions
diff --git a/security/Makefile b/security/Makefile
index 52b71a4dc518..6de27863dc0a 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -589,7 +589,6 @@
SUBDIR += pam_require
SUBDIR += pam_smb
SUBDIR += pam_ssh_agent_auth
- SUBDIR += pamsfs
SUBDIR += pamtester
SUBDIR += pantera
SUBDIR += paperkey
diff --git a/security/pamsfs/Makefile b/security/pamsfs/Makefile
deleted file mode 100644
index b202f6cf1ca4..000000000000
--- a/security/pamsfs/Makefile
+++ /dev/null
@@ -1,37 +0,0 @@
-# New ports collection Makefile for: pamsfs
-# Date created: 2005-09-13
-# Whom: David Thiel <lx@redundancy.redundancy.org>
-#
-# $FreeBSD$
-#
-
-PORTNAME= pamsfs
-PORTVERSION= 0.1b
-CATEGORIES= security
-MASTER_SITES= ftp://ftp.codecobra.com/pamsfs/
-DISTNAME= ${PORTNAME}-${PORTVERSION}-src
-
-MAINTAINER= lx@FreeBSD.org
-COMMENT= A PAM module to mount SFS home directories
-
-BUILD_DEPENDS= sfskey:${PORTSDIR}/security/sfs
-
-DEPRECATED= SFS is dead, this project is dead, and site is gone
-EXPIRATION_DATE= 2010-11-11
-
-ALL_TARGET= pam-sfs
-WRKSRC= ${WRKDIR}/${PORTNAME}
-PLIST_FILES= lib/pam_sfs.so
-PORTDOCS= README
-
-pre-build:
- @${REINPLACE_CMD} -e "s|/usr/local/sfs-0.7.2|${PREFIX}|g" ${WRKSRC}/pam_sfs.c
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/pam_sfs.so ${PREFIX}/lib
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
-.endif
-
-.include <bsd.port.mk>
diff --git a/security/pamsfs/distinfo b/security/pamsfs/distinfo
deleted file mode 100644
index 5e867c624a94..000000000000
--- a/security/pamsfs/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (pamsfs-0.1b-src.tar.gz) = 8ff6c4b3eac7d06027fb980992907379
-SHA256 (pamsfs-0.1b-src.tar.gz) = d45b1b5ce42c2edec6d769d6f71804277b2efc318f60bc2aa566179405f109b8
-SIZE (pamsfs-0.1b-src.tar.gz) = 9466
diff --git a/security/pamsfs/files/patch-pam_sfs.c b/security/pamsfs/files/patch-pam_sfs.c
deleted file mode 100644
index d9a9a932397a..000000000000
--- a/security/pamsfs/files/patch-pam_sfs.c
+++ /dev/null
@@ -1,102 +0,0 @@
---- pam_sfs.c.orig Tue Feb 15 02:19:36 2005
-+++ pam_sfs.c Sun Sep 18 15:43:56 2005
-@@ -38,14 +38,26 @@
- void safe_strcat(char*,const char*,int);
-
- PAM_EXTERN int pam_sm_authenticate(pam_handle_t *pamh,int flags,int argc,const char **argv) {
-+ const char *user;
-+ const char *pass;
-+ struct passwd *pw;
-+ char *homedir;
-+ char *sfs="/sfs/";
-+ char *serverBegin;
-+ char *serverEnd;
-+ int lenServer;
-+ char *server;
-+ int pid;
-+ int maxCmd=4096;
-+ char *cmd;
-+ FILE *f;
-+ int status;
-+
- openlog("pam_sfs",0,LOG_AUTH);
-
- syslog(LOG_DEBUG,"%s","pam_sm_authenticate");
-
- //read the authentication information
-- const char *user;
-- const char *pass;
--
- if (pam_get_user(pamh,&user,NULL)!=PAM_SUCCESS)
- return PAM_SERVICE_ERR;
-
-@@ -53,7 +65,7 @@
- return PAM_SERVICE_ERR;
-
- //get the pw entry for the given user
-- struct passwd *pw=getpwnam(user);
-+ pw=getpwnam(user);
- if (pw==NULL)
- return PAM_USER_UNKNOWN;
-
-@@ -62,26 +74,24 @@
- //check if user's home-directory matches /sfs/<host>/
- //if not, exit right away
- //if it does, extract <host>
-- char *homedir=pw->pw_dir;
--
-- char *sfs="/sfs/";
-+ homedir=pw->pw_dir;
-
- if (strncmp(homedir,sfs,strlen(sfs))!=0)
- return PAM_SUCCESS; //home dir not in /sfs
-
-- char *serverBegin=homedir+strlen(sfs);
-- char *serverEnd=strchr(serverBegin,'/');
-+ serverBegin=homedir+strlen(sfs);
-+ serverEnd=strchr(serverBegin,'/');
-
- //absolute max of 2048 characters in server name
-- int lenServer=serverEnd-serverBegin+1;
-+ lenServer=serverEnd-serverBegin+1;
- if (lenServer>2048)
- return PAM_SERVICE_ERR;
-
-- char *server=malloc(lenServer);
-+ server=malloc(lenServer);
- strncpy(server,serverBegin,lenServer-1);
- server[lenServer-1]='\0';
-
-- int pid=fork();
-+ pid=fork();
- if (pid==0) {
- //child
- //change to the desired user
-@@ -93,8 +103,7 @@
- system("/usr/local/sfs-0.7.2/bin/sfsagent -c 2>/dev/null");
-
- //use a temporary variable to assemble the command in
-- int maxCmd=4096;
-- char *cmd=malloc(maxCmd);
-+ *cmd=malloc(maxCmd);
-
- strcpy(cmd,"export HOME=/ ; /usr/local/sfs-0.7.2/bin/sfskey -p 0 add ");
- safe_strcat(cmd,user,maxCmd);
-@@ -104,7 +113,7 @@
-
- //syslog(LOG_DEBUG,"executing: %s",cmd);
-
-- FILE *f=popen(cmd,"w");
-+ f=popen(cmd,"w");
-
- free(cmd);
- free(server); //child's copy
-@@ -116,7 +125,7 @@
-
- fprintf(f,"%s",pass);
-
-- int status=pclose(f);
-+ status=pclose(f);
- if (status!=0) {
- syslog(LOG_ERR,"Error from sfskey: %d.",status);
- exit(EXIT_FAILURE);
diff --git a/security/pamsfs/pkg-descr b/security/pamsfs/pkg-descr
deleted file mode 100644
index 97f373951b68..000000000000
--- a/security/pamsfs/pkg-descr
+++ /dev/null
@@ -1,5 +0,0 @@
-pamsfs is a PAM module that logs a user into a SFS server on
-system login. The primary reason for doing this is to allow users'
-home-directories to be located on a SFS server.
-
-WWW: http://www.codecobra.com/pamsfs/