aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorJoseph Mingrone <jrm@FreeBSD.org>2017-03-23 02:33:45 +0000
committerJoseph Mingrone <jrm@FreeBSD.org>2017-03-23 02:33:45 +0000
commitc0bc9257e93b160b53da93d1889743dfae2f6c35 (patch)
tree2598d1b7292499a2184e5a9f166417970a8db479 /security
parent8f7c85922455d98779ddd173b433910f1f062d62 (diff)
downloadports-c0bc9257e93b160b53da93d1889743dfae2f6c35.tar.gz
ports-c0bc9257e93b160b53da93d1889743dfae2f6c35.zip
security/py-pyaes: Pure-Python implementation of AES block-cipher and
common modes of operation. WWW: https://github.com/ricmoo/pyaes Approved by: swills (mentor, implicit)
Notes
Notes: svn path=/head/; revision=436753
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/py-pyaes/Makefile20
-rw-r--r--security/py-pyaes/distinfo3
-rw-r--r--security/py-pyaes/pkg-descr10
4 files changed, 34 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 3f565514fbd4..1bc3a2e921df 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -897,6 +897,7 @@
SUBDIR += py-plone.session
SUBDIR += py-potr
SUBDIR += py-pow
+ SUBDIR += py-pyaes
SUBDIR += py-pyaff4
SUBDIR += py-pyclamd
SUBDIR += py-pycrypto
diff --git a/security/py-pyaes/Makefile b/security/py-pyaes/Makefile
new file mode 100644
index 000000000000..5823ed50ae6c
--- /dev/null
+++ b/security/py-pyaes/Makefile
@@ -0,0 +1,20 @@
+# $FreeBSD$
+
+PORTNAME= pyaes
+PORTVERSION= 1.6.0
+CATEGORIES= security python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= jrm@FreeBSD.org
+COMMENT= Pure-Python implementation of AES block-cipher
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+NO_ARCH= yes
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/security/py-pyaes/distinfo b/security/py-pyaes/distinfo
new file mode 100644
index 000000000000..80476623a1c8
--- /dev/null
+++ b/security/py-pyaes/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1490235520
+SHA256 (pyaes-1.6.0.tar.gz) = 9cd5a54d914b1eebfb14fcb490315214b6a0304d9f1bb47e90d1d8e0b15ce92e
+SIZE (pyaes-1.6.0.tar.gz) = 28237
diff --git a/security/py-pyaes/pkg-descr b/security/py-pyaes/pkg-descr
new file mode 100644
index 000000000000..74b804beb05f
--- /dev/null
+++ b/security/py-pyaes/pkg-descr
@@ -0,0 +1,10 @@
+pyaes is a pure-Python implmentation of the AES block cipher algorithm and the
+common modes of operation (CBC, CFB, CTR, ECB and OFB).
+
+- Supports all AES key sizes
+- Supports all AES common modes
+- Pure-Python (no external dependancies)
+- BlockFeeder API allows streams to easily be encrypted and decrypted
+- Python 2.x and 3.x support
+
+WWW: https://github.com/ricmoo/pyaes