aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2006-06-12 17:04:13 +0000
committerAlex Dupre <ale@FreeBSD.org>2006-06-12 17:04:13 +0000
commit6050f3251d4a42ef6dbc4f706eba332570594c6d (patch)
treeaad54bd136fd0a5e725f80fd5b6e1516dc647dac /security
parentacf7714db05f3204313d93cda1f633ee3753fe02 (diff)
downloadports-6050f3251d4a42ef6dbc4f706eba332570594c6d.tar.gz
ports-6050f3251d4a42ef6dbc4f706eba332570594c6d.zip
Engine_pkcs11 is an implementation of an engine for OpenSSL.
It can be loaded using code, config file or command line and will pass any function call by openssl to a PKCS#11 module. Engine_pkcs11 is meant to be used with smart cards and software for using smart cards in PKCS#11 format, such as OpenSC. WWW: http://www.opensc-project.org/engine_pkcs11/ Note: the port requires the OpenSSL installed from ports, since dynamic engine loading is disabled in base system. See PR bin/79570 for details.
Notes
Notes: svn path=/head/; revision=165248
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/engine_pkcs11/Makefile35
-rw-r--r--security/engine_pkcs11/distinfo3
-rw-r--r--security/engine_pkcs11/pkg-descr10
-rw-r--r--security/engine_pkcs11/pkg-plist4
5 files changed, 53 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index a2be8fd688bb..4e891c65ca54 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -103,6 +103,7 @@
SUBDIR += drweb-qmail
SUBDIR += drweb-sendmail
SUBDIR += dsniff
+ SUBDIR += engine_pkcs11
SUBDIR += expiretable
SUBDIR += f-prot
SUBDIR += f-prot-sig
diff --git a/security/engine_pkcs11/Makefile b/security/engine_pkcs11/Makefile
new file mode 100644
index 000000000000..6ce4b2a4b5b3
--- /dev/null
+++ b/security/engine_pkcs11/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: engine_pkcs11
+# Date created: 1 Jun 2006
+# Whom: Alex Dupre <ale@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= engine_pkcs11
+PORTVERSION= 0.1.3
+CATEGORIES= security
+MASTER_SITES= http://www.opensc-project.org/files/${PORTNAME}/
+
+MAINTAINER= ale@FreeBSD.org
+COMMENT= An implementation of a PKCS#11 engine for OpenSSL
+
+LIB_DEPENDS= p11.1:${PORTSDIR}/security/libp11
+
+USE_OPENSSL= yes
+WITH_OPENSSL_PORT=yes
+GNU_CONFIGURE= yes
+USE_GNOME= pkgconfig
+
+CONFIGURE_ARGS= --with-openssl="${OPENSSLBASE}"
+
+DOC_FILES= README *.sh *.xsl *.css *.html
+
+PORTDOCS= *
+
+.ifndef(NOPORTDOCS)
+post-install:
+ @${MKDIR} ${DOCSDIR}
+ @(cd ${WRKSRC}/doc && ${CP} -R ${DOC_FILES} ${DOCSDIR})
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/engine_pkcs11/distinfo b/security/engine_pkcs11/distinfo
new file mode 100644
index 000000000000..e50a34b85077
--- /dev/null
+++ b/security/engine_pkcs11/distinfo
@@ -0,0 +1,3 @@
+MD5 (engine_pkcs11-0.1.3.tar.gz) = 26eb84950a10b7d869e41a50620ebf09
+SHA256 (engine_pkcs11-0.1.3.tar.gz) = bf6f49203912cb77f92db55c146117312abf9244ba49e78649e4a7da22448e54
+SIZE (engine_pkcs11-0.1.3.tar.gz) = 312738
diff --git a/security/engine_pkcs11/pkg-descr b/security/engine_pkcs11/pkg-descr
new file mode 100644
index 000000000000..52f809671cf1
--- /dev/null
+++ b/security/engine_pkcs11/pkg-descr
@@ -0,0 +1,10 @@
+Engine_pkcs11 is an implementation of an engine for OpenSSL.
+It can be loaded using code, config file or command line and
+will pass any function call by openssl to a PKCS#11 module.
+Engine_pkcs11 is meant to be used with smart cards and software
+for using smart cards in PKCS#11 format, such as OpenSC.
+
+WWW: http://www.opensc-project.org/engine_pkcs11/
+
+- Alex Dupre
+ale@FreeBSD.org
diff --git a/security/engine_pkcs11/pkg-plist b/security/engine_pkcs11/pkg-plist
new file mode 100644
index 000000000000..0bb5ba9fbf02
--- /dev/null
+++ b/security/engine_pkcs11/pkg-plist
@@ -0,0 +1,4 @@
+lib/engines/engine_pkcs11.a
+lib/engines/engine_pkcs11.la
+lib/engines/engine_pkcs11.so
+@dirrmtry lib/engines