aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2012-04-27 18:22:13 +0000
committerRenato Botelho <garga@FreeBSD.org>2012-04-27 18:22:13 +0000
commitee1aeaafe5e4abfe367366a4ea509d88b30a2711 (patch)
tree0f4ae27e92b29874d6f393fca39af2fe81bd4142 /security
parentf50467e568e1b4648e170f5ce0a533aafeb93bb8 (diff)
downloadports-ee1aeaafe5e4abfe367366a4ea509d88b30a2711.tar.gz
ports-ee1aeaafe5e4abfe367366a4ea509d88b30a2711.zip
Ressurrect security/cmd5checkpw and take maintainership
Notes
Notes: svn path=/head/; revision=295616
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/cmd5checkpw/Makefile38
-rw-r--r--security/cmd5checkpw/distinfo3
-rw-r--r--security/cmd5checkpw/pkg-descr6
-rw-r--r--security/cmd5checkpw/pkg-plist9
5 files changed, 57 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 98d1709fe1db..53d21f9d5516 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -80,6 +80,7 @@
SUBDIR += clamsmtp
SUBDIR += clamtk
SUBDIR += clusterssh
+ SUBDIR += cmd5checkpw
SUBDIR += cops
SUBDIR += courier-authlib
SUBDIR += courier-authlib-base
diff --git a/security/cmd5checkpw/Makefile b/security/cmd5checkpw/Makefile
new file mode 100644
index 000000000000..eb265ea89397
--- /dev/null
+++ b/security/cmd5checkpw/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: cmd5checkpw
+# Date created: 8 Sep 2003
+# Whom: Clement Laforet <sheepkiller@cultdeadsheep.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cmd5checkpw
+PORTVERSION= 0.22
+CATEGORIES= security
+MASTER_SITES= http://beautytech.googlecode.com/svn-history/r6/trunk/src/qmail/tar/
+
+MAINTAINER= garga@FreeBSD.org
+COMMENT= Checkpassword compatible authentication program that uses CRAM-MD5
+
+MAN8= cmd5checkpw.8
+
+DOCS_FILES= CHANGES CREDITS INSTALL README rfc1321.txt rfc2104.txt
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/etc/poppasswd|${LOCALBASE}/etc/poppasswd|' \
+ ${WRKSRC}/main.c
+ @${REINPLACE_CMD} -e 's|^\(CC\)|#\1|; s|^\(CFLAGS\)|#\1|; \
+ s|LD=gcc|LD=$${CC}|; s|LDFLAGS=-g|LDFLAGS=$${CFLAGS} ${LDFLAGS}|;' \
+ ${WRKSRC}/Makefile
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/cmd5checkpw ${LOCALBASE}/bin
+ @${INSTALL_DATA} ${WRKSRC}/poppasswd ${LOCALBASE}/etc/poppasswd.dist
+ @${INSTALL_MAN} ${WRKSRC}/cmd5checkpw.8 ${MANPREFIX}/man/man8
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+. for f in ${DOCS_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+. endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/cmd5checkpw/distinfo b/security/cmd5checkpw/distinfo
new file mode 100644
index 000000000000..8aa87bb07c94
--- /dev/null
+++ b/security/cmd5checkpw/distinfo
@@ -0,0 +1,3 @@
+MD5 (cmd5checkpw-0.22.tar.gz) = 40092caf3608cbc8bd23220b2b28cb52
+SHA256 (cmd5checkpw-0.22.tar.gz) = 26d375a909520aaf980b59f01d994a796c87dfcf317b9dc31284f14ed92032d9
+SIZE (cmd5checkpw-0.22.tar.gz) = 24323
diff --git a/security/cmd5checkpw/pkg-descr b/security/cmd5checkpw/pkg-descr
new file mode 100644
index 000000000000..3c3409443f51
--- /dev/null
+++ b/security/cmd5checkpw/pkg-descr
@@ -0,0 +1,6 @@
+cmd5checkpw is a checkpassword compatible authentication program that uses
+CRAM-MD5 authentication mode. It was designed primary to work with qmail
+but it can be used by any other program that knows how to use checkpassword
+compatible authentication.
+
+WWW: http://members.elysium.pl/brush/cmd5checkpw/
diff --git a/security/cmd5checkpw/pkg-plist b/security/cmd5checkpw/pkg-plist
new file mode 100644
index 000000000000..75b84ff2372b
--- /dev/null
+++ b/security/cmd5checkpw/pkg-plist
@@ -0,0 +1,9 @@
+bin/cmd5checkpw
+etc/poppasswd.dist
+%%PORTDOCS%%%%DOCSDIR%%/CHANGES
+%%PORTDOCS%%%%DOCSDIR%%/CREDITS
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/rfc1321.txt
+%%PORTDOCS%%%%DOCSDIR%%/rfc2104.txt
+%%PORTDOCS%%@dirrm %%DOCSDIR%%