aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2012-05-04 11:07:46 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2012-05-04 11:07:46 +0000
commit779ffc83f9f104b07409f56b7734e2f35374bf7b (patch)
treec445c9c1e48bd14f8bc498315f068f2609899872 /security
parentdf68d0a9eb362ad970ab0f96d0bdff6ae004bb90 (diff)
downloadports-779ffc83f9f104b07409f56b7734e2f35374bf7b.tar.gz
ports-779ffc83f9f104b07409f56b7734e2f35374bf7b.zip
- Add optional dependency on security/pinentry port.
I'd like to keep this port (and package built on pointyhat) having simple dependencies. So this knob is off by default. PR: ports/156287, ports/164333 Submitted by: Joseph Olatt <joji@eskimo.com>, Oliver Herold <oh@fixmbr.de>
Notes
Notes: svn path=/head/; revision=296001
Diffstat (limited to 'security')
-rw-r--r--security/gnupg/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/security/gnupg/Makefile b/security/gnupg/Makefile
index 85b07f94ada4..e89fe5b8f5fb 100644
--- a/security/gnupg/Makefile
+++ b/security/gnupg/Makefile
@@ -42,7 +42,8 @@ MAN8= addgnupghome.8 applygnupgdefaults.8
INFO= gnupg
.endif
-OPTIONS= LDAP "LDAP keyserver interface" off \
+OPTIONS= PINENTRY "Use pinentry" off \
+ LDAP "LDAP keyserver interface" off \
SCDAEMON "Enable Smartcard daemon (with libusb)" off \
CURL "Use the real curl library (worked around if no)" on \
GPGSM "Enable GPGSM (requires LDAP)" off \
@@ -52,11 +53,15 @@ OPTIONS= LDAP "LDAP keyserver interface" off \
.include <bsd.port.pre.mk>
+.if defined(WITH_PINENTRY)
+RUN_DEPENDS+= pinentry>0:${PORTSDIR}/security/pinentry
+.endif
+
.if defined(WITHOUT_GPGSM)
CONFIGURE_ARGS+=--disable-gpgsm
PLIST_SUB+= GPGSM="@comment "
.else
-RUN_DEPENDS= dirmngr:${PORTSDIR}/security/dirmngr
+RUN_DEPENDS+= dirmngr:${PORTSDIR}/security/dirmngr
WITH_LDAP= YES
.undef WITHOUT_LDAP
PLIST_SUB+= GPGSM=""