aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-05-30 13:43:46 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-05-30 13:43:46 +0000
commitb489be38e7e38067f770b80654defefe1d776fa9 (patch)
tree9dd3f02060d385cf1c0a0371dd10d8705d5813bf /security
parent42c64d81e3156f7c79ea3931340c1902aa8dd02b (diff)
downloadports-b489be38e7e38067f770b80654defefe1d776fa9.tar.gz
ports-b489be38e7e38067f770b80654defefe1d776fa9.zip
- Update to 2.2.2
PR: 123949 Submitted by: Ganael Laplanche <ganael.laplanche@martymac.com> (maintainer)
Notes
Notes: svn path=/head/; revision=213929
Diffstat (limited to 'security')
-rw-r--r--security/vlock/Makefile16
-rw-r--r--security/vlock/distinfo6
-rw-r--r--security/vlock/files/patch-configure24
3 files changed, 27 insertions, 19 deletions
diff --git a/security/vlock/Makefile b/security/vlock/Makefile
index 559fad7f07ba..310a502e75f2 100644
--- a/security/vlock/Makefile
+++ b/security/vlock/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= vlock
-PORTVERSION= 2.2.1
+PORTVERSION= 2.2.2
CATEGORIES= security
MASTER_SITES= http://cthulhu.c3d2.de/~toidinamai/vlock/archive/
@@ -21,10 +21,12 @@ CONFIGURE_ARGS= --enable-plugins --enable-pam \
--with-modules="${VLOCKMODULES}" \
--with-scripts="${VLOCKSCRIPTS}" \
VLOCK_GROUP="${VLOCKGRP}" \
- VLOCK_MODE="0750"
-CONFIGURE_ENV= LOCALBASE=${LOCALBASE}
+ VLOCK_MODE="0750" \
+ EXTRA_CFLAGS="-I${LOCALBASE}/include" \
+ EXTRA_LDFLAGS="-L${LOCALBASE}/lib"
-OPTIONS= VLOCKSCRIPTS "Install sample hook scripts" off \
+OPTIONS= ROOTPWD "Enable unlock using root password" on \
+ VLOCKSCRIPTS "Install sample hook scripts" off \
CACASAVER "Enable libcaca screensaver" off
MANLANG= ""
@@ -42,6 +44,12 @@ VLOCKGID= 129
.include <bsd.port.pre.mk>
+.if !defined(WITHOUT_ROOTPWD)
+CONFIGURE_ARGS+= --enable-root-password
+.else
+CONFIGURE_ARGS+= --disable-root-password
+.endif
+
.if !defined(WITHOUT_VLOCKSCRIPTS)
VLOCKSCRIPTS+= amarok.sh example_script.sh mplayer.sh
PLIST_SUB+= PL_VLOCKSCRIPTS=""
diff --git a/security/vlock/distinfo b/security/vlock/distinfo
index 09f399206a11..d5b354628c3d 100644
--- a/security/vlock/distinfo
+++ b/security/vlock/distinfo
@@ -1,3 +1,3 @@
-MD5 (vlock-2.2.1.tar.gz) = 5a8f7bb07b9f6107f1d06acb3aaa5578
-SHA256 (vlock-2.2.1.tar.gz) = 11fa31b0cdc9e936cd114384db09b36981c412af7e23db83368d7c40677a031c
-SIZE (vlock-2.2.1.tar.gz) = 54381
+MD5 (vlock-2.2.2.tar.gz) = 51c389ee4ef814bf59063bc367437eb8
+SHA256 (vlock-2.2.2.tar.gz) = ea875250cad150872583b6ed2436470bc5e9c3a580d85554e31a2d5ae1d92fad
+SIZE (vlock-2.2.2.tar.gz) = 54732
diff --git a/security/vlock/files/patch-configure b/security/vlock/files/patch-configure
index 9abfa18ab2e3..8cf43e19abdb 100644
--- a/security/vlock/files/patch-configure
+++ b/security/vlock/files/patch-configure
@@ -1,12 +1,12 @@
---- configure.orig 2008-03-26 17:49:33.000000000 +0800
-+++ configure 2008-03-30 13:32:41.000000000 +0800
-@@ -255,6 +255,9 @@
- DL_LIB=''
- CRYPT_LIB=''
- MODULES="all.so new.so"
-+ CFLAGS="${CFLAGS} -I${LOCALBASE}/include"
-+ LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
-+ ROOT_GROUP="wheel"
- ;;
- esac
- }
+--- configure.orig 2008-05-24 08:37:25.515872840 +0200
++++ configure 2008-05-24 08:38:44.943843155 +0200
+@@ -220,7 +220,8 @@
+ MODULEDIR="\$(LIBDIR)/vlock/modules"
+
+ CC=gcc
+- DEFAULT_CFLAGS="-O2 -Wall -W -pedantic -std=gnu99"
++ #DEFAULT_CFLAGS="-O2 -Wall -W -pedantic -std=gnu99"
++ DEFAULT_CFLAGS="-pedantic -std=gnu99"
+ DEBUG_CFLAGS="-O0 -g -Wall -W -pedantic -std=gnu99"
+ CFLAGS="${DEFAULT_CFLAGS}"
+ LD=ld