aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2010-12-22 18:38:32 +0000
committerMathieu Arnold <mat@FreeBSD.org>2010-12-22 18:38:32 +0000
commit11aa096a9e625f509edf84a4b9c72eb205b92891 (patch)
tree87d1a4f6771379dd94fc8e37288f1aa9a9993014 /security
parent86237f883c5f6347251021780d9c8894f5ef06a7 (diff)
downloadports-11aa096a9e625f509edf84a4b9c72eb205b92891.tar.gz
ports-11aa096a9e625f509edf84a4b9c72eb205b92891.zip
This module allows to secure connections of POE::Wheel::ReadWrite with OpenSSL
by a POE::Filter object, and behaves (beside of SSLing) as POE::Filter::Stream.
Notes
Notes: svn path=/head/; revision=266730
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-POE-Filter-SSL/Makefile29
-rw-r--r--security/p5-POE-Filter-SSL/distinfo3
-rw-r--r--security/p5-POE-Filter-SSL/pkg-descr4
-rw-r--r--security/p5-POE-Filter-SSL/pkg-plist9
5 files changed, 46 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index ca1e929f108b..c00aa0750165 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -550,6 +550,7 @@
SUBDIR += p5-PGP
SUBDIR += p5-PGP-Sign
SUBDIR += p5-POE-Component-SSLify
+ SUBDIR += p5-POE-Filter-SSL
SUBDIR += p5-PerlCryptLib
SUBDIR += p5-SAVI-Perl
SUBDIR += p5-SHA
diff --git a/security/p5-POE-Filter-SSL/Makefile b/security/p5-POE-Filter-SSL/Makefile
new file mode 100644
index 000000000000..cd0e23c6ed6b
--- /dev/null
+++ b/security/p5-POE-Filter-SSL/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: POE-Filter-SSL
+# Date created: December 22, 2010
+# Whom: mat
+#
+# $FreeBSD$
+#
+
+PORTNAME= POE-Filter-SSL
+PORTVERSION= 0.22
+CATEGORIES= security perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= mat@FreeBSD.org
+COMMENT= The easiest and flexiblest way to SSL in POEIntegrate SSL into POE
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Net/SSLeay.pm:${PORTSDIR}/security/p5-Net-SSLeay \
+ ${SITE_PERL}/HTTP/Status.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/POE/Filter/Stackable.pm:${PORTSDIR}/devel/p5-POE \
+ ${SITE_PERL}/Test/Simple.pm:${PORTSDIR}/devel/p5-Test-Simple
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Net/SSLeay.pm:${PORTSDIR}/security/p5-Net-SSLeay \
+ ${SITE_PERL}/HTTP/Status.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/POE/Filter/Stackable.pm:${PORTSDIR}/devel/p5-POE
+
+PERL_CONFIGURE= yes
+
+MAN3= POE::Filter::SSL.3
+
+.include <bsd.port.mk>
diff --git a/security/p5-POE-Filter-SSL/distinfo b/security/p5-POE-Filter-SSL/distinfo
new file mode 100644
index 000000000000..146c0a76773a
--- /dev/null
+++ b/security/p5-POE-Filter-SSL/distinfo
@@ -0,0 +1,3 @@
+MD5 (POE-Filter-SSL-0.22.tar.gz) = 2f3d769277a55b4c61c2a5424d189d2c
+SHA256 (POE-Filter-SSL-0.22.tar.gz) = 49d3cec3f55999feded92da10fbd3ab9eb923eae320c6b9d039dbd00f883c047
+SIZE (POE-Filter-SSL-0.22.tar.gz) = 55926
diff --git a/security/p5-POE-Filter-SSL/pkg-descr b/security/p5-POE-Filter-SSL/pkg-descr
new file mode 100644
index 000000000000..89108c3b797c
--- /dev/null
+++ b/security/p5-POE-Filter-SSL/pkg-descr
@@ -0,0 +1,4 @@
+This module allows to secure connections of POE::Wheel::ReadWrite with OpenSSL
+by a POE::Filter object, and behaves (beside of SSLing) as POE::Filter::Stream.
+
+WWW: http://search.cpan.org/dist/POE-Filter-SSL/
diff --git a/security/p5-POE-Filter-SSL/pkg-plist b/security/p5-POE-Filter-SSL/pkg-plist
new file mode 100644
index 000000000000..03e7e5a937a1
--- /dev/null
+++ b/security/p5-POE-Filter-SSL/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Filter/SSL/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Filter/SSL/SSL.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Filter/SSL/SSL.so
+%%SITE_PERL%%/%%PERL_ARCH%%/POE/Filter/SSL.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Filter/SSL
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Filter
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/POE/Filter
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/POE