aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2007-09-18 06:39:28 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2007-09-18 06:39:28 +0000
commit56016e8f4021670da1c904696ca3798a98f5db81 (patch)
tree608d38c2ac5155ba47d5bd507c8d046a157523aa /security
parent5e9dd3dc4806dee84f396d916525e418ba3410e2 (diff)
downloadports-56016e8f4021670da1c904696ca3798a98f5db81.tar.gz
ports-56016e8f4021670da1c904696ca3798a98f5db81.zip
- New port: security/fpc-openssl
Free Pascal unit for OpenSSL
Notes
Notes: svn path=/head/; revision=199669
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/fpc-openssl/Makefile23
-rw-r--r--security/fpc-openssl/pkg-plist9
3 files changed, 33 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 39c9daa6ab7a..d44f2a2af438 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -137,6 +137,7 @@
SUBDIR += fl0p
SUBDIR += flawfinder
SUBDIR += fpc-hash
+ SUBDIR += fpc-openssl
SUBDIR += fpm
SUBDIR += fragroute
SUBDIR += fragrouter
diff --git a/security/fpc-openssl/Makefile b/security/fpc-openssl/Makefile
new file mode 100644
index 000000000000..92bf661fb7ed
--- /dev/null
+++ b/security/fpc-openssl/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: fpc-openssl
+# Date created: 2007-09-11
+# Whom: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTREVISION= 0
+CATEGORIES= security lang
+PKGNAMESUFFIX= -openssl
+
+MAINTAINER= acm@FreeBSD.org
+COMMENT= Free Pascal unit for OpenSSL
+
+BUILD_DEPENDS= ppc386:${PORTSDIR}/lang/fpc
+
+MASTERDIR= ${.CURDIR}/../../lang/fpc
+WRKUNITDIR= ${FPCSRCDIR}/packages/extra/${PKGNAMESUFFIX:S/-//}
+EXTRACTUNITDIR+= ${WRKUNITDIR}
+
+OPTIONS= OPENSSL "Install SSL and crypto library" on
+
+.include "${MASTERDIR}/Makefile"
diff --git a/security/fpc-openssl/pkg-plist b/security/fpc-openssl/pkg-plist
new file mode 100644
index 000000000000..92d1473ae6ae
--- /dev/null
+++ b/security/fpc-openssl/pkg-plist
@@ -0,0 +1,9 @@
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/openssl/Package.fpc
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/openssl/openssl.ppu
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/openssl/openssl.o
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/openssl/libpopenssl.a
+@dirrm lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/openssl
+@dirrmtry lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%
+@dirrmtry lib/fpc/%%PORTVERSION%%/units
+@dirrmtry lib/fpc/%%PORTVERSION%%
+@dirrmtry lib/fpc