aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2011-12-20 03:21:09 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2011-12-20 03:21:09 +0000
commitee0c6512c405610fd617b7af08d9a61a070e7062 (patch)
tree2a42d1003079611f39271d3fd69127c2844a06fa /security
parent3b2ff1de727ae9d48b667c50e41ae8e0f626bac0 (diff)
downloadports-ee0c6512c405610fd617b7af08d9a61a070e7062.tar.gz
ports-ee0c6512c405610fd617b7af08d9a61a070e7062.zip
Add py-ssh 1.7.11, python SSH2 protocol library.
Notes
Notes: svn path=/head/; revision=287693
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/py-ssh/Makefile22
-rw-r--r--security/py-ssh/distinfo2
-rw-r--r--security/py-ssh/pkg-descr6
4 files changed, 31 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 98abcf378569..6738d5ad243e 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -717,6 +717,7 @@
SUBDIR += py-pylibacl
SUBDIR += py-pyme
SUBDIR += py-rijndael
+ SUBDIR += py-ssh
SUBDIR += py-sslstrip
SUBDIR += py-tlslite
SUBDIR += py-trustedpickle
diff --git a/security/py-ssh/Makefile b/security/py-ssh/Makefile
new file mode 100644
index 000000000000..7ab17931b206
--- /dev/null
+++ b/security/py-ssh/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: py-ssh
+# Date created: 2011-12-20
+# Whom: Li-Wen Hsu <lwhsu@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ssh
+PORTVERSION= 1.7.11
+CATEGORIES= security python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= lwhsu@FreeBSD.org
+COMMENT= Python SSH2 protocol library
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= easy_install
+
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
+
+.include <bsd.port.mk>
diff --git a/security/py-ssh/distinfo b/security/py-ssh/distinfo
new file mode 100644
index 000000000000..8939b81673f8
--- /dev/null
+++ b/security/py-ssh/distinfo
@@ -0,0 +1,2 @@
+SHA256 (ssh-1.7.11.tar.gz) = 9e5fe370292c9dd0687d0cdb44e2a4d05a55e7e583ddf1feab321d4f714e2540
+SIZE (ssh-1.7.11.tar.gz) = 774188
diff --git a/security/py-ssh/pkg-descr b/security/py-ssh/pkg-descr
new file mode 100644
index 000000000000..6ce57fe2ce53
--- /dev/null
+++ b/security/py-ssh/pkg-descr
@@ -0,0 +1,6 @@
+This is a library for making SSH2 connections (client or server). Emphasis is
+on using SSH2 as an alternative to SSL for making secure connections between
+python scripts. All major ciphers and hash methods are supported. SFTP client
+and server mode are both supported too.
+
+WWW: http://pypi.python.org/pypi/ssh/