aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2016-02-09 01:34:41 +0000
committerJan Beich <jbeich@FreeBSD.org>2016-02-09 01:34:41 +0000
commit50d2caa5c82d61a73f0ee4c8ede4ad3daeff37e2 (patch)
treeda5283e2999c6287b5e1d35a67373cef7dd33a35 /security
parent3ccdef7c6ef19f40f8e5ce8d2731e1b19ae17f5d (diff)
downloadports-50d2caa5c82d61a73f0ee4c8ede4ad3daeff37e2.tar.gz
ports-50d2caa5c82d61a73f0ee4c8ede4ad3daeff37e2.zip
MFH: r405494
security/nss: update to 3.21 Temporarily disable gtests as they require C++0x support and install a library that may have conflicting API with devel/googletest. Changes: https://developer.mozilla.org/en-US/docs/Mozilla/Projects/NSS/NSS_3.21_release_notes Approved by: ports-secteam (feld)
Notes
Notes: svn path=/branches/2016Q1/; revision=408522
Diffstat (limited to 'security')
-rw-r--r--security/ca_root_nss/Makefile2
-rw-r--r--security/ca_root_nss/distinfo4
-rw-r--r--security/nss/Makefile4
-rw-r--r--security/nss/distinfo4
-rw-r--r--security/nss/files/patch-bug1226179156
-rw-r--r--security/nss/files/patch-coreconf_command.mk14
6 files changed, 171 insertions, 13 deletions
diff --git a/security/ca_root_nss/Makefile b/security/ca_root_nss/Makefile
index 9138af239e3c..0fe5498ff49a 100644
--- a/security/ca_root_nss/Makefile
+++ b/security/ca_root_nss/Makefile
@@ -32,7 +32,7 @@ PLIST_SUB+= CERTDIR=${CERTDIR}
# !!! Please DO NOT submit patches for new version until it has !!!
# !!! been committed there first. !!!
# !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
-VERSION_NSS= 3.20.1
+VERSION_NSS= 3.21
#NSS_SUFFIX= -with-ckbi-1.98
CERTDATA_TXT_PATH= nss-${VERSION_NSS}/nss/lib/ckfw/builtins/certdata.txt
BUNDLE_PROCESSOR= MAca-bundle.pl
diff --git a/security/ca_root_nss/distinfo b/security/ca_root_nss/distinfo
index 3445661eb2ff..e317f4b5a503 100644
--- a/security/ca_root_nss/distinfo
+++ b/security/ca_root_nss/distinfo
@@ -1,2 +1,2 @@
-SHA256 (nss-3.20.1.tar.gz) = ad3c8f11dfd9570c2d04a6140d5ef7c2bdd0fe30d6c9e5548721a4251a5e8c97
-SIZE (nss-3.20.1.tar.gz) = 6958956
+SHA256 (nss-3.21.tar.gz) = 3f7a5b027d7cdd5c0e4ff7544da33fdc6f56c2f8c27fff02938fd4a6fbe87239
+SIZE (nss-3.21.tar.gz) = 6978112
diff --git a/security/nss/Makefile b/security/nss/Makefile
index 41abd9bd1043..4b453d62ba5e 100644
--- a/security/nss/Makefile
+++ b/security/nss/Makefile
@@ -2,9 +2,8 @@
# $FreeBSD$
PORTNAME= nss
-PORTVERSION= 3.20.2
+PORTVERSION= 3.21
#DISTVERSIONSUFFIX= -with-ckbi-1.98
-PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= MOZILLA/security/${PORTNAME}/releases/${DISTNAME:tu:C/[-.]/_/g}_RTM/src
@@ -28,6 +27,7 @@ USE_PERL5= build
MAKE_ENV= LIBRARY_PATH="${LOCALBASE}/lib" \
SQLITE_INCLUDE_DIR="${LOCALBASE}/include" \
FREEBL_LOWHASH=1 \
+ NSS_DISABLE_GTESTS=1 \
NSS_USE_SYSTEM_SQLITE=1
CFLAGS+= -I${LOCALBASE}/include/nspr
diff --git a/security/nss/distinfo b/security/nss/distinfo
index 232b6c6f7e25..e317f4b5a503 100644
--- a/security/nss/distinfo
+++ b/security/nss/distinfo
@@ -1,2 +1,2 @@
-SHA256 (nss-3.20.2.tar.gz) = 141a3a59d57fbcd00b669bcaa4ccd2fd632a9306e2fb4623e89eed0a2e93f286
-SIZE (nss-3.20.2.tar.gz) = 6959455
+SHA256 (nss-3.21.tar.gz) = 3f7a5b027d7cdd5c0e4ff7544da33fdc6f56c2f8c27fff02938fd4a6fbe87239
+SIZE (nss-3.21.tar.gz) = 6978112
diff --git a/security/nss/files/patch-bug1226179 b/security/nss/files/patch-bug1226179
new file mode 100644
index 000000000000..c16c321e2867
--- /dev/null
+++ b/security/nss/files/patch-bug1226179
@@ -0,0 +1,156 @@
+# HG changeset patch
+# User Martin Thomson <martin.thomson@gmail.com>
+# Date 1451888957 -39600
+# Mon Jan 04 17:29:17 2016 +1100
+# Node ID 7b4febd4ad04d5ffe8858a342f23cff58928ce10
+# Parent afa3eeff3ca6fed718fb29324368a026fbe8ffd8
+Bug 1226179 - Using -Werror on all unix platforms, r?gaston
+
+diff --git a/coreconf/Darwin.mk b/coreconf/Darwin.mk
+--- coreconf/Darwin.mk
++++ coreconf/Darwin.mk
+@@ -77,17 +77,17 @@ endif
+ # The meaning of a common is ambiguous. It may be a true definition:
+ # int x = 0;
+ # or it may be a declaration of a symbol defined in another file:
+ # extern int x;
+ # Use the -fno-common option to force all commons to become true
+ # definitions so that the linker can catch multiply-defined symbols.
+ # Also, common symbols are not allowed with Darwin dynamic libraries.
+
+-OS_CFLAGS = $(DSO_CFLAGS) $(OS_REL_CFLAGS) $(WARNING_CFLAGS) -fno-common -pipe -DDARWIN -DHAVE_STRERROR -DHAVE_BSD_FLOCK $(DARWIN_SDK_CFLAGS)
++OS_CFLAGS = $(DSO_CFLAGS) $(OS_REL_CFLAGS) -fno-common -pipe -DDARWIN -DHAVE_STRERROR -DHAVE_BSD_FLOCK $(DARWIN_SDK_CFLAGS)
+
+ ifdef BUILD_OPT
+ ifeq (11,$(ALLOW_OPT_CODE_SIZE)$(OPT_CODE_SIZE))
+ OPTIMIZER = -Oz
+ else
+ OPTIMIZER = -O2
+ endif
+ ifdef MOZ_DEBUG_SYMBOLS
+diff --git a/coreconf/Linux.mk b/coreconf/Linux.mk
+--- coreconf/Linux.mk
++++ coreconf/Linux.mk
+@@ -1,15 +1,14 @@
+ #
+ # This Source Code Form is subject to the terms of the Mozilla Public
+ # License, v. 2.0. If a copy of the MPL was not distributed with this
+ # file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+ include $(CORE_DEPTH)/coreconf/UNIX.mk
+-include $(CORE_DEPTH)/coreconf/Werror.mk
+
+ #
+ # The default implementation strategy for Linux is now pthreads
+ #
+ ifneq ($(OS_TARGET),Android)
+ USE_PTHREADS = 1
+ endif
+
+@@ -135,17 +134,17 @@ endif
+ ifndef COMPILER_TAG
+ COMPILER_TAG := _$(CC_NAME)
+ endif
+
+ ifeq ($(USE_PTHREADS),1)
+ OS_PTHREAD = -lpthread
+ endif
+
+-OS_CFLAGS = $(DSO_CFLAGS) $(OS_REL_CFLAGS) $(ARCHFLAG) $(WARNING_CFLAGS) -pipe -ffunction-sections -fdata-sections -DLINUX -Dlinux -DHAVE_STRERROR
++OS_CFLAGS = $(DSO_CFLAGS) $(OS_REL_CFLAGS) $(ARCHFLAG) -pipe -ffunction-sections -fdata-sections -DLINUX -Dlinux -DHAVE_STRERROR
+ OS_LIBS = $(OS_PTHREAD) -ldl -lc
+
+ ifdef USE_PTHREADS
+ DEFINES += -D_REENTRANT
+ endif
+
+ ARCH = linux
+
+diff --git a/coreconf/UNIX.mk b/coreconf/UNIX.mk
+--- coreconf/UNIX.mk
++++ coreconf/UNIX.mk
+@@ -57,8 +57,10 @@ else
+ INSTALL = $(NSINSTALL)
+ INSTALL += -R
+ endif
+ endif
+
+ define MAKE_OBJDIR
+ if test ! -d $(@D); then rm -rf $(@D); $(NSINSTALL) -D $(@D); fi
+ endef
++
++include $(CORE_DEPTH)/coreconf/Werror.mk
+diff --git a/coreconf/WIN32.mk b/coreconf/WIN32.mk
+--- coreconf/WIN32.mk
++++ coreconf/WIN32.mk
+@@ -118,24 +118,24 @@ ifdef NS_USE_GCC
+ OPTIMIZER += -g
+ NULLSTRING :=
+ SPACE := $(NULLSTRING) # end of the line
+ USERNAME := $(subst $(SPACE),_,$(USERNAME))
+ USERNAME := $(subst -,_,$(USERNAME))
+ DEFINES += -DDEBUG -UNDEBUG -DDEBUG_$(USERNAME)
+ endif
+ else # !NS_USE_GCC
+- OS_CFLAGS += -W3 -nologo -D_CRT_SECURE_NO_WARNINGS \
+- -D_CRT_NONSTDC_NO_WARNINGS
++ WARNING_CFLAGS = -W3 -nologo -D_CRT_SECURE_NO_WARNINGS \
++ -D_CRT_NONSTDC_NO_WARNINGS
+ OS_DLLFLAGS += -nologo -DLL -SUBSYSTEM:WINDOWS
+ ifndef NSS_ENABLE_WERROR
+ NSS_ENABLE_WERROR = 1
+ endif
+ ifeq ($(NSS_ENABLE_WERROR),1)
+- OS_CFLAGS += -WX
++ WARNING_CFLAGS += -WX
+ endif
+ ifeq ($(_MSC_VER),$(_MSC_VER_6))
+ ifndef MOZ_DEBUG_SYMBOLS
+ OS_DLLFLAGS += -PDB:NONE
+ endif
+ endif
+ ifdef USE_DYNAMICBASE
+ OS_DLLFLAGS += -DYNAMICBASE
+diff --git a/coreconf/Werror.mk b/coreconf/Werror.mk
+--- coreconf/Werror.mk
++++ coreconf/Werror.mk
+@@ -1,14 +1,14 @@
+ #
+ # This Source Code Form is subject to the terms of the Mozilla Public
+ # License, v. 2.0. If a copy of the MPL was not distributed with this
+ # file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+-# This sets warning flags for unix-like operating systems.
++# This sets WARNING_CFLAGS for unix-like operating systems.
+
+ ifndef CC_NAME
+ CC_NAME := $(shell $(CC) -? 2>&1 >/dev/null | sed -e 's/:.*//;1q')
+ export CC_NAME
+ endif
+
+ ifndef WARNING_CFLAGS
+ # This tests to see if enabling the warning is possible before
+diff --git a/coreconf/command.mk b/coreconf/command.mk
+--- coreconf/command.mk
++++ coreconf/command.mk
+@@ -7,18 +7,18 @@
+ # Master "Core Components" default command macros; #
+ # can be overridden in <arch>.mk #
+ #######################################################################
+
+ AS = $(CC)
+ ASFLAGS += $(CFLAGS)
+ CCF = $(CC) $(CFLAGS)
+ LINK_DLL = $(LINK) $(OS_DLLFLAGS) $(DLLFLAGS) $(XLDFLAGS)
+-CFLAGS = $(OPTIMIZER) $(OS_CFLAGS) $(XP_DEFINE) $(DEFINES) $(INCLUDES) \
+- $(XCFLAGS)
++CFLAGS = $(OPTIMIZER) $(OS_CFLAGS) $(WARNING_CFLAGS) $(XP_DEFINE) \
++ $(DEFINES) $(INCLUDES) $(XCFLAGS)
+ PERL = perl
+ RANLIB = echo
+ TAR = /bin/tar
+ #
+ # For purify
+ #
+ NOMD_CFLAGS += $(OPTIMIZER) $(NOMD_OS_CFLAGS) $(XP_DEFINE) $(DEFINES) \
+ $(INCLUDES) $(XCFLAGS)
diff --git a/security/nss/files/patch-coreconf_command.mk b/security/nss/files/patch-coreconf_command.mk
index 4be941cef587..08dcdad87410 100644
--- a/security/nss/files/patch-coreconf_command.mk
+++ b/security/nss/files/patch-coreconf_command.mk
@@ -1,9 +1,11 @@
--- coreconf/command.mk Mon Oct 10 19:46:12 2005
+++ coreconf/command.mk Wed Jan 18 17:23:28 2006
-@@ -46,5 +46,5 @@
- LINK_DLL = $(LINK) $(OS_DLLFLAGS) $(DLLFLAGS)
- LINK_EXE = $(LINK) $(OS_LFLAGS) $(LFLAGS)
--CFLAGS = $(OPTIMIZER) $(OS_CFLAGS) $(XP_DEFINE) $(DEFINES) $(INCLUDES) \
-+CFLAGS += $(OPTIMIZER) $(OS_CFLAGS) $(XP_DEFINE) $(DEFINES) $(INCLUDES) \
- $(XCFLAGS)
+@@ -12,7 +12,7 @@ AS = $(CC)
+ ASFLAGS += $(CFLAGS)
+ CCF = $(CC) $(CFLAGS)
+ LINK_DLL = $(LINK) $(OS_DLLFLAGS) $(DLLFLAGS) $(XLDFLAGS)
+-CFLAGS = $(OPTIMIZER) $(OS_CFLAGS) $(WARNING_CFLAGS) $(XP_DEFINE) \
++CFLAGS += $(OPTIMIZER) $(OS_CFLAGS) $(WARNING_CFLAGS) $(XP_DEFINE) \
+ $(DEFINES) $(INCLUDES) $(XCFLAGS)
+ PERL = perl
RANLIB = echo