aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-12-31 10:58:52 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-12-31 10:58:52 +0000
commitc5c1b337f43e210e98049a25b67d4ea0d736c342 (patch)
treedd96f58535b5c43f67eb8af5f6e17fc5035661ff /security
parenta5b75f4afd4bbf91acbb7c957b626bce4d9f62dd (diff)
downloadports-c5c1b337f43e210e98049a25b67d4ea0d736c342.tar.gz
ports-c5c1b337f43e210e98049a25b67d4ea0d736c342.zip
- Add LICENSE
- Add NO_ARCH - Switch to options helpers - Fix WWW:
Notes
Notes: svn path=/head/; revision=404930
Diffstat (limited to 'security')
-rw-r--r--security/base/Makefile31
-rw-r--r--security/base/pkg-descr2
2 files changed, 14 insertions, 19 deletions
diff --git a/security/base/Makefile b/security/base/Makefile
index fae854201c5f..53e5e0d709d1 100644
--- a/security/base/Makefile
+++ b/security/base/Makefile
@@ -9,6 +9,9 @@ MASTER_SITES= SF/secureideas/BASE/${PORTNAME}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Basic Analysis and Security Engine - analyzing Snort alerts
+LICENSE= GPLv2 # or later
+LICENSE_FILE= ${WRKSRC}/docs/GPL
+
RUN_DEPENDS= ${ADODB_DIR}/adodb.inc.php:${PORTSDIR}/databases/adodb5 \
${LOCALBASE}/share/pear/Image/Graph.php:${PORTSDIR}/graphics/pear-Image_Graph \
${LOCALBASE}/share/pear/Mail.php:${PORTSDIR}/mail/pear-Mail \
@@ -18,44 +21,36 @@ USE_PHP= gd gettext pcre session zlib ctype
ADODB_DIR= ${LOCALBASE}/share/adodb
+NO_ARCH= yes
SUB_FILES= pkg-message
DOCS= docs/CHANGELOG docs/CREDITS docs/README docs/README.mssql \
docs/TODO docs/UPGRADE docs/GPL docs/base_faq.rtf
OPTIONS_DEFINE= MYSQL PGSQL PDF DOCS
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MMYSQL}
-USE_MYSQL= yes
-USE_PHP+= mysql
-.endif
-.if ${PORT_OPTIONS:MPGSQL}
-USES+= pgsql
-USE_PHP+= pgsql
-.endif
-.if ${PORT_OPTIONS:MPDF}
-RUN_DEPENDS+= ${LOCALBASE}/share/fpdf/fpdf.php:${PORTSDIR}/print/fpdf
-.endif
+MYSQL_USE= MYSQL=yes PHP=mysql
+PGSQL_USES= pgsql
+PGSQL_USE= PHP=pgsql
+PDF_RUN_DEPENDS=${LOCALBASE}/share/fpdf/fpdf.php:${PORTSDIR}/print/fpdf
do-build:
@${REINPLACE_CMD} -e 's,DBlib_path = "",DBlib_path = "${ADODB_DIR}",' \
${WRKSRC}/base_conf.php.dist
do-install:
- ${MKDIR} ${STAGEDIR}${PREFIX}/www/base/includes/templates/default
+ @${MKDIR} ${STAGEDIR}${PREFIX}/www/base/includes/templates/default
${INSTALL_DATA} ${WRKSRC}/*.php ${WRKSRC}/*.dist ${STAGEDIR}${PREFIX}/www/base
.for dir in admin help includes languages setup
- ${MKDIR} ${STAGEDIR}${PREFIX}/www/base/${dir}
+ @${MKDIR} ${STAGEDIR}${PREFIX}/www/base/${dir}
${INSTALL_DATA} ${WRKSRC}/${dir}/*.php ${STAGEDIR}${PREFIX}/www/base/${dir}
.endfor
.for dir in images sql styles
- ${MKDIR} ${STAGEDIR}${PREFIX}/www/base/${dir}
+ @${MKDIR} ${STAGEDIR}${PREFIX}/www/base/${dir}
${INSTALL_DATA} ${WRKSRC}/${dir}/* ${STAGEDIR}${PREFIX}/www/base/${dir}
.endfor
-post-install:
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/security/base/pkg-descr b/security/base/pkg-descr
index 9af3407125ff..eea4af510e79 100644
--- a/security/base/pkg-descr
+++ b/security/base/pkg-descr
@@ -8,4 +8,4 @@ system, so that you as the security admin can decide what and how much
information each user can see. It also has a simple to use, web-based
setup program for people not comfortable with editing files directly.
-WWW: http://secureideas.sourceforge.net/
+WWW: http://secureideas.sourceforge.net/