aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorMichael Moll <mmoll@FreeBSD.org>2015-05-08 09:21:47 +0000
committerMichael Moll <mmoll@FreeBSD.org>2015-05-08 09:21:47 +0000
commit5c42eedac5161026578de57b7f085e6351600357 (patch)
treee48fd3efd809126956730b84ea93f9847ad73529 /security
parent570f6b46850db9fe12000f530e6f2486d31f0b89 (diff)
downloadports-5c42eedac5161026578de57b7f085e6351600357.tar.gz
ports-5c42eedac5161026578de57b7f085e6351600357.zip
security/ruby-camellia: unbreak build for ruby 2.1+
PR: 199267 Differential Revision: https://reviews.freebsd.org/D2476 Submitted by: Yoshisato Yanagisawa <osho@pcc-software.org> (maintainer) Approved by: swills (mentor)
Notes
Notes: svn path=/head/; revision=385743
Diffstat (limited to 'security')
-rw-r--r--security/ruby-camellia/Makefile11
-rw-r--r--security/ruby-camellia/files/patch-ext_camellia-rb.c31
-rw-r--r--security/ruby-camellia/files/patch-setup.rb11
-rw-r--r--security/ruby-camellia/pkg-descr2
4 files changed, 47 insertions, 8 deletions
diff --git a/security/ruby-camellia/Makefile b/security/ruby-camellia/Makefile
index 0bfce8a53cde..81a346f5fa7e 100644
--- a/security/ruby-camellia/Makefile
+++ b/security/ruby-camellia/Makefile
@@ -12,6 +12,9 @@ DIST_SUBDIR= ruby
MAINTAINER= osho@pcc-software.org
COMMENT= Ruby extension library which implements Camellia encryption
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/License.txt
+
USE_RUBY= yes
USE_RUBY_SETUP= yes
@@ -32,10 +35,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${RUBY_MODDOCDIR}/
.endfor
-.include <bsd.port.pre.mk>
-
-.if ${RUBY_VER} >= 2.1
-BROKEN= Does not build
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/ruby-camellia/files/patch-ext_camellia-rb.c b/security/ruby-camellia/files/patch-ext_camellia-rb.c
new file mode 100644
index 000000000000..6403e4d418c9
--- /dev/null
+++ b/security/ruby-camellia/files/patch-ext_camellia-rb.c
@@ -0,0 +1,31 @@
+--- ext/camellia-rb.c.orig 2009-01-26 13:53:51.000000000 +0900
++++ ext/camellia-rb.c
+@@ -111,7 +111,7 @@
+ /*
+ # encryption method
+ */
+-static VALUE encrypt(VALUE self, VALUE args)
++static VALUE camellia_encrypt(VALUE self, VALUE args)
+ {
+ camelliaObject *camellia;
+ unsigned char *data;
+@@ -147,7 +147,7 @@
+ /*
+ # decryption method
+ */
+-static VALUE decrypt(VALUE self,VALUE args)
++static VALUE camellia_decrypt(VALUE self,VALUE args)
+ {
+ camelliaObject *camellia;
+ unsigned char *data;
+@@ -537,8 +537,8 @@
+ //rb_define_singleton_method(cCamellia, "new", s_new, 0);
+ rb_define_private_method(cCamellia, "initialize", set_key, 1);
+ //rb_define_method(cCamellia, "set_key", set_key, 1);
+- rb_define_method(cCamellia, "encrypt", encrypt, 1);
+- rb_define_method(cCamellia, "decrypt", decrypt, 1);
++ rb_define_method(cCamellia, "encrypt", camellia_encrypt, 1);
++ rb_define_method(cCamellia, "decrypt", camellia_decrypt, 1);
+ rb_define_method(cCamellia, "cfb_salt", cfb_salt, 1);
+ rb_define_method(cCamellia, "cfb_encrypt", cfb_encrypt, 1);
+ rb_define_method(cCamellia, "cfb_decrypt", cfb_decrypt, 1);
diff --git a/security/ruby-camellia/files/patch-setup.rb b/security/ruby-camellia/files/patch-setup.rb
new file mode 100644
index 000000000000..3a332ee42c24
--- /dev/null
+++ b/security/ruby-camellia/files/patch-setup.rb
@@ -0,0 +1,11 @@
+--- setup.rb.orig 2009-01-20 10:46:11.000000000 +0900
++++ setup.rb
+@@ -785,7 +785,7 @@
+ else
+ require 'rbconfig'
+ end
+- ::Config::CONFIG
++ ::RbConfig::CONFIG
+ end
+
+ def initialize(ardir_root, config)
diff --git a/security/ruby-camellia/pkg-descr b/security/ruby-camellia/pkg-descr
index 1077521343d3..458d3bdc0561 100644
--- a/security/ruby-camellia/pkg-descr
+++ b/security/ruby-camellia/pkg-descr
@@ -2,4 +2,4 @@ This is a Camellia package for Ruby. Camellia engine is implemented in "C".
Supported key length : 128bit/192bit/256bit
Supported modes of operation : ECB/CFB/CBC
-WWW: http://info.isl.ntt.co.jp/crypt/eng/camellia/index.html
+WWW: http://info.isl.ntt.co.jp/crypt/eng/camellia/index.html