aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorMark Murray <markm@FreeBSD.org>1996-07-29 19:57:58 +0000
committerMark Murray <markm@FreeBSD.org>1996-07-29 19:57:58 +0000
commit2d686b625997193a91a9dcbe01ab38827bb7b4c8 (patch)
tree06b9e683d474c0a1ef23322006abf4dd98599b91 /security
parentf97e2484372a7a4754ff59a4df3ad06ffab42bb0 (diff)
downloadports-2d686b625997193a91a9dcbe01ab38827bb7b4c8.tar.gz
ports-2d686b625997193a91a9dcbe01ab38827bb7b4c8.zip
SSLeay version 0.6.2.
This implementation has been built with Our ((actually its own but in our source tree) DES library and our MD{45}. You will need to link your SSL code with -ldes and -lmd. Are you happy now, Torsten? ;-)
Notes
Notes: svn path=/head/; revision=3448
Diffstat (limited to 'security')
-rw-r--r--security/openssl-beta/Makefile20
-rw-r--r--security/openssl-beta/distinfo2
-rw-r--r--security/openssl-beta/pkg-comment2
-rw-r--r--security/openssl-beta/pkg-descr29
-rw-r--r--security/openssl-beta/pkg-plist93
-rw-r--r--security/openssl/Makefile20
-rw-r--r--security/openssl/distinfo2
-rw-r--r--security/openssl/pkg-comment2
-rw-r--r--security/openssl/pkg-descr29
-rw-r--r--security/openssl/pkg-plist93
10 files changed, 80 insertions, 212 deletions
diff --git a/security/openssl-beta/Makefile b/security/openssl-beta/Makefile
index 4c8b06877e22..c6821064be4c 100644
--- a/security/openssl-beta/Makefile
+++ b/security/openssl-beta/Makefile
@@ -1,17 +1,19 @@
# New ports collection makefile for: Eric Young's SSL/Crypto Library
-# Version required: 0.5.1b
-# Date created: 24 February 1996
+# Version required: 0.6.2
+# Date created: 1 July 1996
# Whom: markm
#
-# $Id: Makefile,v 1.1.1.1 1996/03/03 21:32:34 markm Exp $
+# $Id$
#
-DISTNAME= SSLeay-0.5.1b
-PKGNAME= SSLeay-0.5.1b
-CATEGORIES+= devel security
-MASTER_SITES= psych.psy.uq.oz.au:/pub/Crypto/SSL/
+DISTNAME= SSLeay-0.6.2
+CATEGORIES+= devel security
+MASTER_SITES= psych.psy.uq.oz.au:/pub/Crypto/SSL/
-# Crypto stuff - therefore...
-NO_PACKAGE= YES
+HAS_CONFIGURE= yes
+CONFIGURE_SCRIPT= util/FreeBSD.sh
+MAKEFILE= Makefile.FreeBSD
+
+NO_PACKAGE= "Cryptography"
.include <bsd.port.mk>
diff --git a/security/openssl-beta/distinfo b/security/openssl-beta/distinfo
index e200d179fdcd..cc013c1797d5 100644
--- a/security/openssl-beta/distinfo
+++ b/security/openssl-beta/distinfo
@@ -1 +1 @@
-MD5 (SSLeay-0.5.1b.tar.gz) = 74df21c1ef5c58c5faa7b1d385181d56
+MD5 (SSLeay-0.6.2.tar.gz) = f1e0ac84b4fc07dd6e7cb060d7ca790d
diff --git a/security/openssl-beta/pkg-comment b/security/openssl-beta/pkg-comment
index b096649e0b36..6e2d7f75b37d 100644
--- a/security/openssl-beta/pkg-comment
+++ b/security/openssl-beta/pkg-comment
@@ -1 +1 @@
-SSL and crypto library (Excluding DES)
+SSL and crypto library (Excluding DES, MD2 and MD5)
diff --git a/security/openssl-beta/pkg-descr b/security/openssl-beta/pkg-descr
index 260dd40f8375..bb479fbb02d1 100644
--- a/security/openssl-beta/pkg-descr
+++ b/security/openssl-beta/pkg-descr
@@ -9,7 +9,6 @@ libcrypto.a:
actually logically part of it. It includes routines for the following:
RC4 encryption,
IDEA encryption - 4 different modes, ecb, cbc, cfb and ofb.
- MD5 and MD2 message digest algorithms,
SHA (SHA-0) and SHA-1 message digest algorithms,
RSA encryption/decryption/key generation. There is no limit
on the number of bits.
@@ -21,30 +20,4 @@ libcrypto.a:
(The DES routines, while a part if this source distribution
are not included in the compiled package, as they are part
of the base FreeBSD secure/ distribution)
-
-Programs in this package include
- enc - a general encryption program that can encrypt/decrypt using
- one of 17 different cipher/mode combinations. The
- input/output can also be converted to/from base64
- ascii encoding.
- dgst - a generate message digesting program that will generate
- message digests for any of md2, md5, sha (sha-0) or sha-1.
- asn1parse - parse and display the structure of an asn1 encoded
- binary file.
- rsa - Manipulate RSA private keys.
- dh - Manipulate Diffie-Hellman parameter files.
- crl - Manipulate certificate revocation lists.
- x509 - Manipulate x509 certificates, self-sign certificates.
- req - Manipulate PKCS#10 certificate requests and also
- generate certificate requests.
- genrsa - Generates an arbitrary sized RSA private key.
- gendh - Generates a set of Diffie-Hellman parameters, the prime
- will be a strong prime.
- ca - Create certificates from PKCS#10 certificate requests.
- This program also maintains a database of certificates
- issued.
- verify - Check x509 certificate signatures.
- speed - Benchmark SSLeay's ciphers.
- s_server - A test SSL server.
- s_client - A test SSL client.
- s_time - Benchmark SSL performance of SSL server programs.
+ (MD2 and MD5 are also not compiled as FreeBSD has its own).
diff --git a/security/openssl-beta/pkg-plist b/security/openssl-beta/pkg-plist
index f3c9ef018b2b..6f3bc4d8bed7 100644
--- a/security/openssl-beta/pkg-plist
+++ b/security/openssl-beta/pkg-plist
@@ -1,77 +1,36 @@
-@cwd /usr/local
bin/ssleay
-bin/makecert
-bin/der_chop
-bin/speed
-bin/ca
-bin/enc
-bin/dgst
-bin/verify
-bin/asn1parse
-bin/crl
-bin/rsa
-bin/x509
-bin/genrsa
-bin/gendh
-bin/pem2bin
-bin/bin2pem
-bin/s_server
-bin/s_client
-bin/s_filter
-bin/req
-bin/dh
-bin/errstr
-bin/hashdir
-bin/s_time
-bin/md2
-bin/md5
-bin/sha
-bin/sha1
-bin/des
-bin/des3
-bin/idea
-bin/rc4
-bin/des-cbc
-bin/des-ede-cbc
-bin/des-ede3-cbc
-bin/des-ecb
-bin/des-ede
-bin/des-ede3
-bin/des-cfb
-bin/des-ede-cfb
-bin/des-ede3-cfb
-bin/des-ofb
-bin/des-ede-ofb
-bin/des-ede3-ofb
-bin/idea-cbc
-bin/idea-ecb
-bin/idea-cfb
-bin/idea-ofb
-lib/ssleay.conf
+etc/ssleay.conf
+lib/libssl.a
+@exec ranlib %D/%F
lib/libcrypto.a
@exec ranlib %D/%F
-lib/libssl.a
+lib/libRSAglue.a
@exec ranlib %D/%F
-include/md2.h
-include/md5.h
+include/asn1.h
+include/txt_db.h
+include/stack.h
+include/ssl.h
include/sha.h
-include/rc4.h
-include/idea.h
-include/bn.h
include/rsa.h
-include/dh.h
-include/buffer.h
-include/stack.h
-include/lhash.h
+include/rc4.h
+include/rc2.h
include/rand.h
-include/err.h
-include/objects.h
-include/envelope.h
-include/pem.h
include/pkcs7.h
-include/x509.h
-include/asn1.h
+include/pem.h
+include/objects.h
include/meth.h
+include/md5.h
+include/md2.h
+include/lhash.h
+include/idea.h
+include/err.h
+include/envelope.h
+include/dsa.h
+include/dh.h
+include/cryptoall.h
+include/crypto.h
include/conf.h
-include/txt_db.h
-include/ssl.h
+include/buffer.h
+include/bn.h
+include/asn1_mac.h
+include/x509.h
diff --git a/security/openssl/Makefile b/security/openssl/Makefile
index 4c8b06877e22..c6821064be4c 100644
--- a/security/openssl/Makefile
+++ b/security/openssl/Makefile
@@ -1,17 +1,19 @@
# New ports collection makefile for: Eric Young's SSL/Crypto Library
-# Version required: 0.5.1b
-# Date created: 24 February 1996
+# Version required: 0.6.2
+# Date created: 1 July 1996
# Whom: markm
#
-# $Id: Makefile,v 1.1.1.1 1996/03/03 21:32:34 markm Exp $
+# $Id$
#
-DISTNAME= SSLeay-0.5.1b
-PKGNAME= SSLeay-0.5.1b
-CATEGORIES+= devel security
-MASTER_SITES= psych.psy.uq.oz.au:/pub/Crypto/SSL/
+DISTNAME= SSLeay-0.6.2
+CATEGORIES+= devel security
+MASTER_SITES= psych.psy.uq.oz.au:/pub/Crypto/SSL/
-# Crypto stuff - therefore...
-NO_PACKAGE= YES
+HAS_CONFIGURE= yes
+CONFIGURE_SCRIPT= util/FreeBSD.sh
+MAKEFILE= Makefile.FreeBSD
+
+NO_PACKAGE= "Cryptography"
.include <bsd.port.mk>
diff --git a/security/openssl/distinfo b/security/openssl/distinfo
index e200d179fdcd..cc013c1797d5 100644
--- a/security/openssl/distinfo
+++ b/security/openssl/distinfo
@@ -1 +1 @@
-MD5 (SSLeay-0.5.1b.tar.gz) = 74df21c1ef5c58c5faa7b1d385181d56
+MD5 (SSLeay-0.6.2.tar.gz) = f1e0ac84b4fc07dd6e7cb060d7ca790d
diff --git a/security/openssl/pkg-comment b/security/openssl/pkg-comment
index b096649e0b36..6e2d7f75b37d 100644
--- a/security/openssl/pkg-comment
+++ b/security/openssl/pkg-comment
@@ -1 +1 @@
-SSL and crypto library (Excluding DES)
+SSL and crypto library (Excluding DES, MD2 and MD5)
diff --git a/security/openssl/pkg-descr b/security/openssl/pkg-descr
index 260dd40f8375..bb479fbb02d1 100644
--- a/security/openssl/pkg-descr
+++ b/security/openssl/pkg-descr
@@ -9,7 +9,6 @@ libcrypto.a:
actually logically part of it. It includes routines for the following:
RC4 encryption,
IDEA encryption - 4 different modes, ecb, cbc, cfb and ofb.
- MD5 and MD2 message digest algorithms,
SHA (SHA-0) and SHA-1 message digest algorithms,
RSA encryption/decryption/key generation. There is no limit
on the number of bits.
@@ -21,30 +20,4 @@ libcrypto.a:
(The DES routines, while a part if this source distribution
are not included in the compiled package, as they are part
of the base FreeBSD secure/ distribution)
-
-Programs in this package include
- enc - a general encryption program that can encrypt/decrypt using
- one of 17 different cipher/mode combinations. The
- input/output can also be converted to/from base64
- ascii encoding.
- dgst - a generate message digesting program that will generate
- message digests for any of md2, md5, sha (sha-0) or sha-1.
- asn1parse - parse and display the structure of an asn1 encoded
- binary file.
- rsa - Manipulate RSA private keys.
- dh - Manipulate Diffie-Hellman parameter files.
- crl - Manipulate certificate revocation lists.
- x509 - Manipulate x509 certificates, self-sign certificates.
- req - Manipulate PKCS#10 certificate requests and also
- generate certificate requests.
- genrsa - Generates an arbitrary sized RSA private key.
- gendh - Generates a set of Diffie-Hellman parameters, the prime
- will be a strong prime.
- ca - Create certificates from PKCS#10 certificate requests.
- This program also maintains a database of certificates
- issued.
- verify - Check x509 certificate signatures.
- speed - Benchmark SSLeay's ciphers.
- s_server - A test SSL server.
- s_client - A test SSL client.
- s_time - Benchmark SSL performance of SSL server programs.
+ (MD2 and MD5 are also not compiled as FreeBSD has its own).
diff --git a/security/openssl/pkg-plist b/security/openssl/pkg-plist
index f3c9ef018b2b..6f3bc4d8bed7 100644
--- a/security/openssl/pkg-plist
+++ b/security/openssl/pkg-plist
@@ -1,77 +1,36 @@
-@cwd /usr/local
bin/ssleay
-bin/makecert
-bin/der_chop
-bin/speed
-bin/ca
-bin/enc
-bin/dgst
-bin/verify
-bin/asn1parse
-bin/crl
-bin/rsa
-bin/x509
-bin/genrsa
-bin/gendh
-bin/pem2bin
-bin/bin2pem
-bin/s_server
-bin/s_client
-bin/s_filter
-bin/req
-bin/dh
-bin/errstr
-bin/hashdir
-bin/s_time
-bin/md2
-bin/md5
-bin/sha
-bin/sha1
-bin/des
-bin/des3
-bin/idea
-bin/rc4
-bin/des-cbc
-bin/des-ede-cbc
-bin/des-ede3-cbc
-bin/des-ecb
-bin/des-ede
-bin/des-ede3
-bin/des-cfb
-bin/des-ede-cfb
-bin/des-ede3-cfb
-bin/des-ofb
-bin/des-ede-ofb
-bin/des-ede3-ofb
-bin/idea-cbc
-bin/idea-ecb
-bin/idea-cfb
-bin/idea-ofb
-lib/ssleay.conf
+etc/ssleay.conf
+lib/libssl.a
+@exec ranlib %D/%F
lib/libcrypto.a
@exec ranlib %D/%F
-lib/libssl.a
+lib/libRSAglue.a
@exec ranlib %D/%F
-include/md2.h
-include/md5.h
+include/asn1.h
+include/txt_db.h
+include/stack.h
+include/ssl.h
include/sha.h
-include/rc4.h
-include/idea.h
-include/bn.h
include/rsa.h
-include/dh.h
-include/buffer.h
-include/stack.h
-include/lhash.h
+include/rc4.h
+include/rc2.h
include/rand.h
-include/err.h
-include/objects.h
-include/envelope.h
-include/pem.h
include/pkcs7.h
-include/x509.h
-include/asn1.h
+include/pem.h
+include/objects.h
include/meth.h
+include/md5.h
+include/md2.h
+include/lhash.h
+include/idea.h
+include/err.h
+include/envelope.h
+include/dsa.h
+include/dh.h
+include/cryptoall.h
+include/crypto.h
include/conf.h
-include/txt_db.h
-include/ssl.h
+include/buffer.h
+include/bn.h
+include/asn1_mac.h
+include/x509.h