aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2000-02-12 10:37:45 +0000
committerKris Kennaway <kris@FreeBSD.org>2000-02-12 10:37:45 +0000
commitb6974210ce7a1346616a3640d2a85343d8419b3b (patch)
treed9f17ddd568f094f06a7f7c5a51bc2746f822176 /security
parent9d59123ac1e3d3cd73802fc38422398c7cba9be9 (diff)
downloadports-b6974210ce7a1346616a3640d2a85343d8419b3b.tar.gz
ports-b6974210ce7a1346616a3640d2a85343d8419b3b.zip
USE_OPENSSL
Submitted by: Jim Bloom <bloom@acm.org>
Notes
Notes: svn path=/head/; revision=25684
Diffstat (limited to 'security')
-rw-r--r--security/stunnel/Makefile14
-rw-r--r--security/stunnel/files/patch-ac89
2 files changed, 93 insertions, 10 deletions
diff --git a/security/stunnel/Makefile b/security/stunnel/Makefile
index 7680c84a1eee..eb73bfe9fcdd 100644
--- a/security/stunnel/Makefile
+++ b/security/stunnel/Makefile
@@ -16,14 +16,7 @@ MASTER_SITES= http://opensores.thebunker.net/pub/mirrors/stunnel/ \
MAINTAINER= martti.kuparinen@ericsson.com
-BUILD_DEPENDS= openssl:${PORTSDIR}/security/openssl
-LIB_DEPENDS= crypto.1:${PORTSDIR}/security/openssl \
- ssl.1:${PORTSDIR}/security/openssl
-RUN_DEPENDS= openssl:${PORTSDIR}/security/openssl
-
-.if defined(USA_RESIDENT) && ${USA_RESIDENT} == YES
-LIB_DEPENDS= rsaref.2:${PORTSDIR}/security/rsaref
-.endif
+USE_OPENSSL= RSA
GNU_CONFIGURE= yes
MAN8= stunnel.8
@@ -31,6 +24,11 @@ MAN8= stunnel.8
cert:
@(cd ${WRKSRC}; make cert)
+post-patch:
+ ${SED} -e 's,%%LOCALBASE%%,${LOCALBASE},' ${WRKSRC}/configure > ${WRKSRC}/configure~
+ ${MV} ${WRKSRC}/configure~ ${WRKSRC}/configure
+ ${CHMOD} a+x ${WRKSRC}/configure
+
post-build:
@${ECHO} ""
@${ECHO} "********************************************************************"
diff --git a/security/stunnel/files/patch-ac b/security/stunnel/files/patch-ac
index fbf70ab9dc15..e8d267b7fe69 100644
--- a/security/stunnel/files/patch-ac
+++ b/security/stunnel/files/patch-ac
@@ -1,5 +1,5 @@
---- configure.orig Tue Jul 13 10:35:02 1999
-+++ configure Sat Sep 11 18:25:14 1999
+--- configure.orig Tue Jul 13 09:35:02 1999
++++ configure Thu Feb 3 15:38:42 2000
@@ -932,14 +932,14 @@
echo "$ac_t""no" 1>&6
fi
@@ -35,3 +35,88 @@
else
echo "$ac_t""no" 1>&6
+@@ -1053,53 +1053,6 @@
+ fi
+ rm -f conftest*
+
+-echo $ac_n "checking for SSL directory""... $ac_c" 1>&6
+-echo "configure:1058: checking for SSL directory" >&5
+-for dir in /usr/local/ssl /usr/lib/ssl /usr/pkg /usr/local /usr; do
+- ssldir="$dir"
+- if test -f "$dir/include/openssl/ssl.h"; then
+- cat >> confdefs.h <<\EOF
+-#define HAVE_OPENSSL 1
+-EOF
+-
+- break
+- fi
+- if test -f "$dir/include/ssl.h"; then
+- break
+- fi
+-done
+-echo "$ac_t""$ssldir" 1>&6
+-
+-cat >> confdefs.h <<EOF
+-#define ssldir "$ssldir"
+-EOF
+-
+-CFLAGS="$CFLAGS -I$ssldir/include"
+-LIBS="$LIBS -L$ssldir/lib -lssl -lcrypto"
+-
+-echo $ac_n "checking for RSAref library""... $ac_c" 1>&6
+-echo "configure:1082: checking for RSAref library" >&5
+-saved_LIBS="$LIBS"
+-LIBS="$saved_LIBS -lRSAglue -lrsaref"
+-cat > conftest.$ac_ext <<EOF
+-#line 1086 "configure"
+-#include "confdefs.h"
+-
+-int main() {
+-
+-; return 0; }
+-EOF
+-if { (eval echo configure:1093: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest; then
+- rm -rf conftest*
+- echo "$ac_t""yes" 1>&6;
+-else
+- echo "configure: failed program was:" >&5
+- cat conftest.$ac_ext >&5
+- rm -rf conftest*
+- echo "$ac_t""no" 1>&6; LIBS="$saved_LIBS"
+-fi
+-rm -f conftest*
+-
+ # AC_HEADER_DIRENT
+ # AC_HEADER_STDC
+ # AC_HEADER_SYS_WAIT
+@@ -1266,6 +1219,30 @@
+ echo "$ac_t""no" 1>&6
+ fi
+ done
++
++echo $ac_n "checking for SSL directory""... $ac_c" 1>&6
++echo "configure:1058: checking for SSL directory" >&5
++for dir in /usr %%LOCALBASE%% /usr/local/ssl /usr/lib/ssl /usr/pkg; do
++ ssldir="$dir"
++ if test -f "$dir/include/openssl/ssl.h"; then
++ cat >> confdefs.h <<\EOF
++#define HAVE_OPENSSL 1
++EOF
++
++ break
++ fi
++ if test -f "$dir/include/ssl.h"; then
++ break
++ fi
++done
++echo "$ac_t""$ssldir" 1>&6
++
++cat >> confdefs.h <<EOF
++#define ssldir "$ssldir"
++EOF
++
++CFLAGS="$CFLAGS -I$ssldir/include"
++LIBS="$LIBS -L$ssldir/lib -lssl -lcrypto \${EXTRA_SSL_LIBS}"
+
+
+ trap '' 1 2 15