aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorChris D. Faulhaber <jedgar@FreeBSD.org>2000-02-22 20:43:47 +0000
committerChris D. Faulhaber <jedgar@FreeBSD.org>2000-02-22 20:43:47 +0000
commite73674c6f6efb20713b9f5fa69ba35c198cc1135 (patch)
treef4004240c9b8a9020c0567c20de1c2232c756ec7 /security
parentc07b4c9c050a5f67b47d01375c0d6f5744c1ac21 (diff)
downloadports-e73674c6f6efb20713b9f5fa69ba35c198cc1135.tar.gz
ports-e73674c6f6efb20713b9f5fa69ba35c198cc1135.zip
Initial import of ITS4:
ITS4 is a tool that statically scans C and C++ source code for potential security vulnerabilities.
Notes
Notes: svn path=/head/; revision=26159
Diffstat (limited to 'security')
-rw-r--r--security/its4/Makefile35
-rw-r--r--security/its4/distinfo1
-rw-r--r--security/its4/files/patch-aa25
-rw-r--r--security/its4/files/patch-ab11
-rw-r--r--security/its4/pkg-comment1
-rw-r--r--security/its4/pkg-descr14
-rw-r--r--security/its4/pkg-plist4
7 files changed, 91 insertions, 0 deletions
diff --git a/security/its4/Makefile b/security/its4/Makefile
new file mode 100644
index 000000000000..ecc4b0eed81a
--- /dev/null
+++ b/security/its4/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: its4
+# Version required: 1.0
+# Date created: 21 February 2000
+# Whom: Chris D. Faulhaber <jedgar@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+DISTNAME= its4-1.0
+CATEGORIES= security
+MASTER_SITES= ""
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= jedgar@FreeBSD.org
+
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --prefix=${PREFIX} \
+ --datadir=${PREFIX}/share/its4
+MAN1= its4.1
+RESTRICTED= "For non-commercial use only"
+
+.include <bsd.port.pre.mk>
+
+.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
+IGNORE= "The source to this port may not be automatically fetched due to licensing restrictions. You MUST fetch the source manually at: http://www.rstcorp.com/its4/download.html. Once ${DISTFILES} has been downloaded, move it to ${DISTDIR} and then restart this build"
+.endif
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/LICENCE ${PREFIX}/share/its4
+ @${ECHO}
+ @${ECHO} "This software is for non-commercial use only. See"
+ @${ECHO} "${PREFIX}/share/its4/LICENCE for details."
+ @${ECHO}
+
+.include <bsd.port.post.mk>
diff --git a/security/its4/distinfo b/security/its4/distinfo
new file mode 100644
index 000000000000..b8a17c25817b
--- /dev/null
+++ b/security/its4/distinfo
@@ -0,0 +1 @@
+MD5 (its4-1.0.tgz) = bcf4c815b8d6d114e98b78e8db03141d
diff --git a/security/its4/files/patch-aa b/security/its4/files/patch-aa
new file mode 100644
index 000000000000..ea3d12bfaf12
--- /dev/null
+++ b/security/its4/files/patch-aa
@@ -0,0 +1,25 @@
+--- configure.orig Mon Feb 21 11:53:17 2000
++++ configure Mon Feb 21 23:25:16 2000
+@@ -18,7 +18,7 @@
+ DATADIR=
+ MANDIR=
+ PROGNAME=its4
+-OPTIMIZATION=-O3
++OPTIMIZATION=${CFLAGS}
+ QUIET=
+ CC=
+ INSTALLPROG=
+@@ -192,11 +192,12 @@
+ ###### Check for snprintf()
+ printf %s "Checking for snprintf()... " 1>&5
+ cat >tmp.c <<EOF
++#include <stdio.h>
+ #include <string.h>
+ int main()
+ {
+ char buf[12];
+- snprintf(buf, "%s", 2, "foof");
++ snprintf(buf, 2, "%s", "foof");
+ }
+ EOF
+ if `${CC} tmp.c 2>/dev/null`; then
diff --git a/security/its4/files/patch-ab b/security/its4/files/patch-ab
new file mode 100644
index 000000000000..6e3c9cbf2a0b
--- /dev/null
+++ b/security/its4/files/patch-ab
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Mon Feb 21 11:53:17 2000
++++ Makefile.in Tue Feb 22 09:16:02 2000
+@@ -24,7 +24,7 @@
+ $(INSTALL) vulns.i4d $(INSTALL_DATADIR)
+ $(INSTALL) -d $(INSTALL_MANDIR)/man1
+ $(INSTALL) docs/its4.1 $(INSTALL_MANDIR)/man1/
+- echo "Installation complete."
++ @echo "Installation complete."
+
+ # Dependencies generated by g++ -M *.C | dependstrip >> Makefile.in
+ config.o: config.C config.H vulninfo.H formatter.H vulndb.H dict.H fatal.H query.H strpool.H
diff --git a/security/its4/pkg-comment b/security/its4/pkg-comment
new file mode 100644
index 000000000000..179157c291f1
--- /dev/null
+++ b/security/its4/pkg-comment
@@ -0,0 +1 @@
+Tool to scan C/C++ source for potential vulnerabilities
diff --git a/security/its4/pkg-descr b/security/its4/pkg-descr
new file mode 100644
index 000000000000..dfa7bf37bdae
--- /dev/null
+++ b/security/its4/pkg-descr
@@ -0,0 +1,14 @@
+ITS4 is a tool that statically scans C and C++ source code for
+potential security vulnerabilities. It is a command-line tool that
+works across Unix environments (hopefully) and will also work under
+Windows with CygWin installed. ITS4 scans code, looking for function
+calls that are potentially dangerous. For some calls, ITS4 tries to
+perform some code analysis to determine how risky the call is. In
+each case, ITS4 provides a problem report, including a short
+description of the potential problem and suggestions on how to fix the
+code.
+
+WWW: http://www.rstcorp.com/its4/
+
+- Chris D. Faulhaber
+ <jedgar@FreeBSD.org>
diff --git a/security/its4/pkg-plist b/security/its4/pkg-plist
new file mode 100644
index 000000000000..ca1367d8a8c0
--- /dev/null
+++ b/security/its4/pkg-plist
@@ -0,0 +1,4 @@
+bin/its4
+share/its4/vulns.i4d
+share/its4/LICENCE
+@dirrm share/its4