aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorMark Murray <markm@FreeBSD.org>1999-03-17 11:52:46 +0000
committerMark Murray <markm@FreeBSD.org>1999-03-17 11:52:46 +0000
commit79d0b12ad5cb29857584d41571835dc67f740156 (patch)
treeb676fb0358c193e0a35419c74e3e836a7a791217 /security
parent00d94c509d3f8c03822ceb194c7eff6b25f8d7b6 (diff)
downloadports-79d0b12ad5cb29857584d41571835dc67f740156.tar.gz
ports-79d0b12ad5cb29857584d41571835dc67f740156.zip
Fix filenames so that this can co-exist with PGP 2.*
Notes
Notes: svn path=/head/; revision=17264
Diffstat (limited to 'security')
-rw-r--r--security/pgp5/Makefile4
-rw-r--r--security/pgp5/files/patch-ab21
-rw-r--r--security/pgp5/files/patch-ac30
-rw-r--r--security/pgp5/files/patch-ad11
-rw-r--r--security/pgp5/pkg-plist18
-rw-r--r--security/pgp6/Makefile4
-rw-r--r--security/pgp6/pkg-plist18
7 files changed, 84 insertions, 22 deletions
diff --git a/security/pgp5/Makefile b/security/pgp5/Makefile
index 47de900dd2a5..e9b0c0c9d179 100644
--- a/security/pgp5/Makefile
+++ b/security/pgp5/Makefile
@@ -5,7 +5,7 @@
# Date created: 10 Feb 1998
# Whom: markm
#
-# $Id: Makefile,v 1.25 1999/01/15 14:23:31 scrappy Exp $
+# $Id: Makefile,v 1.26 1999/03/11 21:47:15 scrappy Exp $
#
DISTNAME= pgp50i
@@ -24,7 +24,7 @@ WRKSRC= ${WRKDIR}/${DISTNAME}/src
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX}
RESTRICTED= "Crypto"
-MAN1= pgp.1 pgpe.1 pgpk.1 pgps.1 pgpv.1
+MAN1= pgp5.1 pgpe.1 pgpk.1 pgps.1 pgpv.1
MAN5= pgp.cfg.5
MAN7= pgp-integration.7 pgp-intro.7
diff --git a/security/pgp5/files/patch-ab b/security/pgp5/files/patch-ab
new file mode 100644
index 000000000000..87fb6140a662
--- /dev/null
+++ b/security/pgp5/files/patch-ab
@@ -0,0 +1,21 @@
+--- man/Makefile.in.orig Sat Feb 7 21:54:57 1998
++++ man/Makefile.in Sun Feb 14 14:56:52 1999
+@@ -6,11 +6,16 @@
+ # $Id: Makefile.in,v 1.3.2.4.2.1 1997/08/27 03:57:21 quark Exp $
+ #
+
+-MAN1=pgp.1 pgpe.1 pgpk.1 pgps.1 pgpv.1
++# Change this to pgp5 if you want old and new versions in parallel
++INSTPGP=pgp5
++MAN1=$(INSTPGP).1 pgpe.1 pgpk.1 pgps.1 pgpv.1
+ MAN5=pgp.cfg.5
+ MAN7=pgp-integration.7 pgp-intro.7
+
+-install::
++$(INSTPGP).1: pgp.1
++ $(LN_S) ${.OODATE} ${.TARGET}
++
++install:: $(INSTPGP).1
+ if test 'x$(MAN1)' != x; then \
+ if test ! -d $(DESTDIR)$(mandir)/man1; then \
+ mkdir -p $(DESTDIR)$(mandir)/man1; \
diff --git a/security/pgp5/files/patch-ac b/security/pgp5/files/patch-ac
new file mode 100644
index 000000000000..2ff7c777ef86
--- /dev/null
+++ b/security/pgp5/files/patch-ac
@@ -0,0 +1,30 @@
+--- apps/pgp/Makefile.in.orig Sat Feb 7 21:54:56 1998
++++ apps/pgp/Makefile.in Sun Feb 14 13:59:04 1999
+@@ -7,7 +7,9 @@
+ #
+
+ PROG = pgp
+-INSTALLPROGS = $(PROG)
++# Set this to "pgp5" if you want the keep old and new versions in parallel
++INSTPGP = pgp5
++INSTALLPROGS =
+
+ COMMON=../common
+ LOCALINCLUDES = -I$(COMMON) -I$(srcdir)/$(COMMON)
+@@ -21,11 +23,11 @@
+
+ install:: $(PROG)
+ ( \
+- $(INSTALL) -m 755 pgp $(DESTDIR)$(bindir); \
++ $(INSTALL) -m 755 pgp $(DESTDIR)$(bindir)/$(INSTPGP); \
+ cd $(DESTDIR)$(bindir); \
+ $(RM) pgpe pgps pgpv pgp_old; \
+- $(LN_S) pgp pgpe; \
+- $(LN_S) pgp pgps; \
+- $(LN_S) pgp pgpv; \
+- $(LN_S) pgp pgp_old \
++ $(LN_S) $(INSTPGP) pgpe; \
++ $(LN_S) $(INSTPGP) pgps; \
++ $(LN_S) $(INSTPGP) pgpv; \
++ $(LN_S) $(INSTPGP) pgp_old \
+ )
diff --git a/security/pgp5/files/patch-ad b/security/pgp5/files/patch-ad
new file mode 100644
index 000000000000..666681c7bc8d
--- /dev/null
+++ b/security/pgp5/files/patch-ad
@@ -0,0 +1,11 @@
+--- lib/ttyui/pgpKBUnix.c.orig Sun Feb 14 15:07:55 1999
++++ lib/ttyui/pgpKBUnix.c Sun Feb 14 15:08:32 1999
+@@ -167,7 +167,7 @@
+ int kbOpenKbd(int flags, int InBatchmode) {
+ int lkbFD = -1;
+
+- if(!InBatchmode) {
++ if(!InBatchmode && 0) {
+ if((lkbFD = open("/dev/tty", flags)) < 0) {
+ lkbFD = STDIN_FILENO;
+ }
diff --git a/security/pgp5/pkg-plist b/security/pgp5/pkg-plist
index cf3c2db9185e..a5acc8a38345 100644
--- a/security/pgp5/pkg-plist
+++ b/security/pgp5/pkg-plist
@@ -1,14 +1,14 @@
-bin/pgp
-bin/pgpe
-bin/pgps
-bin/pgpv
-bin/pgp_old
+bin/pgp5
+@exec ln -fs %D/%F %B/pgpe
+@exec ln -fs %D/%F %B/pgps
+@exec ln -fs %D/%F %B/pgpv
+@exec ln -fs %D/%F %B/pgp_old
+@unexec rm %B/pgpe
+@unexec rm %B/pgps
+@unexec rm %B/pgpv
+@unexec rm %B/pgp_old
bin/pgpk
lib/libbn.a
-@exec ranlib %D/%F
lib/libpgp.a
-@exec ranlib %D/%F
lib/libpgptty.a
-@exec ranlib %D/%F
lib/libsimple.a
-@exec ranlib %D/%F
diff --git a/security/pgp6/Makefile b/security/pgp6/Makefile
index 47de900dd2a5..e9b0c0c9d179 100644
--- a/security/pgp6/Makefile
+++ b/security/pgp6/Makefile
@@ -5,7 +5,7 @@
# Date created: 10 Feb 1998
# Whom: markm
#
-# $Id: Makefile,v 1.25 1999/01/15 14:23:31 scrappy Exp $
+# $Id: Makefile,v 1.26 1999/03/11 21:47:15 scrappy Exp $
#
DISTNAME= pgp50i
@@ -24,7 +24,7 @@ WRKSRC= ${WRKDIR}/${DISTNAME}/src
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX}
RESTRICTED= "Crypto"
-MAN1= pgp.1 pgpe.1 pgpk.1 pgps.1 pgpv.1
+MAN1= pgp5.1 pgpe.1 pgpk.1 pgps.1 pgpv.1
MAN5= pgp.cfg.5
MAN7= pgp-integration.7 pgp-intro.7
diff --git a/security/pgp6/pkg-plist b/security/pgp6/pkg-plist
index cf3c2db9185e..a5acc8a38345 100644
--- a/security/pgp6/pkg-plist
+++ b/security/pgp6/pkg-plist
@@ -1,14 +1,14 @@
-bin/pgp
-bin/pgpe
-bin/pgps
-bin/pgpv
-bin/pgp_old
+bin/pgp5
+@exec ln -fs %D/%F %B/pgpe
+@exec ln -fs %D/%F %B/pgps
+@exec ln -fs %D/%F %B/pgpv
+@exec ln -fs %D/%F %B/pgp_old
+@unexec rm %B/pgpe
+@unexec rm %B/pgps
+@unexec rm %B/pgpv
+@unexec rm %B/pgp_old
bin/pgpk
lib/libbn.a
-@exec ranlib %D/%F
lib/libpgp.a
-@exec ranlib %D/%F
lib/libpgptty.a
-@exec ranlib %D/%F
lib/libsimple.a
-@exec ranlib %D/%F