aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-09-12 08:51:36 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-09-12 08:51:36 +0000
commitd2d7c7dc32c1ebdc152f349e1e12d55ec09ddea2 (patch)
treeafe5eaaeae3489149a6532702b6dff8fa7acbf29 /security
parent54d25ae10ed00198829fb49c5f9555886fb071de (diff)
downloadports-d2d7c7dc32c1ebdc152f349e1e12d55ec09ddea2.tar.gz
ports-d2d7c7dc32c1ebdc152f349e1e12d55ec09ddea2.zip
- Respect NOPORTDOCS/NOPORTEXAMPLES
Approved by: portmgr (erwin)
Notes
Notes: svn path=/head/; revision=220362
Diffstat (limited to 'security')
-rw-r--r--security/rid/Makefile10
-rw-r--r--security/rid/pkg-plist6
-rw-r--r--security/sslwrap/Makefile7
-rw-r--r--security/sslwrap/pkg-plist6
4 files changed, 16 insertions, 13 deletions
diff --git a/security/rid/Makefile b/security/rid/Makefile
index 2aedbb3d6737..f0b9ec7303c5 100644
--- a/security/rid/Makefile
+++ b/security/rid/Makefile
@@ -18,16 +18,18 @@ COMMENT= Configurable remote distributed denial of service tool detector
ALL_TARGET= rid
+DOCS= README
+
pre-configure:
- @${REINPLACE_CMD} -e 's:config.txt:${PREFIX}/etc/rid.conf:g' \
+ @${REINPLACE_CMD} -e 's:config.txt:${PREFIX}/etc/rid.conf.sample:g' \
${WRKSRC}/config.h
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/rid ${PREFIX}/sbin
- @${INSTALL_DATA} ${WRKSRC}/config.txt ${PREFIX}/etc/rid.conf
+ @${INSTALL_DATA} ${WRKSRC}/config.txt ${PREFIX}/etc/rid.conf.sample
.if !defined(NOPORTDOCS)
- @${MKDIR} ${PREFIX}/share/doc/rid
- @${INSTALL_MAN} ${WRKSRC}/README ${PREFIX}/share/doc/rid
+ ${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${DOCS:S,^,${WRKSRC}/,} ${DOCSDIR}/
.endif
.include <bsd.port.mk>
diff --git a/security/rid/pkg-plist b/security/rid/pkg-plist
index 14b8c0f2731b..5da7a3f59df0 100644
--- a/security/rid/pkg-plist
+++ b/security/rid/pkg-plist
@@ -1,5 +1,5 @@
@comment $FreeBSD$
sbin/rid
-etc/rid.conf
-share/doc/rid/README
-@dirrm share/doc/rid
+etc/rid.conf.sample
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
diff --git a/security/sslwrap/Makefile b/security/sslwrap/Makefile
index c860ce2e5a1f..ecef0aa4bbed 100644
--- a/security/sslwrap/Makefile
+++ b/security/sslwrap/Makefile
@@ -19,6 +19,8 @@ USE_OPENSSL= YES
WRKSRC= ${WRKDIR}/${PORTNAME}${PORTVERSION:S/.//g}
+DOCS= README docs.html
+
post-patch:
${REINPLACE_CMD} -e \
's/SSL_OP_NON_EXPORT_FIRST/SSL_OP_CIPHER_SERVER_PREFERENCE/g' \
@@ -30,9 +32,8 @@ post-patch:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/sslwrap ${PREFIX}/bin/sslwrap
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/sslwrap
- ${INSTALL_DATA} ${WRKSRC}/README ${WRKSRC}/docs.html \
- ${PREFIX}/share/doc/sslwrap
+ ${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${DOCS:S,^,${WRKSRC}/,} ${DOCSDIR}/
.endif
.include <bsd.port.mk>
diff --git a/security/sslwrap/pkg-plist b/security/sslwrap/pkg-plist
index 5c59136ab67d..a0efe95be4ce 100644
--- a/security/sslwrap/pkg-plist
+++ b/security/sslwrap/pkg-plist
@@ -1,4 +1,4 @@
bin/sslwrap
-share/doc/sslwrap/README
-share/doc/sslwrap/docs.html
-@dirrm share/doc/sslwrap
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/docs.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%